Allow HTML Temp preferences change to "Original HTML" and "Always show attachments inline" whenever "Show HTML" is invoked

If you suddenly cannot receive any more emails

Please read the notes on the latest two most common causes of problems!

Please click here!

This red box disappears when you click on the X in the top right corner.

  • 7.0 on TB 91.2.0 (32 bit) on Windows 8.1 (64 bit):


    With View Message Body As = Plain Text, and Allow HTML Temp preferences set to Plain Text (with "Always show attachments inline" deselected) display is as intended (plain text) until Show HTML is used once. Thereafter any message with HTML content shows as HTML. Preferences have been reset per subject of this thread, although status popup menu still shows Plain Text as selected option.

  • graba

    Approved the thread.
  • Please, uninstall the addon. Restart Thunderbird and than re-install the addon in version 7.0. Some months ago, I've seen your problem here, too. After re-installing the addon the problem was gone and I'm not able to reproduce it again. In theory there is no obvious reason for this problem. Maybe it's a cache problem or some interference between some addons.

  • Hi,

    I just had the same problem since a couple of weeks. Indeed removing and re-installing the addon seems to help.

  • Indeed removing and re-installing the addon seems to help.

    That's weird. Unfortunately, there are sometimes cache problems during development because the commands to clear the caches (also according to developer resources) do not have a 100% guaranteed effect. In addition, since Thunderbird 78 there seems to have been interactions between addons that can hardly be explained plausibly.

  • 1) 91.3.1 (64-bit) (on macos)


    2)


    3) where can I find this "error log"?

  • 3) where can I find this "error log"?

    Menu Tools → Developer Tools → Error console


    You could install and use the following addon development version, which writes a lot of debug lines like "AHT: ........." in the error console. They could help me to understand what happens. The really important lines in case of errors do not have this "AHT: ......". They will show only the error messeage and (on the right) the name of the javascript file, in which the error occurs.


    If the problem occurs, copy all the entry lines out of the error console and send it to me, please.


    Version 7.0.1 with console debug enabled: allow-html-temp_20211125-095729.xpi