Unscharfe Schrift im TB 102, Webrender nicht mehr deaktivierbar?

  • Hallo zusammen,


    Wer unter Windows Clear Type abgeschaltet hat, wird das vermutlich auch im Thunderbird so haben wollen.

    Mit dem Einzug von Webrender gab es unter TB 91 den Workaround, gfx.webrender.force-disabled auf true zu setzen.

    Das wurde auch hier diskutiert: Thunderbird 91.0 veröffentlicht


    Im TB 102 funktioniert das bei mir nicht mehr, die Schrift ist wieder schwammig.

    Ist Webrender tatsächlich nicht mehr deaktivierbar? Falls ja, gibt es irgendeinen anderen Trick, eine scharfe Schrift zu erreichen?

  • Ja, ist dort auch so. Wenn ich das richtig verstanden habe, kommt das durch die neue Rendering Engine WebRender, die man zuvor noch deaktivieren konnte und jetzt offenbar nicht mehr (wie es im Firefox auch schon der Fall ist).

  • Gibt es Einstellungen der Grafikkarte / Monitor o.ä. die Einfluss nehmen könnte?

    Ich habe das Problem nicht, daher ist alles nur spekulativ.

    Eigentlich müsste das, wenn ein Serienproblem, auch hier häufiger aufschlagen.

    Gruß, Bastler

  • Nein, fast alle Programme richten sich nach dem systemweiten Abschalten von Clear Type. Die Mozilla-Produkte leider nicht.

    Ich erinnere mich an ein bugzilla-Ticket, in dem das auch ausführlich erörtert wurde, aber das endete dann mit der Empfehlung, das o.g. gfx.webrender-Setting zu setzen. Das mit 102 keine Wirkung mehr hat.


    Ich vermute, nun ist WebRender tatsächlich gesetzt und es gibt keinen offiziellen Weg drumherum. Daher meine Frage, vielleicht kennt jemand doch noch einen Weg.

  • for what it’s worth: diverse webrender-settings (und "ähnliche tipps" via reddit) haben bei mir nicht geholfen, bin deswegen wieder zur 91.12.0 zurück. :(

  • Das ist für mich keine Option, denn so ist man ewig in der 91er-Version gefangen.

    Ich finde das zwar unschön, aber wenn es keinen Workaround gibt, dann ist das halt so. Im Firefox muss man sich damit ja auch schon abfinden.

  • Im TB 102 funktioniert das bei mir nicht mehr, die Schrift ist wieder schwammig.

    Ich bin zwar kein Betroffener und habe unter Linux einige Möglichkeiten mehr zur Verfügung (s. u.), aber grundsätzlich gilt: für eine optimale Darstellung ist der 'dpi'-Wert an die Auflösung und die geometrischen Abmessungen des Bildschirms anzupassen!


    Dann werden diese Tricks mit Kantenglättung usw. nicht mehr so stark sichtbar. Für ein besseres Verständnis:

    B. Mueller


  • Habe das gleiche Problem (Schrift in der Ordner-und Mailliste ist wieder unscharf) nach dem Update auf 102.2.2. Ist vielleicht eine dumme Frage- aber kann man diesen Bug irgendwo melden?


    Danke

    Polarigel

  • Folgende Lösung funktioniert auf meinem System (Windows 10 Pro, Thunderbird 102.2.2)


    1. Thunderbird-->Einstellungen--> Allgemein-->Konfiguration bearbeiten.
    2. Nach "gfx.text.disable-aa" suchen und von "false" auf "true" stellen.
    3. Thunderbird neu starten.


    Die Lösung habe ich beim Stöbern in Bugzilla-Reports entdeckt (https://bugzilla.mozilla.org/show_bug.cgi?id=1734912).


    Wie lange sie funktioniert, steht in den Sternen. Mein eigener Bug-Report (https://bugzilla.mozilla.org/show_bug.cgi?id=1791326) wurde nämlich mit dem Kommentar "Webrender can't be disabled anymore." abgeschlossen.