Posts by jorgk3

    Hmm, sicher kein BB-spezifischer Bug sondern ein Problem des TB-Codes, den wir benutzen. Zum Thema "inbox corruption in 102" gibt es ja viele Artikel, allerdings nicht mehr in jüngster Zeit seit 102.2. Ich schlage vor, mal die Inbox zu reparieren.

    Können die Linux-Benutzer bitte einmal mitteilen, wie das Thunderbird-Compose-Window gestartet wurde. Dazu das Dokument verschicken und dann `ps aux | grep thunder` in einer Shell-Window absetzen. Ich sehe:

    Bash
    /usr/lib/thunderbird/thunderbird -remote "xfeDoCommand(composeMessage,attachment='file:///home/jorgk/Desktop/huhu.txt',subject='noname')"

    Es funktioniert aber auch:

    Bash
    /usr/lib/thunderbird/thunderbird -compose "attachment='file:///home/jorgk/Desktop/huhu.txt',subject=noname)"

    Ich frage deshalb, weil die erste Version mit Thunderbird 102 nicht geht, die zweite jedoch schon.


    Ergänzung: Dieser Bug und dieser Quell-Code aus LibreOffice. Wie man sieht, verwenden die -compose und -remote. Ersteres geht noch, letzteres nicht.

    Wie gesagt, wenn ich die Suchordner neu anlege, sind sie nach einem TB-Neustart wieder weg.


    Ist ganz offensichtlich ein Bug. Die alten Suchordner sind weg. Ich erwäge nach 20+ Jahren TB-Nutzung ernsthaft den Wechsel auf Outlook.

    Also, den Such-Ordner, den ich für Kommentar #16, dessen Fragen Du übrigens nicht beantwortet hast, angelegt habe, ist immer noch da und funktioniert auch noch.


    Da auch anderen Benutzer hier Schwierigkeiten haben, wäre es ober-Affen-geil einen reproduzierbaren Fall zu haben, den man dann analysieren und reparieren kann. Soweit gibt es zwar einige Beschwerden, aber nichts Greifbares.


    P.S.: Outlook hat keine Such-Ordner, da stellt sich das Problem nicht, oder irre ich mich?

    bei mir funktioniert das ohne Probleme.

    Hab noch mal die Fehlerbeschreibung gelesen. Dort heißt, das Versenden aus LO als PDF geht nicht mehr, die E-Mail wird zwar erzeugt, aber es fehlt der Anhang. Das geht bei Dir? Oder hast Du nur ODF probiert oder vom Desktop zu schicken. Ich hab noch nicht einmal das konfigurieren können, naja, eben mit einer anderen als der Distributionsversion.

    Zwei Dinge: In dem zitierten Reddit-Artikel heißt weiter unten (Zitat):

    Same issue here. Couldn't even recreate them. The folder would show a list of blank emails (all fields empty, not possible to open the emails). And after another restart, the virtual folder was gone again.

    Diese Person hat dasselbe Problem wie #8 beschrieben, nach Wieder-Einrichtung ist die Liste leer.


    Dein Post #17 gibt aber noch einen interessanten Einblick. Hinter dem Such-Ordner verbirgt sich nicht nur virtualFolders.dat, sondern auch eine MSF-Datei, offenbar die Datenbank, aus der die Nachrichten angezeigt werden. Wie wir alle wissen, hat TB 102.x haufenweise MSF-Dateien kaputt gemacht. Die leere Nachrichten-Liste spricht dafür. Ich schlage also vor, die zu dem Such-Ordner gehörige MSF-Datei zu löschen und danach neu anzufangen.

    Hallo liebe Linux-Leute, eben las ich diesen Post in einer Newsgruppe (Zitat):

    ---

    Ich habe hier LibreOffice (LO) und TB 102 unter Linux.


    Bisher konnte ich in LO prima ein Dokument schreiben und das dann

    mittels "Datei/Senden/PDF als Email" an den als Standard-Mailer

    eingestellten TB übergeben, wobei ein .odf in ein .pdf verwandelt wurde

    und als Anhang einer neuen leeren Mail erschien.


    Letzteres geht nun nicht mehr. Eine neue leere Mail mit dem

    Standard-Absender wird erzeugt und geöffnet, aber ohne Anhang. Zu Fuß

    geht das natürlich, aber ich hab mich an die Abkürzung gewöhnt.

    ---


    Ich habe Betterbird 102 mal als Default-Mail-Programm installiert, da ging es auch nicht. Aber vielleicht habe ich was falsch gemacht. Aus einem Ordner ging "Send To > Mail Recipient" auch nicht.


    Es gibt doch hier einige, die mit Linux unterwegs sind ( Susi to visit, Feuerdrache).

    Hmm, dann habe ich das falsch gelesen, es geht nicht um "gruppierte Ordner" (unified folders/inbox) sondern wirklich um Suchordner, d.h. nach einer Suche speichert man das Ergebnis als virtuellen Ordner. Hier geht es noch, ich habe mal einen Such-Ordner angelegt für "nicht" in Betreff:

    Wenn es bei Dir nicht geht, bitte folgende Fragen beantworten, damit ich das nachvollziehen kann:

    1. Der Suchordner basiert auf einem oder mehreren Ordnern?
    2. Der/diese ist/sind lokale Ordner oder IMAP-Ordner?
    3. Ist/Sind der/die Ordner sonst OK, d.h. Inhalt wird angezeigt, MSF ist nicht verschwunden oder kaputt, d.h. der Ordner muss nicht repariert werden?
    4. Was ist denn die Suche genau? Etwas Einfaches oder Kompliziertes?
    5. Kannst Du mal virtualFolders.dat publizieren oder mir schicken. Für meinen "Nicht"-Ordner sieht der Eintrag so aus, s.u.
    Code
    uri=mailbox://jorgk%40MMMMM.com@mail.XXXXX.de/0%20AA%20Thunderbird%20Mail%20DE/Nicht
    scope=mailbox://jorgk%40MMMMM.com@mail.XXXXX.de/0%20AA%20Thunderbird%20Mail%20DE
    terms=AND (subject,contains,nicht)
    searchOnline=false

    Ich bin ziemlich sicher, dass das Feature im Prinzip noch geht, aber irgendwas ist da kaputt gegangen.

    Wie dem auch sein, dass mit Content-Type: application/pdf oder Content-Type: application/octet-stream interessiert mich auch.

    Ich habe das mal selbst ausprobiert: In einem nicht-synchronisierten Ordner habe ich zwei Nachrichten gespeichert, mit den zwei verschiedenen Typen: Resultat: Beide öffnen sich.


    Es wird also tatsächlich an der Größe der Nachricht liegen, setze daher bitte einmal die Limits hoch, wie in #20 beschrieben.


    Zusatz: Mir ist noch eingefallen: Du sagst, TB 68 ging noch, TB 78 nicht mehr. Zwischen diesen zwei Versionen wurde EnigMail in TB integriert und die Option mail.server.default.mime_parts_on_demand von true auf false geändert. Wenn Du keine OpenPGP in TB machst, schalte bitte wieder auf true. Das führt dazu, dann nicht die gesammte Nachricht vom Server geholt wird und die Teile separat im Cache gespeichert werden.


    Ich sehe gerade, dass a) Erhöhen der Limits und b) diese Option genau hier beschrieben werden, Zitat:

    I'll guess that the reporter is not using offline store. If so, setting mail.server.default.mime_parts_on_demand to true may fix it as described here: bug 1673093 comment 13. If that doesn't help, adjustment of the memory cache sizes as described in part 2 may be needed to save big attachments.

    Ah, das mit den 19,8 MB hatte ich nicht gelesen. Sicher, muss man hoch-skalieren, um die ganze Nachricht mit Codierung zu berücksichtigen. Als weiteres Experiment könnte man die Cache-Größen hochsetzen:


    Mach mal browser.cache.memory.max_entry_size auf 40000 und browser.cache.memory.capacity auf 8 * 40000 = 320000 von hier.


    Ist ein bisschen Schade, dass es nicht funktioniert, wenn die Nachricht größer als der Cache ist. Eigentlich sollte es dann auch gehen, nur langsamer.


    Wie dem auch sein, dass mit Content-Type: application/pdf oder Content-Type: application/octet-stream interessiert mich auch.

    Es gehen jedoch nur teilweise die pdfs aus Anlagen nicht auf.

    Aha, ein Hinweis!


    Schau doch bitte mal den Quelltext der E-Mail an und vergleiche die MIME-Header derer, die aufgehen, mit denen, die nicht aufgehen. Das ist leichter als es klingt. Suche nach:

    Content-Type: application/pdf oder Content-Type: application/octet-stream.


    Es gab da mal diesen Bug, den habe ich selbst repariert. Kann sein, dass es danach wieder kaputt gegangen ist. Der Bug beschreibt Deine Situation, in der die Synchronisation ausgeschaltet ist. In dem Dunstkreis gab es noch haufenweise Bugs, hier nur ein paar: 453805, 517796.


    Wenn es wirklich an octet-stream liegen sollte, ist das sicher nicht zu schwer zu reparieren.

    Hat zwischenzeitlich jemand eine Lösung für das Problem (pdfs lassen sich nicht öffnen)?

    Es hat sicher keiner geguckt, denn der Bug tritt nur unter bestimmten Bedingungen auf.


    So klären wäre:

    1. Ist der IMAP-Ordner für Offline-Benutzung lokal synchronisiert? Wenn nicht, warum nicht?
    2. Falls nein, handelt es sich um sehr große PDFs (> 25MB), die Cache-Grenze sprengen?
    3. Ist sonst an irgendwelchen IMAP-Prefs gedreht worden?

    Ich sehe gerade, so ähnlich schrieb ich schon in #10. Bitte mal hier zu lesen anfangen. Wenn von Dir jetzt nicht mehr Rückmeldung kommt, gibt es auch keinen Fortschritt.