Allow HTML Temp - Add-on to allow HTML (only) temporarily

By clicking on the "Show HTML" button of the "Allow HTML Temp" extension, a currently displayed message will immediately be formatted once (if HTML code is included). This makes life easier for all users who, by default, display messages only as plain text or with simplified HTML.

Numerous users activate the mode Plain Text or Simplified HTML in the menu View → Message Body as. This provides more security in everyday life, since not all HTML commands are executed. The disadvantage of this is that many messages (e.g., newsletters from publishers or well-known discounters) are barely legible.

If you now trust the author of the message and assume that the HTML code of the message does not harm you, you probably always want to have the message formatted. Thunderbird itself requires that you first activate the mode Original HTML via the menu View → Message Body as and then deactivate it manually. This is simply uncomfortable.

By clicking on the "Show HTML" button of the "Allow HTML Temp" extension, a currently displayed message is immediately formatted once (if HTML code is included). This makes life easier for all users who, by default, display messages only as Plain Text or with simplified HTML.

1 Download

The download can be found on "ATN (addons.thunderbird.net)".

2 Function example of Allow HTML Temp

Install the “Allow HTML Temp” extension as you would for extensions.

Note

When the extension is installed and Thunderbird is restarted, you must first add the Show HTML button to the Main Toolbar. To do this, right-click on the Main Toolbar and select Customize... . The selection of available buttons will appear and you can drag the Show HTML button from the selection to the toolbar.

Incidentally, the button is displayed in the selection dialog of the available buttons depending on its current setting. That means, it can appear there in any of the (adjustable) variants:

https://www.thunderbird-mail.de/lexicon/entry/226-allow-html-temp-add-on-to-allow-html-only-temporarily/
In the menu View → Message Body as, activate the mode Plain Text and, for example, display the newsletter of a discounter.

Newsletter displayed as Plain Text:

Since the newsletter is only displayed as Plain Text, you can now click on the Show HTML button (if you trust the sender). If you also hold down the Ctrl key when clicking on the button, external contents are also loaded for this message.

Note

If you allow external graphics for the selected message, this is will be valid forever for this message! This is the default behavior of Thunderbird. HTML, however, is only allowed once.

The newsletter will appear completely HTML-formatted after clicking on Show HTML:

If you also hold down the Ctrl key while clicking on the button or have selected the corresponding options in the settings dialog of the addon, the external contents (graphics, style sheets, etc.) will also be

https://www.thunderbird-mail.de/lexicon/entry/226-allow-html-temp-add-on-to-allow-html-only-temporarily/
As soon as you subsequently select a different message, it will automatically return to its default appearance ("Plain Text" or "simplified HTML"). You do not have to manually switch back to Plain Text.

3 Possible locations for the button

The following buttons are available on request:

- The button in the tab bar in the title bar of the main window ("Tab bar")

- The button in the main toolbar:

- The button in the header area ("Message header toolbar"):

4 Different appearance of the button icons

https://www.thunderbird-mail.de/lexicon/entry/226-allow-html-temp-add-on-to-allow-html-only-temporarily/
Depending on the setting for the button, the icon and the label of the button change. By the way, the symbol is based on the official “HTML 5 Icon”:

- Original HTML (plus external content):

- Original HTML:

- Simple HTML:

- Plain Text:

5 Options in the Settings dialog

The settings can be accessed via the entry in the Add-on Manager or via menu Tools → Add-on Options.

The add-on “Allow HTML Temp” in the list of add-ons installed in Add-ons Manager:

The classic settings dialog up to Thunderbird 60:
6 Status bar display

In the status bar at the bottom of the window, you can see the selected default HTML mode (Original HTML, Simplified HTML or Plain Text). By right-clicking on the element, a context menu opens in which you can switch the HTML mode. The options are the same as those of the program itself. For feeds, the context menu is omitted because it does not work reliably (although there are options there too, but they can only be selected in the program's main menu).

Status bar element (for e-mail with context menu):

Status bar element on feeds:

https://www.thunderbird-mail.de/lexicon/entry/226-allow-html-temp-add-on-to-allow-html-only-temporarily/
7 Keyboard commands

7.1 Pure keyboard command

As of version 4.3 of the add-on, a new, stand-alone keyboard command has been introduced. With the key combination \texttt{Ctrl} + \texttt{Alt} + \texttt{F5} (or with macOS \texttt{Cmd} + \texttt{Alt} + \texttt{F5}) you call the function of the button (without mouse click). All options from the settings dialog are taken into account as well as when clicking on the button.

7.2 Mouse click plus keystroke

In contrast to the keyboard command, the function of the button changes if you hold down certain buttons while clicking the button. The following list uses \texttt{Ctrl}. For macOS, this is \texttt{Cmd}.

- (simple) Click: It will do \textbf{what is set in the addons options}.
- Click + \texttt{Shift}: \textbf{Plain Text} is displayed
- Click + \texttt{Ctrl} + \texttt{Shift}: \textbf{Simplified HTML} is displayed
- Click + \texttt{Ctrl}: \textbf{Original HTML and external content} will be shown / loaded

8 Reset settings to default in Config Editor

If you used the "Allow HTML Temp" add-on, the associated or necessary hidden settings in Thunderbird were changed by this add-on according to your selection in the options of the add-on. If you no longer have the add-on installed, or if you want to return to Thunderbird default settings for other reasons, you can do this at any time using the \textbf{Config Editor} (About:config).

You have to check and reset the following settings in the \textbf{Config Editor}:

Thunderbirds own/internal settings:

- \texttt{mailnews.message_display.disable_remote_image}
- \texttt{mail.inline_attachments}
- \texttt{javascript.enabled}

Add-on specific settings:

- \texttt{extensions.allowhtmltemp.ButtonFunction}
- \texttt{extensions.allowhtmltemp.ForceRemoteContent}
- \texttt{extensions.allowhtmltemp.JavaScriptTemp}
- \texttt{extensions.allowhtmltemp.InlineAttachmentsTemp}

9 Localization
9.1 Supplied languages

The add-on has been translated into about 24 languages so far. But some translations are not completely up to date.

9.2 Create and improve localization

Please, use the support forum to provide additional localizations or to improve localizations.

10 Version history

10.1 Version 7.0

- Supports Thunderbird 91. *

10.2 Version 6.3.7

- Small internal changes to follow Thunderbird, so that the add-on options can now be accessed via the wrench icon in the add-ons manager.

10.3 Version 6.3.0

- Remove the option to disable JavaScript because of possible failures. The pref will be reset to Thunderbirds default and a prompt with information text will be shown.

10.4 Version 6.2.1

- The button of the add-on can now also be used for feed messages to allow their HTML.

10.5 Version 6.1.1

- Fix issue in options dialog (dark text on dark background) with some lightweight themes (may be the related issue is a Thunderbird bug)

10.6 Version 6.1.0

- Re-implemented the button in messge header toolbar (customization was removed by Thunderbird core changes in Version 78.*)
- Improved Icons for Light and Dark Mode

10.7 Version 6.0.2

- Improvements for Dark-Mode in Thunderbird 78

10.8 Version 6.0

- Upgraded for Thunderbird 78 using the WindowListener-API
• Improvements for Dark-Mode in Thunderbird 78

10.9 Version 5.7.8

• Last Version for Thunderbird 68 including fixed locales (Version 5.7.7 failed completely for most locales)

10.10 Version 5.7.3

• Adjustments for the upcoming Thunderbird 68. This mainly affects the settings dialog, in which there is no "Cancel" button anymore. Settings are now necessarily saved immediately when changing, so that a "Cancel" button no longer makes sense. It has been tested so far with Thunderbird 67 Beta 3 to be prepared for Thunderbird 68.

10.11 Version 5.4.3

• Bug fix: In previous versions Allow HTML Temp could lead to misrepresented special characters in emails in a certain situation, as the character encoding was no longer recognized correctly when external content was allowed.

10.12 Version 5.4.2

• Icon of the button is now displayed again in the Customize dialog of the toolbar in Thunderbird 60 Beta and newer.

10.13 Version 5.4.1

• Supports Thunderbird versions 58+ (add-on settings dialog).
• The changes in the previous version 5.1, in combination with Enigmail, resulted in double passphrase queries when displaying PGP/MIME encrypted emails. This is now avoided by internal code changes related to HTML recognition.

10.14 Version 5.1

• Correct HTML recognition and thus (previously missing) activation of the button for encrypted messages. If messages are encrypted via S/MIME, this will now work reliably. If messages are encrypted via PGP/MIME, the button will always be activated as a "workaround", since in this case it can not be detected whether an HTML part is present in the message.

10.15 Version 5.0.2

• Further improved display of the symbols in "Lightweight Themes"

10.16 Version 5.0.1

• Improved display of icons when using (dark) "lightweight themes"
10.17 Version 5.0

- The main function of the "Show HTML" button can now be changed in the options. This is no longer fixed as "Original HTML", but can alternatively be changed to "Plain Text" or "Simplified HTML".
- Additional keyboard shortcut Ctrl + Shift + click "Show HTML" now leads directly to "Simplified HTML".
- More customized and differentiated symbols:

Depending on the setting for the button, different icons are now displayed on the button.
Depending on the setting for the button, the label of the button is adjusted.

10.18 Version 4.3.2

- Fixed an issue that caused the button icon not to be displayed if certain theme add-ons were used for Thunderbird.

10.19 Version 4.3.1

- SVG icons are now used from Thunderbird 52. * and newer. The icons were replaced by completely different ones.
- A new option in the Preferences dialog now allows you to load / view the external content of the selected message by simply clicking on the Show HTML button. (So far, this was only possible with simultaneous pressing of the key Ctrl or Cmd.
- In addition, there is now a keyboard command Ctrl + Alt + F5 or Cmd + Alt + F5, which performs exactly the function of the button (including the settings of the button considered). Thus, users can use the function "Show HTML" (including the options) completely without mouse, when navigating and viewing the e-mails. Of course, unlike the click on the button you can not press additional buttons to change the function.
- An error in all versions prior to version 4.3.1 has been fixed. The error resulted in the "Show HTML" button in the headers area (ie in the message header) not being displayed (or hidden) if the button had not been inserted in the main toolbar.

10.20 Version 4.0

- New (SVG) icons for Thunderbird from version 57+
- Modification of an internal JS function on the recommendation of the AMO team

11 See also

- Allow HTML Temp - Ein Add-on, um HTML (nur) kurzzeitig zu erlauben
- Support forum for "Allow HTML Temp"

[https://www.thunderbird-mail.de/lexicon/entry/226-allow-html-temp-add-on-to-allow-html-only-temporarily/](https://www.thunderbird-mail.de/lexicon/entry/226-allow-html-temp-add-on-to-allow-html-only-temporarily/)