Posts by ta7h12

    Ich finde die Darstellung der Mailgrösse n kB nach wie vor besser als die in kB und MB. Mit was kann man das hinkriegen, wo es size-in-kB ab TB 60 nicht mehr gibt?

    Thomas

    • Thunderbird-Version: 52.2.1 (32-Bit) auf Win7-64prof
    • Lightning-Version: 5.4.2.1
    • Betriebssystem + Version: Win7-64prof
    • Eingesetzte Antivirensoftware: WIndows Defender
    • Firewall (Betriebssystem-intern/Externe Software): Windows-intern

    TB-Erweiterungen:

    SoGO-Connector 31.0.3

    CategoryManager 2 2.04

    als Server: ownCloud 9.1 auf Ubuntu 16.04


    Hallo,

    Ich stelle immer mal wieder Synchronisationsprobleme der Adressen fest. Wenn man erstmal fetgestellt hat, DASS ein Problem da ist, dann kann man es auch beheben. Aber hat jemand einen hübschen Trick entwickelt, das automatisch/halbautomatisch zu testen? Ungefähr: jeder User/Client schreibt beim Start in eine Pseudoadressen einen Zeitstempel.

    Dann könnte man das von irgendeiner Ecke des Netzwerks auf einen Blick prüfen. Für Tipps wäre ich dankbar.
    Thomas

    Ich häng mich mal an diesen alten Thread an:


    Meine Arbeitsgruppe hat einerseits individuelle Signaturen, möchte aber auch auf Aktuelles hinweisen.
    Im Moment müssen jedes Mal alle Signaturen neu erstellt werden, wenn sich "Aktuelles" ändert.

    Ich stelle mir vor, dass man in die individuellen Footer sowas wie ein "include"-Kommando einbaut, so dass nur jeweils eine Datei "aktuelles.html" neu zu erstellen und im Netz zu speichern wäre.


    Hat jemand eine Idee dazu?


    Thnx Thomas

    Herzlichen Dank für's Dranbleiben, eXcel !

    Quote from "eXcel"

    Allerdings hat dort jemand genau das Addon gepostet, das ich suche: https://addons.mozilla.org/en-…derbird/addon/size-in-kb/
    Funktioniert einwandfrei und zeigt die Mailgröße wieder durchgehend in KB an. Keine Ahnung wieso ich das nicht gefunden hatte, ich hab die Addon-Datenbank eigentlich nach allen möglichen, meiner Meinung nach passenden Stichworten durchsucht.


    Dieses Add-on wird komischerweise in der Datenbank von TB nicht gefunden, weder unter seinem Namen, noch unter diversen Stichworten.
    Kann jemand dieses Mysterium erklären?
    Jedenfalls grosses Lob an Entwickler und Entdecker!
    Thomas

    Ich hab wieder 3.1.15 und die Aktualisierung abgeschaltet.
    Das ist die letzte Version mit der "altmodischen" Darstellung.
    SIe ist direkt auf der TB-Download-Seite als Alternative anwählbar.
    Sagt mir Bescheid, wenn diese "Erleichterung" vorüber ist.
    Thomas

    Hallo fossil_fuel,

    Quote from "fossil_fuel"


    Hier im Thread ist öfter von einer Schritt-für-Schritt-Anleitung die Rede... Würde ich auch sehr begrüßen ;)


    Ich hab da schon was auf dem Schirm, bin aber neulich bei der Sektion "Bearbeiten von Einträgen" abgestürzt.
    Wenn von irgendwoher ein Zeitschei..er kommt, mache ich mich wieder dran.
    Aber bitte: lasse sich niemand davon abhalten, selbst mal was zu schreiben.


    Peter: wo wäre denn der Platz, an dem man sowas gemeinsam erarbeiten könnte?


    Grüsse
    Thomas

    Quote from "easy"


    Bei mir tritt dieses Problem auf wenn in den Einstellungen zum Plugin unter RDN Basis nicht DisplayName steht!
    Mann achte auf das "N" das muss groß geschrieben werden!!!

    Super, vielen Dank für diesen Tipp. Dafür würde ich dir gerne 2 Flaschen von dem Biowein zukommen lassen, wenn du mir (per pm) deine Adresse und deine Weinpräferenzen mittteilst.
    Und überhaupt ist es schön, dass wieder etwas Bewegung in das Thema kommt.
    Inzwischen schreiben ich die Schritt-für-Schritt-Anleitung selbst, wenn alles klappt auch gerne hierher.

    Das war der nächste gute Tipp.
    Manchmal sieht man ja, welches Feld bemängelt wird, aber wie hast du denn gerochen, dass der obige Fehler das Land betrifft?
    Gibt's ne Liste, ein Logfile, ein Protokoll?


    Ich versuche, die Adressen durch Export und Reimport von einem Adressbuch auf den LDAP-Server zu kriegen.
    NB: Warum tritt eigentlich das Feld "Anzeigename" beim Export 2 Mal auf?


    Aber auch wenn ich's direkt mache, habe ich immer Probleme mit leerer "SecondEmail" (Weitere Email-Adresse).


    Error: addquery 21
    NO_SUCH_OBJECT
    mail: value #1 invalid per syntax


    Wenn man zunächst einen Buchstaben rein schreibt, kann man den hinterher auch wieder löschen und das Feld ist wieder leer.
    Aber geht's nicht auch anders?


    Danke für alle Tipps! Und: 4 Flaschen Wein sind noch übrig.

    Ich hab mnenhy ausprobiert:
    eine neue Spaltenverteilung geht damit nicht,
    aber das steht auch nicht in der Anleitung.


    Da ist nur die Rede von einer anderen Darstellung der Kopfzeilen und das geht auch.


    Falls jemand eine Lösung hat, wie die Spalten der Nachrichtenliste einheitlich für alle Ordner gemacht werden können: bitte posten.
    Danke!


    Thomas

    Haaallloooo,
    NIcht mehr los seit 14 Tagen? Liegt's an der WM?

    Quote from "ta7h12"

    Vom LDAP-Browser ldapadmin kann ich prima arbeiten.
    LdapRW allerdings antwortet grundsätzlich mit "Error: genrdn: basisRdn.length = 0"


    Keine Einfälle?
    Oder hat doch jemand eine Step-by-step-Anleitung?
    Da könnte ich sogar meine als Grundlage anbieten, aber es funktioniert ja bei mir leider nicht.
    Oder will mir jemand mit ner Fernwartung helfen?
    Wie wär's mit 6 Flaschen Biorotwein für die Lösung des Problems?
    Thomas

    Hi Peter,


    Danke für den Tipp!

    Quote from "Peter_Lehmann"


    Gib mal folgende acl ein:
    access to * by * write
    ...
    Zum Testen des slapd solltest du dir einen der üblichen ldap-Browser einrichten. Erst wenn damit das übliche lesen und schreiben vollständig funktioniert, ein ldap-Adressbuch im Thunderbird anlegen. Du kannst vorher dein komplettes Adressbuch als ldif exportieren und in den ldap importieren. Und wenn das richtig funktioniert, dann mit ldapRW anfangen.


    Die acl hab ich entsprechend geändert.


    Vom LDAP-Browser ldapadmin kann ich prima arbeiten.
    LdapRW allerdings antwortet grundsätzlich mit "Error: genrdn: basisRdn.length = 0"


    Viele Grüsse
    Thomas

    Hi HS

    Quote from "hssuhle"

    thomas:
    Du greifst also auf Deinen LDAP bei zzzzz.dyndns.org zu.
    Nur mal blöd am Rande gefragt:
    Hast Du in Deinem Router eine Portweiterleitung für Port 389 eingerichtet?


    Ich hab's grad nochmal geprüft: ja.
    Logisch auch, denn die LDAP-Abfrage von Thunderbird funktionierte ja auch.
    Aber da ich gerade dabei war - wie durch ein Wunder - lief so manches:
    Änderungen an meinem einzigen Testeintrag funktionieren.
    Ich komme zwar mit dieser Oberfläche noch überhaupt nicht zurecht (welches Adressbuch wird gerade verwendet usw.), aber immerhin.
    Die Neuanlage von Einträgen dagegen macht immer wieder ein "Error: genrdn: basisRdn.length = 0".
    Demnach müsste das ein Problem sein zwischen den EInstellungen in LdapRW ("Objektclassen neuer ...") und meinem LDAP-Server.
    Ist da was in meiner slapd.conf?
    Vielleicht ist was zu ändern bei
    "access to * by self write
    by * write" ???


    Thomas

    Hallo HS!


    Quote from "hssuhle"

    thomas:
    Welche Config hast Du denn gewählt?
    Interessant wäre sowohl Deine slapd.conf als auch Deine LDAPRW-Konfiguration. Hast Du denn die erste Fehlermeldung beseitigen können, so wie ich es Dir beschrieben hatte?


    Die Fehlermeldung geht nicht weg. Ich habe ldap_2.servers.DEIN_ADRESSBUCH_NAME.dirType auf integer=2 gesetzt, für das LDAP-Adressbuch von TB UND das lokale Adressbuch LdapRW (welches meintest DU eigentlich?) und für alle Fälle mal das Java-RTE auf Version 1.6.0 gebracht ... vergeblich.


    Meine slapd.conf ist folgende:
    ucdata-path ./ucdata
    include ./schema/core.schema
    include ./schema/cosine.schema
    include ./schema/inetorgperson.schema
    include ./schema/nis.schema
    include ./schema/extension.schema
    include ./schema/mozillaAbPersonAlpha.schema
    # include ./schema/mozilla_op20.schema
    # include ./schema/mozilla_btw.schema
    pidfile ./run/slapd.pid
    argsfile ./run/slapd.args
    database bdb
    suffix "dc=xxxxx,dc=de"
    rootdn "cn=Manager,dc=xxxxx,dc=de"
    rootpw yyyyyyyy
    directory ./data
    access to * by self write
    by * write


    Das LDAP-Adressbuch in TB hat die Parameter:


    Name: LDAP_uuu
    Server zzzzz.dyndns.org
    Base-DN: dc=xxxxx,dc=de
    Port: 389
    Bind-DN: cn=Manager,dc=xxxxx,dc=de


    und läuft prima.


    LDAPRW hat folgende Parameter:


    Adressbuch: LdapRW
    URI: 'ldap://zzzzz.dyndns.org/dc=xxxxx,dc=de??sub?(objectclass=*)'
    aber auch 'ldap://zzzzz.dyndns.org/ou=adressen,dc=xxxxx,dc=de??sub?(objectclass=*)' ist nicht besser (beides ohne quotes)
    auth: cn=Manager,dc=xxxxx,dc=de
    objektklassen inetorgperson, mozillaAbPersonAlpha, organizationalPerson,person
    objektklassen für neue: groupOfNames
    Max. Ergebnis: 100
    Use LiveUpdate: Prompt

    Quote from "hssuhle"

    Was allerdings tatsächlich (meistens) geht, ist das Schreiben LDAP --> Lokales AB, das Editieren und das Zurückschreiben.


    Bei mir geht da nix.


    Kannst du dir das mal von Peter zeigen lassen und gut mitnotieren: welche Schaltflächen, welche Einträge ... ?
    Danke!
    Thomas

    Es bleibt dabei : "Error: genrdn: basisRdn.length = 0"


    Quote from "Peter_Lehmann"

    ...
    Dort kannst du sie editieren und per Extras >> ldapRW Sync werden sie wieder auf den ldap geschrieben.


    Ich vermute mal, dass das was mit meinem "Manager" zu tun hat.
    Es darf zwar mittlerweile anonym auf den LDAP geschrieben werden, aber das unterstützt LdapRW vermutlich nicht, oder?


    Vermutlich ist der "Manager" nicht vorhanden in "ou=people".
    Kannste mir ne kleine Nachhilfe geben, wie ich den per slapadd hinzufüge?
    Thanksalot!
    Thomas

    Hi Peter,


    Quote from "Peter_Lehmann"

    ...
    Dort kannst du sie editieren und per Extras >> ldapRW Sync werden sie wieder auf den ldap geschrieben.


    Bearbeiten kann ich die Adressen in dem neu angelegten Adressbuch natürlich.


    Aber wenn ich sie syncen will, bekomme ich ein "Error: genrdn: basisRdn.length = 0"


    oder das Ding mit Line 71


    Kann das mit dem Passwort zu tun haben?
    Ist das richtig, dass man einiges händisch in die about::config schreiben muss?
    Und was?

    Hallo Peter,
    Danke für's Motivieren, ich hab's geknackt:
    Wenn man schon bei der auth-DN ein "cn=" reinschreibt, dann darf man natürlich bei RDN-Attribut auch nicht "uid" reinschreiben, sondern "cn".
    Vielleicht hilft's mal jemand.


    Jetzt kann ich also krieg ich "nur noch" so eine komische Meldung beim Start:
    --------
    Error getprefs [Exception... "Component returned failure code: 0x8000ffff
    (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getIntPref]" nsresult: "0x8000ffff
    (NS_ERROR_UNEXPECTED)" location: "JS frame :: chrome://ldaprw/content/prefs.js :: getprefs ::
    line 72" data: no]
    Please check preferences
    ---------
    Ich weiss nicht mal, in welcher Datei ich die Zeile 72 suchen soll.


    Das Schreiben TB -> LDAP scheint auch höchstens verzögert zu wirken. Aber vielleicht ist der Timeout in ldaprw auf was Schnelleres eingestellt als auf zwei DSL6000-Endpunkte.


    Und was mir weiterhin fehlt, ist:
    wie bekomme ich Einträge von den lokalen Adressbüchern in das LDAP-Adressbuch?
    Mit Drap-and-Drop geht's jedenfalls nicht.


    Klar, kann man mit LDAPadd und Vorbehandlung viel machen, aber das soll's ja gerade nicht sein.
    Also? Und lass dir das mit dem Wein durch den Kopf gehen ;)

    Hallo Peter,


    Danke für deine Tipps.
    Das mit dem Schema mag schon mal ganz gut gewesen sein.
    Könntest du nicht mal die von dir als funktionierend erkannten und verwendeten Schema-Dateien irgendwohin packen. Gepackt hätte unserein Dummy dann auch nicht das Problem mit Zeilenumbrüchen usw. .. seufz


    Quote

    Hallo ta7h12,
    Zu ldapRW: Du musst ein zusätzliches leeres lokales Adressbuch anlegen und auf dieses verweisen. Das war der Grund, warum es bei mir nicht funktioniert hatte.


    Sorry, das kapier ich nicht, vor allem das mit dem "verweisen".
    Für eine funktiionierende Schritt-für-Schritt-Anleitung würde ich dir inzwischen ein paar gute Flaschen Wein zukommen lassen, denn es ist wahnsinnig mühsam, aus den FAQs sich das Ganze so zusammenzusuchen, dass es passt


    Thomas

    Ich hab etwas mit ldapRW experimentiert, aber ich krieg es nicht zum Laufen.
    Das LDAP-Adressbook in TB funktioniert.
    Aber mir fehlt das Rezept, wie ich die Parameter von Thunderbird auf die Parameter von ldapRW übertrage?
    Oder liegt's an den Schemata? Ich verwende core, cosine, inetorgperson und mozilla_btw


    Ich verwende openLDAP for Windows 2.2.29 auf einem windows XP Prof, nicht-local.
    Thunderbird ist Version 3.0.4
    ldaprw ist version 0.4.201005222007

    Quote from "allblue"


    Solltest du Firefox benutzen, so kann man dort einstellen, dass Links, die ein neues Fenster erzwingen, in einem neuen Tab geöffnet werden. Sollte das nicht klappen, kann man mit der Erweiterung Tab Mix Plus noch einstellen, dass ebenso mit Links aus externen Anwendungen (wie z.B. Thunderbird) umgegangen wird.


    So klappt das bei mir, die Links aus Thunderbird werden im Hintergrund in neuen Tabs (im zuletzt aktiven Fenster von Firefox) geöffnet. Voraussetzung ist, dass Firefox bereits läuft, sonst wird beim Öffnen natürlich Firefox in den Vordergrund geholt.


    Ich krieg's nicht hin.
    Ich dachte, wenn ich im Reiter "Tab-Fokus" die Einstellung "Tabs im Vordergrund öffnen" "aus Links" deaktiviere, dann funktioniert's, tut aber nicht.
    FF ist 3.5.1, TMP ist 0.3.8.1

    Hallo Peter,


    Das mit LDAP hab ich auch schon probiert, es ist eigentlich prima, aber Thunderbird hat ja leider keine Bordmittel, um das LDAP-Verzeichnis zu pflegen.
    Was empfiehlts du?
    Grüsse
    Thomas


    Quote from "Peter_Lehmann"

    ...
    Adressbuch:
    Die imho einzig vernünftige Lösung ist die Verwendung eines ldap-Servers. Dieser wird von TB direkt unterstützt. ...