Posts by psychorosti

    Seid gegrüßt!


    Bei allen wo die Batch (.bat) Datei nicht richtig vom Taskmanager ausgeführt wird, hier nochmal ein Tipp, der zumindest mit meinem englischem XP-Professional SP2 funzt.


    Das Problem: Der TaskManager unterstützt nicht zweimal die doppelten Anführungszeichen in seinem Kommandozeilen-Parser.


    Die Lösung: Um das es trotzdem funktioniert muss man den an die .bat Datei übergebenen Ordner in das alte Dos-8-Zeichen Format umwandeln, damit man sich die doppelten Anführungszeichen sparen kann.


    Der Lösungsweg:

    Quote


    FEHLER!
    "C:\TB Backup\TB-Backup.bat" TB-Backup "C:\Documents and Settings\Administrator\Application Data\Thunderbird"


    in das umwandeln:

    Quote


    RICHTIG!
    "C:\TB Backup\TB-Backup.bat" TB-Backup D:\DOCUME~1\ADMINI~1\APPLIC~1\THUNDE~1


    Wenn ihr wissen wollte wie ihr an den abgekürzten Pfad kommen sollt, habt ihr 2 Wege.


    1. Weg:
    Ausführen->"command"
    Schreibt "cd " und kopiert mit Rechtsklick (ins Fenster)->Einfügen den langen Pfadnamen rein. Dann steht im Fenster z.b.
    C:\cd "C:\Documents and Settings\Administrator\Application Data\Thunderbird"
    Mit Enter bestätigen und dann sollte der richtige Pfad dranstehen. Dann direkt aus dem Fenster mit rechter Maustaste->Markieren den Pfad markieren und nochmals rechtsklicken - damit habt ihr ihn kopiert.


    2. Weg:
    Ihr kürzt mit Hand ab.

    also zuerst alle Ordnernamen auf 6 Buchstaben kürzen sowie alle Leerzeichen weglassen.
    C:\Documents and Settings\Administrator\Application Data\Thunderbird
    ... wird zu ...
    C:\Docume\Admini\Applic\Thunde
    Dann fügt ihr überall noch ein "~1" an das Ende jeden Ordnernamens
    Hinweis: Die Zahl ist übrigens dafür da das falls es mehrere Ordner gibt bei denen die ersten 6 Zeichen gleich sind dann nur die Zahl erhöht werden muss (bis 4 gleiche Ordner jedenfalls).
    C:\Docume~1\Admini~1\Applic~1\Thunde~1


    Das kommt dann Anstelle des vollen Pfades in euren Task rein, so das jetzt nur noch einmal doppelte Anführungszeichen zu sehen sind:
    [Starten] C:\TB Backup\TB-Backup.bat" TB-Backup D:\DOCUME~1\ADMINI~1\APPLIC~1\THUNDE~1


    Hoffe konnte helfen!



    mfg
    psycho


    Edit1+2: Kleine Schreibfehler