Posts by MisterKnister

    Hallo Mapenzi,


    ich war gerade dabei meinen nächsten Beitrag abzuschließen als Dein neuer Post eingetrudelt ist.


    Deshalb zunächst einmal ein Dankeschön an Dich und die Antworten zu Deinen Fragen:


    1.) Der String beschreibt einen lokalen Ordner, der von beiden virtuellen Ordnern überwacht wird; deshalb taucht er 2x auf


    2.) Das IMAP-Postfach kam vor ein paar Wochen neu dazu; ich hatte es vergessen zu erwähnen, aber es hat auch nichts am Verhalten geändert


    3.) Die Spotlight-Suche habe ich mal deaktiviert


    4.) Auf meinem Mac läuft zwar noch Windows, aber unter VMWARE ohne direkten Kontakt zu TB; der Eintrag stammt wahrscheinlich noch aus
    der Zeit vor dem Umstieg auf den Mac


    So, ... nun zu meinen neuen Entdeckungen...


    Nachdem mir heute Nachmittag beide Virtuelle Ordner um die Ohren geflogen sind - diesmal ohne sichtbare Begleiterscheinungen - hab ich mich daran erinnert, dass ja nicht nur OSX eine Fehlerkonsole hat, sondern auch Thunderbird. Und siehe da! ... ;)



    Wenn ich in den Sourcecode reinschaue, scheint der für mich zumindest was mit Suchfunktionen zu tun zu haben...
    Bleibt noch die Frage warum es an dieser Stelle knallt und wie man den Fehler reproduzierbar macht.

    Hallo,


    nach dem Erhalt einer einzelnen E-Mail gestern Nachmittag trat der Fehler erneut auf. Beim Klick auf die ungelesene E-Mail kam die folgende Warnmeldung als PopUp:

    Quote

    Adressbuch-Datei konnte nicht geladen werden
    Die Adressbuch-Datei abook.mab konnte nicht geladen
    werden. Es könnte sein, dass sie schreibgeschützte ist
    oder gerade von einer anderen Anwendung verwendet
    wird. Bitte versuchen Sie es später erneut.


    Diese Meldung trat gestern zum ersten mal auf. Die Adressbuch-Datei ist nicht schreibgeschützt und ich weiß auch nicht welche Anwendung sonst noch schreibend auf diese Datei zugreifen, und sie somit sperren sollte.
    Unmittelbar nach diesem Fehler war der zweite, der beiden virtuellen Ordner futsch. Ein Vergleich der Datei virtualfolders.dat im Zustand voher-nachher ergibt, dass auf Distanz 0x19e 39 Bytes entfernt wurden und auf Distanz 0x427 wurden diese 39 Bytes eingefügt.
    Bei Interesse kann ich die beiden Dateien gerne schicken.


    Um den Fehler zu reproduzieren habe ich einerseits versucht, die Mail als ungelesen zu markieren und wieder anzuklicken, und sie mir andernseits noch mal selber zugesendet. Beide Versuche führten jedoch nicht zum Erfolg...

    Hallo und vielen Dank erstmal,


    ... vor allem an grabs und Mapenzi
    Natürlich ist mir bewusst, dass hier einige Leute viel Freizeit investieren, um die Probleme anderer Leute zu lösen.
    Deshalb freue ich mich um so mehr über die Resonanz und auch über die Tipps, um zukünftig den Frust etwas einzudämmen :-)


    Hier erstmal der Link, den ich im Januar zu diesem Thema gefunden habe: http://www.thunderbird-mail.de…iewtopic.php?f=30&t=58747


    Und nun zu meinem System-Umfeld:


    Ich arbeite auf einem Mac Book Pro (Late 2013) unter OSX 10.9.5 mit Thunderbird 31.2.0 und Firefox 33.0.2


    Ich bin Anfang des Jahres von meinem Windows(7)-Rechner auf den Mac umgezogen und habe die Profile von FF und TB einfach entsprechend umkopiert. Das hat auch wunderbar geklappt.


    Ich habe schon immer mit virtuellen Ordnern gearbeitet und hatte unter Windows nie Probleme damit. Ich benutze die Ordner um ungelesene und markierte Mails für meine diversen Mail-Accounts und lokalen Ordner (auf die ich die Nachrichten per Regel verteile) gesammelt im Blick zu haben. Dafür benutze ich je einen virtuellen Ordner für die ungelesenen und die markierten Nachrichten.


    Hin und wieder und in sehr unregelmäßigen Abständen kommt es vor, dass die virtuellen Ordner (meist nur einer von beiden zur selben Zeit) ihre Einstellungen verlieren. Es sind dann nachwievor noch virtuelle Ordner (mit Lupe) aber die Suchbedingung lautet plötzlich "Betreff enthält <leer>" und die zu überwachenden Ordner sind allesamt nicht mehr markiert. Die virtuellen Ordner wurden übrigens nicht umbenannt.
    Das tritt, wie gesagt, sehr unregelmäßig auf; von mehrmals täglich bis 1x im Monat. Zur Zeit hat es sich so bei 2x pro Monat eingependelt.
    Der Fehler tritt meist im laufenden Betrieb auf. Mal kurz vom Suchordner in einen anderen gewechselt und wieder zurück und schon ist er futsch.
    Meine Sicherungen mit TimeMachine mache ich mittlerweile nur noch manuell, 1x täglich, so dass mir die Software nicht reinpfuschen kann.


    Da es evtt. eine Rolle spielen könnte, hier noch 2 Phämomene, die bei mir ebenfalls hin und wieder auftreten:


    1.) Ohne ersichtlichen Grund sind plötzlich Nachrichten in lokalen Ordnern ( z.B. "Entwürfe" oder Ordner in welche Nachrichten per Filter verschoben werden ) als ungelesen markiert.


    2.) Es kommt die Fehlermeldung, dass Nachrichten nicht in einen Ordner verschoben werden können (kein Schreibzugriff)


    Dies aber nur m Rande; die beiden Fehler sind weitaus weniger lästig, als die Sache mit den virtuellen Ordnern.


    So, ... erst mal viele Grüße und Merci...

    hmmm.........


    Nach einem halben Jahr - so denke ich - wird es mal Zeit für ein kurzes Resumée.


    An meinem Problem mit Thunderbird unter Mac OSX hat sich nicht wirklich etwas geändert.
    Die 90 Zugriffe seit April auf meinen Beitrag lassen mich aber darauf schließen, dass ich nicht
    der Einzige bin, der mit diesem Problem zu kämpfen hat. Trotzdem sieht es für mich so aus,
    als ob das Problem nicht wirklich jemanden interessiert. Ich hatte eigentlich gehofft, dass
    hier auch der ein oder andere Entwickler mal in die Foren guckt und eventuell mal Hilfestellung
    bei der Fehlerdiagnose gibt, aber das war in diesem Fall wohl ein Irrtum. Vielleicht ist Thunderbird
    auf einem Apfel-Rechner ja so etwas wie ein ungeliebtes Stiefkind und interessiert niemanden so wirklich ?


    Schade eigentlich....

    Thunderbird-Version: 24.4.0
    Betriebssystem + Version: Mac OS X 10.9.2
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): 1 & 1


    Hallo zusammen,


    ich weiß, dieses (anscheinend ungelöste) Thema gab es bereits vor 2 Jahren einmal. Da sich da aber seitdem nix mehr bewegt, habe ich mich entschlossen einen neuen Thread zu beginnen.


    Das Problem ist, dass die Einstellungen der virtuellen Ordner nach einiger Zeit verloren gehen. Sämtliche Suchkriterien sind dann futsch.
    Da das Problem auch schon auf Windows-Rechnern auftrat, gehe ich mal davon aus, dass es sich nicht um ein Mac-spezifisches Problem handelt auch wenn ich persönlich unter Windows nie dieses Problem hatte.


    Auf meinen Mac-Book-Pro läuft derzeit auch keine Antiviren-Software, die unter OSX öfters mal Probleme macht, und gesichert wird bei mir mit Time Machine. Ich konnte noch nicht eingrenzen, unter welchen Bedingungen der Fehler auftritt - nach ein bis zwei Tagen sind die Einstellungen einfach weg.


    Ich wäre dankbar für ein paar Informationen, ob es sich bei mir um ein Einzelschicksal handelt, oder ob andere User das gleiche Problem haben und wie man am effektivsten die Ursache und natüröich auch eine Lösung für dieses Problem findet.


    Merci schon mal für eure Beiträge