Posts by Frère Jacques

    Hallo Susi,


    löschen + neu importieren des neuen Schlüssels hat nicht geholfen. Den alten Schlüssel wollte ich nicht so gerne löschen, weil ich den erst in meinen Backups hätte suchen müssen.


    Ich hab's jetzt aber anders hingekriegt:


    Ich habe in der ~/.thunderbird/????????.default/prefs.js die beiden Werte ...

    user_pref("mail.identity.id1.openpgp_key_id", "????????????????");

    ... und ...

    user_pref("mail.identity.id1.pgpkeyId", "0x????????????????????????????????????????");

    ... auf den neuen Schlüssel geändert. Damit funktioniert jetzt alles wie gewünscht.


    Ich bin jetzt nur gespannt, ob ich wieder manuell Textdateien editieren muss, wenn mein jetzt aktueller Schlüssel abläuft. Aber das dauert noch knapp zwei Jahre ...


    Danke für Deine Hilfe,

    schönen Gruß



    Frère Jacques

    Hallo Susi,


    das komplette Paar war schon importiert. Zumindest sagt mir "Extras", "OpenPGP-Schlüssel verwalten", Doppelklick auf meinen neuen Schlüssel, "Schlüsseltyp": "Schlüsselpaar (geheimer und öffentlicher Schlüssel)".


    Mein Problem ist eher, dass ich in den Konto-Einstellungen weder den neuen Schlüssel noch keinen Schlüssel auswählen kann. Das heißt: Ich kann in der Schlüsselauswahl schon den neuen Schlüssel oder auch "Keiner. OpenPGP für diese Identität nicht verwendet" auswählen. Aber die Einstellung greift nicht, und wenn ich das nächste Mal in den Konto-Einstellungen nach dem Schlüssel sehe, ist wieder der abgelaufene alte Schlüssel ausgewählt.


    (Andere, noch ältere Schlüsselpaare, die auch schon abgelaufen sind, kann ich erst gar nicht auswählen.)

    Hallo,


    ich verwende Thunderbird 78.7.1 unter Debian Testing. Vor wenigen Wochen ist der von mir verwendete OpenPGP-Schlüssel abgelaufen, und ich habe heute (mit GnuPG) ein neues Schlüsselpaar erstellt.


    Unter "Bearbeiten", "Konto-Einstellungen", mein Konto, "Ende-zu-Ende-Verschlüsselung" sagt Thunderbird mir (zu Recht): "Derzeit ist die Verwendung der Schlüssel-ID 0x???????????????? festgelegt, aber der Schlüssel ist abgelaufen."


    Dann gehe ich auf "Schlüssel hinzufügen...", "Bestehenden OpenPGP-Schlüssel importieren" und wähle die Datei mit meinem neuen Secret Key aus. Thunderbird schreibt: "Thunderbird erkannte einen importierbaren Schlüssel." Der Haken vor "Diesen Schlüssel als persönlichen Schlüssel verwenden" ist gesetzt. Ich klicke auf "Weiter" und gebe mein Passwort ein. Thunderbird schreibt: "OpenPGP-Schlüssel wurde erfolgreich importiert". Ich klicke wieder auf "Weiter".


    Jetzt wähle ich in der Liste der Schlüssel den neuen Schlüssel aus und schließe danach den "Konto-Einstellungen"-Tab.


    Trotzdem will Thunderbird weiterhin den abgelaufenen Schlüssel verwenden: Wenn ich mir selbst eine Mail schicken will, sagt Thunderbird: "Die Nachricht konnte nicht gesendet werden, weil es ein Problem mit Ihrem persönlichen Schlüssel gibt. Der Schlüssel [Bezeichnung meines abgelaufenen Schlüssels] ist abgelaufen."


    Was kann ich tun, um meinen neuen OpenPGP-Schlüssel in Thunderbird zu verwenden?


    Vielen Dank!



    Frère Jacques

    Quote from "mrb"

    Thunderbird muss geschlossen sein, bevor man die msf löscht.


    Das hatte ich gemacht.


    Quote from "mrb"

    Und direkt nach dem Neustart legt Thunderbird diese wieder neu an, ein Öffnen von Ordnern ist dabei nicht notwendig.


    Ja, die Dateien legt er neu an. Aber leer, also mit 0 Bytes Größe.
    Einen Inhalt bekommen die .msf-Dateien erst, wenn ich die Ordner wie oben beschrieben öffne.
    Das ist imho normal so, oder irre ich mich da?


    Quote from "mrb"

    Entweder liegt es bei dir an Linus oder dein Profil ist beschädigt. Das können schon zu große Mbox-Dateien sein.


    An Linux scheint's nicht zu liegen, ich habe nochmal alle .msf-Dateien gelöscht und das Profil (ca. 1,3 GB) auf 'nen Windowssystem (XP SP3) kopiert, da werden die .msf-Dateien auch leer erstellt und erst beim Öffnen des Ordners gefüllt.


    Die größte mbox-Datei ist "Sent" mit ca. 300 MB. Ist das ein Problem?


    Na ja, notfalls muss ich mich einmal durch meine 230 Ordner klicken. Das wird auch in 'nem Stündchen erledigt sein.


    Danke für Deine Hilfe



    Frère

    Thunderbird-Version: 31.1.1
    Betriebssystem + Version: Xubuntu 14.04 (Trusty Tahr)
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): verschiedene


    Hallo,


    ich konnte in meinem Thunderbird etliche E-Mails in fast allen Ordnern nicht mehr lesen. Nachdem ich (erst testweise einige; als das erfolgreich war:) alle .msf-Dateien gelöscht habe, kann ich wieder alle E-Mails lesen.


    Aber: Wenn ich jetzt in der Baumansicht (links) auf einen Ordner gehe, sehe ich rechts nicht die Liste mit den E-Mails dieses Ordners, sondern eine Seite "Thunderbird E-Mail - [Ordnername]" mit den Überschriften "Konten" und "Erweiterte Funktionen".
    Wenn ich den Ordner in einem neuen Tab öffne, kommt ein neuer Tab mit leerer Überschrift. Erst wenn ich diesen Tab in den Vordergrund hole, sehe ich meine Mails. - Ab dann auch im ersten Tab. Wenn ich mich nicht irre, liegt das daran, dass die .msf-Datei erst erstellt wird, wenn ich einen Ordner öffne. Und dafür scheint es nicht zu reichen, den Ordner anzuklicken, sondern ich muss ihn in einem neuen Tab öffnen und dann diesen Tab in den Vordergrund holen.


    Wie kann ich erreichen, dass alle .msf-Dateien neu angelegt werden, ohne dass ich mich manuell durch alle (deutlich über 100) Ordner klicken muss?


    Vielen Dank!



    Frère