Posts by steffan

    Mein Rat wäre, das Profil neu zu erstellen.

    Dazu benötigst du keine weiteren Tools wie Mailstore. Du kannst die Mailboxen einfach mit dem Explorer an den gleichen Ort in das neue Profil kopieren. Auch das ist in den Anleitungen und im Forum schon sehr oft beschrieben worden.

    Kalender und Adressbücher lassen sich aus dem Thunderbird heraus ex- und später wieder importieren. Fertig.

    ja, neues Profil erstellen ist sicherlich die beste Lösung.


    Mit dem Add-on Import-ExportsTools habe ich schon gearbeitet, klappt im Prinzip auch, ist aber bei vielen Ordnern aufwendig; ansonsten werde ich mir evtl. auch noch mal "MailStore Home" ansehen, das Matt59 erwähnt hatte, falls das mit dem "einfach per Explorer kopieren" nicht so einfach klappt.


    Du erwähnst, dass man aus dem Backup-Profilordner einfach die Mailordner kopieren kann.


    Die Vorgehensweise wäre also:

    • neues Profil erstellen, und alle POP und IMAP-Konten neu erstellen
    • im neuen Profil den Ordner "Mail" löschen, und aus dem alten Profil diesen Ordner "Mail" (der offenbar alle POP Ornder enthält) kopieren; den Ordner "IMAPMail" braucht man vermutlich nicht, weil man die Ordner der IMAP-Konten einfach wieder importiert


    Meine Bedenken wären, ob dann jedes neu eingerichtete Konto auch wirklich "seinen" korrekten Mailordner findet -- vor allem dann, wenn man mehrere Konten vom gleichen Anbieter hat (siehe Bild)


    Falls es eine Anleitung dazu hier im Forum gibt, oder sonst irgendwo im Netz, dann bitte einfach den Link posten.

    nicht nur Caschy warnt vor solchen unnützen Systemkillern: Tuning-Tools, die Plage des 21. Jahrhunderts? Sogar Microsoft rät in der Microsoft-Supportrichtlinie für die Verwendung von Dienstprogrammen zur Bereinigung der Registrierung ausdrücklich davon ab.


    Gruß Ingo

    ich will nicht behaupten, dass Bleachbit harmlos wäre, aber es ist

    - kein Tuning-Tool

    - kein Tool zur Bereinigung der Registry


    Dass trotzdem einiges mit Bleachbit schief gehen kann, ist offensichtlich und kaum zu bestreiten.


    Und Caschy schreibt im bereits oben erwähnten Link auch nicht, dass Bleachbit generell unnütz und schlecht ist, sondern


    Quote


    BleachBit ist ein System-Werkzeug – mittlerweile auch in komplett neuer Optik – mit vielen Funktionen, welches Datenmüll und -reste löscht, was man aber nur zum Einsatz bitten sollte, wenn man weiß, was man dort tut.

    also, hier findet man wie gesagt diese von der Community gepflegte Datei "winapp2ini"

    https://docs.bleachbit.org/doc/winapp2ini.html


    Ich habe die wenigen Einträge aus dieser umfangreichen Datei, welche die Lösch-Positionen zum Thunderbird betreffen, hier als *.txt mitgeschickt.

    Die unter "Filekey X" dort angegebenen Werte sind offenbar die zum Löschen vorgesehenen Positionen.


    Von den dort vorhandenen Löschpositionen kommt mir allerdings keiner "verdächtig" vor als Verursacher der beschriebenen Probleme. Aber ich habe den Verdacht, dass dort ein paar die Einträge fehlen, nämlich die unteren 5 Einträge aus dem Bild s.o., bspw. "Passwörter" und "Index".


    Unbedingt weiterempfehlen würde ich Bleachbit allerdings nicht mehr. Andererseits braucht man schon irgendeinen Cleaner, finde ich.

    Caschy ist auf seinem Blog nicht so sicher, ob das der Fall ist https://stadt-bremerhaven.de/b…g-fuer-windows-und-linux/

    Danke erst mal für die Antwort -

    also, der Umfang der Reinigungsmöglichkeiten wird schon von der Community gepflegt, siehe hier

    https://docs.bleachbit.org/doc/winapp2ini.html

    dort: "BleachBit imports cleaning rules from winapp2.ini files giving Windows users 2400+ additional cleaners (and growing) created by the community."


    die angebotenen Löschoptionen sieht man in dem Bild "bleachbit-tb.jpg" -

    und nein, ganz so blauäugig wie man meinen konnte war ich auch nicht, sondern habe auch alle Punkte, zu denen Bleachbit beim Setzen des 'globalen Hakens' für TB (siehe Bild) dann direkt die von Dir im Posting zuvor geposteten Warnmeldungen ausgibt, dann auch nicht verwendet (=keinen Haken gesetzt), so auch bei den Passwörtern. Aber die verbleibenden Haken haben offenbar ausgereicht, dass es die beschreibenen Probleme gibt. (im Bild hier sieht man nicht die Hakensetzung, die zu Problemen geführt hat, die verbleibenden Haken sollten keine Probleme mehr machen; am besten natürlich: Bleachbit soll TB komplett ignorieren, also alle Haken zu TB wegnehmen)


    Und ja, es gibt ein Log, das direkt nach dem Reinigen angezeigt wird. Aber es wird offenbar keine Log-Datei abgespeichert. Für so eine Log-Datei müsste man offenbar selbst "basteln", wie hier beschrieben https://www.bleachbit.org/forum/log-file-creation Habe ich aber natürlich nicht sofort gemacht, weil ich von den Problemen noch nichts wusste.


    Zur Richigstellung noch: Nachrichten abrufen bei TB geht schon, nur eben nicht automatisch bei Starten, sondem man muss auf "Abrufen" klicken (oder F5 drücken); und "Nachrichtenfenster wird eingeblendet" soll heißen, dass man immer erst mal "F8" drücken muss, oder das Nachrichtenfenster (in der 'klassischen Ansicht') mit der Maus zusammenschieben muss, weil TB sich nicht (wie eigentlich üblich) die beim Schließen von TB bestehende Ansicht merkt.


    Man könnte also denken:

    mit den Problemen kannst Du gut leben, einfach alles so lassen -- aber nervend ist es doch, finde ich.


    Irgendeine Funktion für TB, bei denen die "Startup"-Vorgaben auf Standard zurückgesetzt werden, so dass eben wieder das Standard-Verhalten von TB vonhanden ist, wäre gut.

    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version : 78.7.1 32 bit
    • Betriebssystem:Win 10
    • Kontenart: POP und IMAP
    • Postfach-Anbieter: GMX
    • Eingesetzte Antiviren-Software: ESET

    Nach Reinung mit dem eigentlich guten, und schon länger von mir verwendeten Programm Bleachbit https://www.bleachbit.org/ gab es mit Thunderbird ("TB") mehrere Probleme.


    Hintergrund:

    es gibt bei Bleachbit von der Bleachbit-Community bereitgestellte Reinigungsroutinen, u.a. seit neuerem auch für TB. Mein Tipp: Thunderbird nicht von Bleachbit reinigen lassen, also: die entsprechenden Haken bei den Reinigungsvorschlägen für TB nicht setzen! Welcher Punkt jetzt genau meine Probleme verursacht hat, weiß ich nicht genau, meine Vermutung wäre: - Löschen von "Startup Cache Extras" oder "TB DOM Strorage"


    Aktuell ist jetzt mein Problem:

    bei Starten von TB erfolgt kein automatischer Abruf mehr und Nachrichtenfenster wird immer wieder eingeblendet; natürlich habe ich bereits erledigt:

    - Konteneinstellungen -> Kontenaktionen-> als Standard festlegen

    - bei Server-Einstellungen "Beim Starten auf neue Nachrichten prüfen" Haken weggenommen und erneut gesetzt

    - mit "F8" und auch per Maus im Menu unter: Ansicht -> Fensterlayout-> Nachrichtenbereich den Nachrichtenbereich ausgeblendet


    Erfolg: Null


    Erfolgreich konnte ich das Starten mit Order Papierkorb beenden, per Add-on "Manually Sort Folders" und dann damit im TB-Menü auswählen: Extras-> Konten- und Ordnerreihenfolge ändern-> Erweitert-> Zuletzt geöffneten Ordner verwenden


    Die Methode, Thunderbird zu deinstallieren, und dann neu zu installieren, hat auch nicht geholfen.


    Mir fällt jetzt nur noch ein, dass ich mit dem Ad-on "ImportExportTools NG" alle Mailordner rauskopiere, Thunderbird komplett lösche (einschließlich Profilordner) und dann alle Konten neu einrichte und nur die Mailordner wieder übernehme. Ich scheue aber den Aufwand, weil ich eine ganze Menge Ordner und Konten habe ...


    Gibt es eine Methode, einen Thunderbird "Refresh" oder "Reset" durchzuführen, wodurch man die geschilderten Probleme in Ordnung bringen kann, ohne den Aufwand der gerade geschilderten 'Radikallösung'?


    Ich bin für alle Tipps dankbar!

    Bei mir gab es das gleiche Problem - habe jetzt das Enigmail Add-on deaktiviert, und jetzt geht wieder alles. Also: Einstellungen für Quicktext unter Extras -> Add-on-Einstellungen, und auch der Knopf im "Verfassen"-Fenster ist wieder vorhanden.


    Grüße,

    Steffan

    ... ich stimme Dir zu - ich hatte die Seite von Paolo Kosmos noch nie durchgelesen, er erklärt das dort tatsächlich, dass er den Aufwand der Anpassung an die WebExtensions nicht mehr betreiben will.


    Na gut, ohne "DontRestoreTabs" kann man schon auskommen (und braucht halt einen Extra-Klick für das Schließen der Tabs), aber kennt jemand einen Ersatz für das Add-on "ExportImportTools" (das zwar derzeit noch funktioniert, aber demnach absehbar ebenfalls nicht mehr lange). Dieses brauche ich zwar eher selten, aber wenn, dann werde ich es sicherlich vermissen (von Hand einzelne Mail-Ordner von TB rumzukopieren halte ich für kein akzeptables Work-around - und wüsste noch nicht mal, ob es ohne weiteres möglich ist).


    Gruß

    Steffan


    P.S.. noch ein off-topic: gibt es einen Mechanismus, der (deaktivierte) Add-ons aus TB entfernt ? Ich finde zwar noch einige deaktivierte Add-ons in der Liste, aber das "DontRestoreTabs" nicht mehr - ich kann mich aber nicht erinnern, es heute gelöscht zu haben.

    ... leider geht seit dem Update auf TB 60 das "dontrestoretabs" nicht mehr !


    Schaut man hier

    https://addons.thunderbird.net…dontrestoretabs/versions/

    und vor allem hier (homepage des Entwicklers)

    https://freeshell.de/~kaosmos/index-en.html

    muss man befürchten, dass der Entwickler dieses Add-on nicht mehr weiterentwickeln (bzw. pflegen) wird (weil: dieses Add-on ist auf seiner Homepage nicht zu finden)


    Sehr schade - ich habe schon mal gespendet an ihn als Motivationshilfe mit entsprechendem Kommentar. Vielleicht sieht das jemand genauso, und spendet auch (oder schreibt ihm eine E-Mail).


    Ansonsten:

    Ich finde es erstaunlich, dass so eine "Basisfunktion" (finde ich .. ) nicht im TB selbst eingestellt werden kann. In Firefox kann und konnte man das schon immer einstellen. Vielleicht sollte man mal die Entwickler bitten, das noch nachzuholen.

    Scheint ein Bug zu sein, der bisher noch nicht gelöst werden konnte:

    https://bugzilla.mozilla.org/show_bug.cgi?id=1106251


    Diese popstate-n.dat sind dann offenbar zusätzlich in der GUI ganz links bei den Konten zu sehen (unter "attachments" kann man bei dem Link s.o. zwei Bilder dazu anschauen).


    Grüße



    P.S. möglicherweise hat es was mit Dropbox zu tun, das sich nicht gut mit Thunderbird "versteht". Falls du das verwendest, vielleicht ist das die Antwort auf dein Problem


    https://www.dropboxforum.com/t…pstate-issues/td-p/255886

    Der eingestellte Bug ist ein Duplikat - also dort bereits seit einigen Wochen bekannt.


    Hier dieser bekannte Bug
    https://bugzilla.mozilla.org/show_bug.cgi?id=1314236


    Wie erwähnt, entsteht das Problem nur, wenn man einen "clean install" macht, also Thunderbird ohne bestehendes Profil installiert. Beim
    Migrieren mit Importieren des alten Profils entsteht das Problem also nicht. (Problem entsteht aber auch beim Erstellen eines neuen Profils per Profilmanager)


    Zur Behebung des Problems kann man (wie bereits oben erwähnt) eine Version vor der 45.5.0 installieren (das Problem tritt erstmals bei der 45.5.0 auf), also z.B. diese hier
    http://ftp.mozilla.org/pub/thu…rd/releases/45.4.0/win32/


    Auf Bugzilla wird als workaround vorgeschlagen, in der Datei pref.js den Eintrag mail.winsearch.firstRunDone auf true zu setzen, bzw. dort folgende Zeile einzufügen:


    user_pref("mail.winsearch.firstRunDone", true);


    Habe es ausprobiert - funktioniert !


    Grüße

    Hallo,


    versuchs doch mal so:
    - kopiere den Profilordner vom deinem NAS in das übliche Standard-Verzeichnis von Thunderbird (Achtung: beim Kopiervorgang muss Thunderbird geschlossen sein, weil sonst einige Dateien gesperrt sind und nicht kopiert werden können)
    - per Profilmanager dieses Profil im Thunderbird hinzufügen
    Profilordner - Sichern und aus Backup wiederherstellen


    Ich bevorzuge normalerweise das Verfahren, das in folgendem Link im letzten Absatz auf der Seite beschrieben wird.
    http://www.at2907.net/tipps1/tipp15.php


    Grüße

    Hallo,


    also, ich kann das Problem von Sonja bestätigen:
    es tritt offenbar erstmals für diese derzeit neue Version Thunderbird 45.5.0 bei einer Neuinstalation auf (Einrichten eines neuen Profils per Profilmanager erzeugt auch diesen Fehler).
    (Betriebssystem Win 10 Pro)


    Ich habe irgendwo im Forum (älterer Post) schon mal so was ähnliches gelesen, und die dort beschriebe Vorgehensweise hilft weiter:
    - eine ältere Version von Thunderbird installieren
    - Thunderbird starten bzw. ein Profil erstellen (muss nicht komplett sein), es genügt, wenn der Thunderbird akzeptiert hat, dass er der Standard-Client ist (erkennbar daran, dass nach Schließen und Öffnen keine Abfrage mehr kommt); am besten aber evtl. für eine E-Mail-Adresse fertig einrichten
    - jetzt kann man entsprechend Updaten (in meinem Fall: mehrmals jeweils durch Klicken auf "Hilfe" -> über Thunderbird bis man auf der aktuellen Version landet) der Fehler tritt jetzt auch hier nicht mehr auf (= keine neue Abfrage nach Standard-Client mehr) evtl. kann man auch die aktuelle Version herunterladen und über den eingerichteten Thunderbird drüberinstallieren und erhält den Thunderbird in der aktuellen Version ohne dieses Problem.


    Das einzige, was mich wundert, ist, dass das Internet nicht voll ist von anderen, die auch dieses Problem haben (ist sonst bei ähnlichem immer der Fall). Ich habe zumindest nichts in dieser Art gefunden.


    Grüße,
    Steffan


    P.S.: dieses Problem tritt nicht auf bei Thunderbird 45.5.0, wenn er auf Windows XP läuft (gerade getestet...)