Posts by anton

    Die Hintergründe der Änderungen (Mozilla und Thunderbird getrennt, dann doch wieder nicht, dann Umstellung der Codebase wegen Quantum usw...) sind mir in groben Zügen durchaus bekannt. Es ist nur leider oft zu bemerken, dass etwas auf neue Beine gestellt wird, ohne die Funktionalität aus der "alten" Version sicherzustellen. DAS bemängele ich.


    Meine Kritik mit "Open Source" war zugegebenermaßen sehr pauschal, gefühlt zieht sich das aber bei Linux durch alle Bereiche (Gnome 4, Wayland, Ghostscript, ...).


    Ob ich nach 16 Jahren Linux um Betrieb wirklich nur dumm bin?


    Du solltest auf Deine Wortwahl achten, sie wirkt etwas unprofessionell.

    Danke für Deine Mühe. Abbruch und Fehlermeldung sind keine Option, weil dann im Support das bekannt "Programm kaputt" aufschlägt.

    Wieder mal so ein Beispiel, wie Open Source durch die eigenen Leute sabotiert wird. :(

    Die gibt es (noch) nicht.

    Und in der 91'er Version? Ich kann mir kaum vorstellen, dass bewährte Funktionalitäten einfach entfernt werden. Thunderbird läuft auf einem Produktivsystem im Gesundheitswesen. Da möchte ich doch nicht, dass die Leute etwas versehentlich nicht verschlüsseln. Genausowenig möchte ich einen Mailclient (68'er), der keine Sicherheitsupdates mehr bekommt.

    78.3.1

    Linux, Fedora 34

    POP

    gpg (GnuPG) 2.2.25, libgcrypt 1.8.8


    Nach dem Update von 68 auf 78 suche ich die Empfängerregeln für die gpg Verschlüsselung. Wo finde ich die? Die ganze Integration sollte gegenüber der 68'er mit Enigmail ja eine Verbesserung sein ??

    Ist tatsächlich ein Fehler in Thunderbird. Im Mail-Entwurfsfenster wird bei neuen E-Mail bei der Auswahl der Mailkonten die Identität nicht umgeschaltet.


    Etwas umständlicher Workaround:

    • Mail mit dem ausgewählten Konto und der falschen Identität zunächst an sich selber schicken.
    • Dann Mausrechtsklick und "Als neu bearbeiten" auswählen.
    • Da nun im Entwurfsfenster das Mailkonto nicht mehr ausgewählt, sondern bereits richtig vorbelegt ist, stimmt auch die Identität zum Konto und es wird die passende Signatur (Zertifikat) benutzt.

    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 68.4.1 (64-Bit)
    • Betriebssystem + Version: Linux Fedora 30
    • Kontenart (POP / IMAP): POP3
    • Postfach-Anbieter (z.B. GMX): selbst
    • Eingesetzte Antiviren-Software: keine
    • Firewall (Betriebssystem-intern/Externe Software): Betriebssystem


    Zustand:

    4 verschiedene Mailkonten im maildir Format und Speicherung aller Nachrichten in Unterordnern des "Lokalen Ordner":


    Problem beim Schreiben neuer Mails:

    Alle vier Konten haben scheinbar die selbe Identität, nämlich die des in der Auswahlliste der neuen Mail ersten Kontos.



    Wenn ich nun im Entwurfsfenster bei ausgewählten Absenderkonto xxx@xxxysio.de die

    Enigmail -> Einstellungen -> Signatur-/Verschlüsselungsoptionen aufrufe





    Erscheint die Identität des ersten Kontos xxxqxxxily.de



    Diese wird auch beim Versenden benutzt, was dann zu falschen Ergebnissen führt.



    Was ist die Ursache für diesen Fehler?

    Es hat sich gezeigt, dass der Fehler nicht bei Enigmail lag. Vielmehr war wohl der Profilordner nicht mehr in Ordnung. Er wurde vor 2012 mit dem Umstieg von Evolution auf Thunderbird eingerichtet und stets durch die ganzen Updates mitgeschleppt.

    Eine Neuinstallation mit neuen Profilordner war die Lösung.


    Es wäre wünschenswert, wenn der Einrichtungsassistent zuallererst das Mailformat (mbox oder maildir) abfragen würde, weil es nach der Kontoeinrichtung nicht mehr ohne Aufwand für den Bestand zu ändern ist.

    • Thunderbird-Version: 68.2.2
    • Betriebssystem + Version: Linux Fedora 30
    • Kontenart (POP / IMAP): POP3
    • Postfachanbieter (z.B. GMX): Hoster
    • S/MIME oder PGP: beides
    • Eingesetzte Antivirensoftware: keine
    • Firewall (Betriebssystem-intern/Externe Software): BS


    Zwei Mailkonten: a@1234.de und b@5678.de (sind in echt natürlich anders)

    Keine zusätzlichen Identitäten ausser der betreffenden Standardidentität.

    Gleicher SMPT und POP3 Server, jedoch andere Nutzer und Passwörter, SMPT-Port 465 und POP3 Port 995, beide SSL/TSL


    Problem: Beim Senden mit b@5678.de wird das S/MIME Zertifikat von a@1234.de verwendet.

    Die Schlüssel sind korrekt und explizit zugeordnet.


    Obwohl OpenPGP Unterstützung testweise bei b@5678.de deaktiviert ist


    wird beim Versand pgp-inline Verschlüsselung und das Signieren aktiviert:



    Deaktiviere ich das und signiere die Nachricht mit S/MIME, wird das Zertifikat von a@1234.de verwendet.

    Erst das zusätzliche Deaktivieren der OpenPGP Unterstützung in a@1234.de bewirkt, dass die ausgehende Mail von b@5678.de die korrekte eigene S/MIME Signatur bekommt.


    Wie lässt sich das ändern?

    Das stimmt schon, weil ich bei einer meiner Mailadressen aus historischen Gründen OpenPGP verwende und deshalb das Plugin installiert habe.

    Ich sehe aber gerade, dass dort bei "Automatische Updates" die Einstellung "Standard" ist und scheinbar zuletzt am 26.03.2018 eine Aktualisierung stattfand. Das passt zumindest zeitlich zum geschilderten Sachverhalt.


    Es scheint tatsächlich so zu sein, dass das Plugin seit dem letzten Update sich nicht mehr mit S/MIME verträgt. Ich habe das Plugin deaktiviert und nun klappt der Versand.


    Vielen Dank für den Tip!

    • Thunderbird-Version: 52.6.0 (64-Bit)
    • Betriebssystem + Version:Linus CentOS 7
    • Kontenart (POP / IMAP):POP

    Meine E-Mail Adresse hat ein S/MIME Zertifikat zum unterschreiben und verschlüsseln:




    Zum Versand (SMPT) wurde die Verschlüsselung ausgestellt und "unterschreiben" eingestellt.

    Der Versand scheitert:



    Das ist schon richtig, weil der Empfänger kein Zertifikat hat.

    Beim erneuten nachschauen war zusätzlich zum unterschreiben auch verschlüsseln angekreuzt, obwohl das vor dem Versand explizit deaktiviert war!


    Erst ohne dem Häkchen beim "Unterschreiben" kann die Nachricht versandt werden, dann allerdings ohne Zertifikat.


    Woran kann das liegen?

    Hab das nun so gelöst, dass ich Thunderbird per Script starte. Vor dem Start von Thunderbird schreibt das Script mit xclip die Formatierungsanweisung in die Zwischenablage und startet dann erst Thunderbird.

    Wenn ich nun eine neue Mail verfasse oder eine beantworte, brauche ich nur in der HTML-Ansicht einen Klick mit der mittleren Maustaste im header-Bereich machen und der Inhalt der Zwischenablage wird eingefügt.

    Version 52.2.1, Linux, POP


    Wenn ich eine html-EMail beantworte, kommt es häufig vor, dass die falsche Schriftart (meist Times NR) angezeigt wird.

    Um das zu ändern, muss ich im Header stets "<style>.fonts {font-family: "Lucida Sans Unicode";}</style>" angeben und im Body meinen Text mit "<div class="fonts">Mein Text</div> einrahmen.


    Das ist auf Dauer lästig.

    Frage: Wie lässt sich die Standardvorlage von Thunderbird so ändern, dass bei neuer Mail oder Antwortmail diese Formatierungsanweisung schon enthalten sind?