Posts by 2bein

    Ich habe den Schlüssel wieder importiert und kann zumindest die Entwürfe wieder (verschlüsselt) abspeichern. Hilft das vielleicht kurzfristig?


    Ich hab in bugzilla mit den Leuten etwas diskutiert https://bugzilla.mozilla.org/show_bug.cgi?id=1666846


    Herausgekommen ist nur, dass es so gewollt ist, dass die Entwürfe verschlüsselt werden (kein Bug, sondern by Design!). Vielleicht bauen Sie irgendwann noch einen Schalter wieder ein (wie es ja eigentlich bei Enigmail vorhanden war).


    Bei mir ist wahrscheinlich durch den Import der Enigmail-Einstellungen in TB78 und meinem strukturierten Schlüssel einiges schief gelaufen, sodass ich TB und meine Konten komplett neu aufsetzen werden muss (ohne PGP). Bei sind auch die Keys bzw. OpenPGP nicht mehr deaktivierbar und wen ich die Schlüssel lösche, bleiben die Entwürfe verschlüsselt oder es kommt zu der oben genannten Fehlermeldung beim abspeichern (wie gesagt, re-import des Keys hat geholfen). In der Arbeit benutze ich zusätzlich SMIME, und da kann ich OpenPGP und auch die Verschlüsselung an sich völlig abwählen. Daheim ohne SMIME-Zertifikat geht das nicht, auch nicht für OpenPGP!? Also alles etwas komisch, sodass ich bei Gelegenheit eine Neuinstallation probieren werde, aber mit OpenPGP werden die Entwürfe wohl default verschlüsselt ohne Möglichkeit, das zu ändern.


    Ich habe allerdings in den Einstellungen... Konfiguration bearbeiten... (ganz unten) eine Einstellung gefunden "mail.identity.id#.autoEncryptDrafts" und diese auf "false" gestellt. Hilft aber nichts. Erst wenn ich "mail.identity.id#.mimePreferOpenPGP" auf 0 stelle, wird die Verschlüsselung komplett abgestellt, ist aber derselbe Effekt, den ich oben beschrieben habe. Hier kann man evtl noch andere Schalter probieren, wenn man eh damit rechnen muss, TB und die Konten neu zu installieren - hab aber grad leider keine Zeit.

    Es ist halt ein gutes Stück "Neuland" ;-)

    Ja, das scheint so, leider auch nach über 15 Jahren PGP ;(;(;(. Mein Problem ist nach vielem rumprobieren so vielschichtig und verwirrend geworden (s. auch Nachtrag oben), dass ich es hier kaum beschreiben kann, was ich aber unten nochmal ausführlich versuchen will. Das HAUPTPROBLEM ist dennoch ersichtlich bei mir: Es gibt es wohl KEINE Möglichkeit, die Verschlüsselung von Entwürfen abzuschalten (wohlgemerkt nach einer evtl. fehlerhaften Migration von Enigmail), ob meine Schlüssel nun stimmen oder nicht. Und das ist für mich wohl nun ein Zwang zum Downgrade (falls eine komplette Neuinstallation nicht hilft), da ich Entwürfe am Handy weiterbearbeiten können muss.


    So, nun zu den Details, die vielleicht zur Eingrenzung des Problems helfen, falls jemand das überhaupt reproduzieren kann:


    Ich habe im Moment einen PGP-Schlüssel mit 3 Identitäten/email-Adressen, Hauptidentität X und Alias Y und Z. Dazu waren im alten TB 3 Konten angelegt

    A) Konto Identität X mit OpenPGP und S/Mime Schlüssel (dienstlich)

    B) Konto Identität Y mit OpenPGP

    C) Konto Identität Z mit OpenPGP


    Nach der Migration erscheint in den Einstellungen "Ende-zu-Ende-Verschlüsselung" zu Konto A die Möglichkeit, im Abschnitt "OpenPGP" 2 Felder mit Radiobuttons zur Auswahl von "Keiner" oder "0x0...". Manchmal erscheint beim Öffnen der Optionen kein Feld ausgewählt, auch nach einer vorigen Auswahl (Schon das riecht nach Bug)! Wenn ich nun den "0x0..." Schlüssel auswähle und weiter unten "Automatische Auswahl" oder "OpenPGP bevorzugen" wähle, werden die Entwürfe verschlüsselt (wohlgemerkt, Verschlüsselung ist deaktiviert in den Optionen des Nachrichtenfensters). Wenn ich nun "Keiner" auswähle, werden die Entwürfe NICHT verschlüsselt, das ist wie erwartet!

    Im Abschnitt S/Mime ist der vorhandene Schlüssel erfolgreich eingetragen/migriert. Wenn ich unten "S/MIME" bevorzugt auswähle, werden die Entwürfe auch NICHT verschlüsselt (ich kann sie in K9 problemlos bearbeiten). Soweit kann ich mit diesem Konto arbeiten zumindest, aber es kann sein, dass der Grund für die nicht-verschlüsselung nur ist, dass das S/MIME-Kryptographie-Modul (Dongle) beim Speichern des Entwurfs nicht aktiv ist :/.


    Bei Konto B sieht es in den Einstellungen seltsam anders aus. Hier habe ich NICHT die Radiobutton Auswahl ob "Keiner" oder einen gültigen Schlüssel! Obwohl anscheinend kein Schlüssel migriert wurde (Problem Nebenidentität ist nicht Konto-Adresse?), wurden die Entwürfe verschlüsselt, und ich konnte sie nicht mehr öffnen bzw. waren leer (lokal und auf einem anderen Clienten). Nachdem ich den Schlüssel manuell importiert habe, ist aber trotzdem keine Radiobutton-Auswahl erschienen, um diesen Schlüssel wieder abzuwählen (seltsam, oder?). Ich kann auch diesen Schlüssel nicht mehr entfernen (Das ist noch seltsamer!!!). [Nebenbemerkung: Die Konten-Adresse Y entspricht nicht der Hauptidentität X des Schlüssels, aber der Nebenidentität Y, dass TB hier Probleme hat habe ich hier auch schon bei Susi gelesen und sollte unbedingt behoben werden.]

    Dennoch, verschlüsselte Entwürfe konnte ich nun zumindest lokal wieder (weiter)bearbeiten (nicht in K9, K9 sieht nur ein verschlüsseltes Attachment, das liegt wohl an K9).

    So, im Abschnitt "S/MIME" sollte eigentlich ja kein Schlüssel migriert werden, aber da steht nun unter "Persönliches Zertifikat für Verschlüsselung" MEIN NAME. Dann kann ich unten auch "S/MIME" als bevorzugte Verschlüsselung auswählen, und seltsam: dann werden die Entwürfe NICHT verschlüsselt.

    So, Problem mit diesem Workaround: Wenn ich in S/MIME das seltsame Zertifikat "Leere" (kein Name mehr im Feld), dann kann ich unten auch nicht mehr S/MIME-Bevorzugung auswählen, und meine Entwürfe werden zwangsweise verschlüsselt.


    Noch seltsamer: Nach mehrerem hin und herklicken (beenden und neustart von TB) erscheint auf einmal wieder unter S/MIME wie von Geisterhand mein Name in dem Feld des Persönlichen Verschlüsselungszertifikat und ich kann S/MIME wieder bevorzugt auswählen, die Entwürfe werden dann nicht verschlüsselt (es sei denn ich wähle OpenPGP-Bevorzugung oder Automatisch).


    Konto C verhält sich wie B.


    Ebenso das gleiche Verhalten auf meinem Laptop und auf einem alten Windows 7-Rechner... Sorry für das ganze Gelaber, aber ich musste das von der Seele reden, bin sehr traurig, dass meine 15-jährige Hoffnung für eine Jedermann-Verschlüsselungs-Implementierung schon wieder zurückgedrängt wird. Wenn es hier schon solche Probleme gibt, warum soll ich meiner Frau und Kinder denn noch beibringen, wozu man überhaupt Schlüssel generiert und es dann kaum jemand nutzt ||



    Kann es sein, dass die Verschlüsselungseinstellungen nicht sauber von Konto zu Konto getrennt sind? Oder hat die Enigmail-Migration was total durcheinander gewürfelt in der config? Wenn ich Zeit finde, werden ich eine Komplette Neuinstallation ohne Enigmail-Migration probieren...:wall:


    Schönes Wochenende!

    (Danke an den Moderator für das Abzweigen des Themas!)


    OpenPgp funktioniert normal. Jetzt, nachdem ich nochmal den Schlüssel abgewählt und wieder angeklickt habe, kann ich nun neue gespeicherten Mails wieder in TB bearbeiten, aber ich habe weiter das Problem, das ich diese Entwürfe NICHT in K9-Mail in Android bearbeiten kann (Schlimmer noch, wenn ich das versuche, ist der Betreff und Text komplett weg). Die Entwürfe in K9 erscheinen als NICHT-verschlüsselt, aber es sind Unterschrift und Schlüssel als ANHANG dran - da ist doch was faul beim Abspeichern der Entwürfe, oder warum kann K9 das nicht erkennen???


    Auch aus diesem Grund will ich die Entwürfe NICHT verschlüsselt speichern oder zumindest die Möglichkeit haben, dies individuell abzuwählen. Wie gesagt, ich habe die Verschlüsselung standard-mäßig ABgeschaltet. Gibt es keine Möglichkeit, das Speichern von Entwürfen dahingehend zu beeinflussen? OK workaround ist, dass ich den Schlüssel in den Einstellungen komplett deaktiviere, aber das kann es ja auch nicht sein.


    Ich habe leider seit ich PGP benutze (bin seit den Anfängen von PGP dabei) VIEL mehr Zeit verschwendet in die Konfiguration meiner email-Clienten oder Add-Ons als dass ich für das Verfassen von verschlüsselten Mails benötigt habe (auch mangels Empfänger mit Schlüsseln). Jetzt hatte ich so sehr gehofft, dass TB das mit der Integration schafft und habe schon wieder unverständliche Probleme...



    Nachtrag: Jetzt ist das Problem noch schlimmer, nachdem ich in einem Konto die Schlüssel gelöscht habe (OpenPGP und S/MIME, in S/MIME stand nur mein Name drin!?). Jetzt kann ich gar keinen Entwurf mehr speichern, es kommt die Fehlermeldung "Beim Speichern des Entwurfs trat ein Fehler auf. - Die konfigurierte Schlüssel-ID '0x0...' wurde nicht in Ihrem Schlüsselbund gefunden". Was soll das, ich habe keinen Schlüssel mehr konfiguriert - wo nimmt Thunderbird diesen Schlüssel her???


    Thunderbird-Version (konkrete Versionsnummer): 78.2.2

    Betriebssystem + Version: Windows 10

    Kontenart (POP / IMAP): IMAP

    Postfachanbieter (z.B. GMX): Privat PGP-Software / PGP-Version: OpenPGP

    Eingesetzte Antivirensoftware: n.a.
    Firewall (Betriebssystem-intern/Externe Software): n.a.


    Ich habe ein großes Problem mit dem Bearbeiten von ENTWÜRFEN nach der Migration von Enigmail und meinen OpenPGP Schlüsseln!!! Obwohl ich die Verschlüsselung standardmäßig abgeschaltet habe, werden die Entwürfe anscheinend verschlüsselt gespeichert: Im Betreff steht dann nur "..." und jeglicher Text ist unwiederbringlich verloren ;(;(;(:cursing:. Es kommt keine Abfrage des Passworts und ich sehe keine Möglicheit, die gespeicherten Entwürfe wieder zu bearbeiten (auch am Smartphone mit K9 und installierter Krypromodulen!). Was ist da los. Ich muss doch die Verschlüsselung irgendwo in den Einstellungen komplett abschalten können, vor allem für die Speicherung von Entwürfen!?


    Haben andere noch die Erfahrung oder Lösungen?


    LG 2bein


    Edit: Ich habe obigen Beitrag aus dem ursprünglichen Thread abgetrennt. graba, Gl.-Mod.