Problem mit Thunderbird & Proxy

  • Guten Morgen liebe thunderbird Freunde.
    Ich stelle hier weniger eine Frage,
    vielmehr möchte ich eine Antwort geben.
    Die Antwort richtet sich an alle, die auch nach ewigen wälzen
    der unzähligen Forenseiten keine antwort erhielten.
    Wie viele hier im Forum schon berichteten,
    tauchen bei der Verwendung von Thunderbird
    hinter einem Proxy Verbindungsprobleme auf.
    Wie ich leider feststellen musste,
    gibt es nur geringfügig brauchbare Antworten.
    (oft gespickt mit kleinen Herzlichkeiten
    oder Tips zum Kauf einer "besseren" Firewall
    oder gar vorschläge für andere Betriebssysteme)
    Da ich selber aber ebenfalls eine Antwort suchte,
    habe ich mich einfach mal wild auf die
    "erweiterte Thunderbird Config" gestürzt.
    (nachdem Tips aus diesem Forum wie
    "lösche die angaben der lokalen Proxy umgehung"
    von mir ausprobiert und als untauglich abgehakt wurden).


    Lösung:


    Öffne die Thunderbird Konfiguration,
    gehe in die "Proxy Einstellungen"
    trage dort deine Proxydaten ein [siehe Bild]
    [IMG:http://file-base.de/files/0101.jpg]
    Danach musst du TB ein wenig auf die Sprünge helfen
    (fragt mich nicht wie ich auf die Idee kam das so einzustellen)
    Öffne im Konfiguratonsmenue von thunderbird den Tab
    "Erweitert" und klicke im unteren Teil auf "Konfiguration bearbeiten".
    Um eine bessere Übersicht zu bekommen,
    lassen wir uns lediglich die Proxy settings anzeigen
    und ändern die Variablen gemäss dem folgenden Bild.
    (beachtet auch hier wieder,
    dass ihr nicht meine Proxydaten angebt
    sonst steht Ihr wieder am Anfang)
    Das wohl entscheidende Flag ist die Zeile network.proxy.socks_version
    die ich von standard 5 auf 4 gesetzt habe
    (ich habe bei mir im Lan zwar die freie Wahl der Waffen
    (Socks4/5 od. Http), jedoch funktionierte socks 5
    mit der alten Einstellung nicht.
    Seit ich die TB socks version auf 4 habe,
    kann ich sowohl socks 4 wie auch socks5 nutzen
    **da strahlt einem die IT Logik entgegen**)
    [IMG:http://file-base.de/files/0202.jpg]
    Wenn Ihr nun eure Proxydaten richtig eingegeben habt,
    habt ihr es geschafft.
    Schliesst die Konfiguration
    und habt spass mit eurem TB.
    (ich habe die hier verwendete Einstellung
    sowohl über Socks (mit/ohne Auth.)
    wie auch über HTTP getestet
    und sie funktioniert tadellos.



    p.S. Ich hoffe ich bin mit diesem Beitrag
    niemandem zu nahe getreten und hoffe,
    dass er einigen weiter hilft.


    p.S.2 sollte mir jemand eine Erklärung
    zum oben beschriebenen Kuriosum geben können,
    wäre ich mehr als dankbar.
    Andernfalls geniesse ich stillschweigend meinen funktionierenden TB.


    Keep Living-Fruity

    Einmal editiert, zuletzt von LinuBo ()

  • Hallo LinuBo,


    hat es bei der Konfiguration nicht ausgereicht den Haken "Für alle Protokolle den selben Proxy verwenden" heraus zu nehmen und die Konfiguration für den Socks und den SSL-Proxy manuell dort einzutragen? Immerhin ist ja der Port für SSL bei dir nicht 1080 sondern 808 und damit nicht identisch mit der oben zentral angegebenen Einstellung.


    Was ich bestätigen kann ist, dass die Einstellung "Für alle Protokolle den selben Proxy verwenden" regelmäßig zu Problemen führt, wenn es nicht wirklich einen Socks-Proxy mit der gleichen Einstellung gibt - oder es gar keinen gibt.


    Wenn du das aber schon probiert hast, ist das warscheinlich ein Bug... bzw. eine fehlende Einstellmöglichkeit in den Verbindungseinstellungen des TB.



    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Hallo Toolman,


    Ich habe wirklich ungelogen mehrere Stunden
    am TB rumgeschraubt.Da ich es leid war,
    jedesmal das Notebook im LAN vor den Proxy zu bringen
    (ist ja nicht Sinn der Sache)
    Ich probierte jede Variante der Socksdaten
    in jeglicher Kombination mit/ohne Haken
    bei der "Für alle Protokolle den selben Proxy verwenden" Option,
    mit Socks4/5 und HTTP (es ging garnichts,
    jedesmal waren die Hosts unerreichbar
    und mein Proxylog verzeichnete nicht einmal eine Anfrage).
    Ich selber kann es mir garnicht erklären, wieso dies nicht wie z.B. beim Firefox funktionierte.
    Aber ich bin wirklich "happy" dass es nun endlich funktioniert.

  • Liegt es an mir oder sind die Bilder tatsächlich nicht mehr auf dem Server? Wenn es nicht an mir liegt, was war denn auf den Bildern zu sehen? Ich hab nämlich das gleiche Problem...

  • Also die Bilder liegen wirklich nicht mehr auf dem Server.
    Mal abgesehen davon, dass der Thread von 2006 ist.
    Hatte die Bilder "damals" noch einmal bereitgestellt.
    Dies ist nun aber auch schon mehr als ein Jahr her.
    Zudem ist mein Problem bei einer durchaus älteren Version aufgetreten.


    Auf den Bildern waren Snapshots der "about:config" Sektion zu sehen.


    Vorweg. Nein, ich habe die Bilder nicht mehr. Ich kann leider die Settings nicht mehr nachvollziehen,
    da es wie gesagt eine ältere Version war und ich seit langer Zeit nicht mehr mit einem Proxy arbeiten muss.
    Tut mir mir leid.

  • naja, trotzdem danke für die prompte Antwort, ich werd dann mal weiter probieren, vielleicht läuft mir die lösung ja über den weg...