Schlüsselverwaltung funktioniert nicht

  • Ich benutze GnuPG 1.4.7, Thunderbird 2.0.0.0 und Enigmail 0.95.1 (Da ich alles drei heute erst runtergeladen habe, gehe ich davon aus, alles ist auf dem neuesten Stand)


    Nun habe ich das Problem, dass ich die Schlüsselverwaltung gar nicht nutzen kann.
    Wenn ich diese Schlüssel mit WinPT importiere, werden sie dort korrekt aufgeführt und die Verschlüsselung funktionierte unter Outlook auch wunderbar (naja, so gut wie, aber das tut nichts zur Sache ^^). Jedoch in der Enigmail Schlüsselverwaltung werden keine Schlüssel aufgeführt. Versuche ich dann diese Schlüssel dort zu impoertieren, gibt er mir die Rückmeldung, dass die SChlüssel bereits vorhanden seien.
    Und auch, wenn ich aus WinPT die Schlüssel herauslösche, und sie dann in Enigmail neu importiere, dann sagt er mir zwar, dass sie importiert wurden, jedoch werden sie weiterhin nicht aufgeführt.
    Und auch meine Versuche, mithilfe der - ja angeblich vorhandenen - Schlüssel zu verschlüsseln schlägt kläglich fehl - sobald ich auf Senden klicke gibt er mir eine Fehlermeldung zurück, ich solle meine Kontoeinstellungen überprüfen (an denen es nicht liegen kann, da ohne Verschlüsselung alles klappt)


    So, ich hoffe ich habe alle Probleme ausführlich genug geschildert...
    Danke schon einmal für eventuelle Antworten!

  • Zitat

    Ich benutze GnuPG 1.4.7, Thunderbird 2.0.0.0 und Enigmail 0.95.1 (Da ich alles drei heute erst runtergeladen habe, gehe ich davon aus, alles ist auf dem neuesten Stand)


    Sieht so aus.
    Dein Betriebssystem wäre noch interessant.
    Wir haben hier gerade einen ähnlichen Fall (wenn auch noch ungelöst), kannst dich ja mal dort belesen,
    http://www.thunderbird-mail.de…ic.php?t=28313&highlight=


    m.

  • Ich habe das gleiche Problem: XP Home SP2; TB 2.0.0.4; GPG4Win 1.1.0; Enigmail 0.95.1


    GPG funktioniert. Schlüssel werden mit GPA und WinPT problemlos angezeigt. Enigmail zeigt keinen Schlüssel an und meldet beim Import, dass der Schlüssel bereits vorhanden ist. Interessant ist aber der Konsolenauszug:


    enigmail> C:\Programme\GNU\GnuPG\pub\gpg.exe --charset utf8 --batch --no-tty --status-fd 2 --with-fingerprint --fixed-list-mode --with-colons --list-keys
    gpg: error reading key: public key not found


    enigmail> C:\Programme\GNU\GnuPG\pub\gpg.exe --charset utf8 --batch --no-tty --status-fd 2 --with-fingerprint --fixed-list-mode --with-colons --list-secret-keys
    gpg: error reading key: secret key not available


    Enigmail versucht gpg mit den Parametern "--charset utf8 --batch --no-tty --status-fd 2 --with-fingerprint --fixed-list-mode --with-colons --list-secret-keys" zu starten, was auch im DOS-Prompt fehl schlägt. Woher kommen diese Befehlszeilenparameter?


    MfG
    Markus Voigt

  • Hallo Markus, willkommen im Forum.


    "MVoigt1971" schrieb:

    Ich habe das gleiche Problem: XP Home SP2; TB 2.0.0.4; GPG4Win 1.1.0; Enigmail 0.95.1


    Möglicherweise ist das doch ein anderes Problem denn im Gegensatz zu Merovius benutzt du GPG4Win.


    Wichtig: Bitte beachten: Enigmail und GPG4Win


    Gruß
    Werner

  • Ja, ich gebe Dir recht, doch in der GPG4Win ist das GPG 1.4.7 enthalten und wird auch durch Enigmail genutzt.


    Gruß Markus

  • Hallo Markus,


    falls es dir entgangen sein sollte, meine letzte Antwort enthält einen Link.
    Hast du den verlinkten Beitrag gelesen?


    Gruß
    Werner

  • Au Backe, das ist mir in der Tat entgangen. Ich werde es gleich ausprobieren und mich wieder melden.


    Gruß
    Markus