Problem mit Verschlüsselung und IMAP


  • Hi!
    Hab seit kurzem ein merkwürdiges Problem beim Entschlüsseln von IMAP Nachrichten.


    Wenn ich Nachrichten mit Anhang verschlüssle (mit pgp/mime) und mir schicke, kann ich diese nicht mehr vollständig laden.


    Normalerweise habe ich meine Passphrase eingetippt, worauf ein Hinweis kam, daß die Nachricht zum Entschlüsseln komplett vom Server geladen werden muss... Nach der Bestätigung konnt ich die Nachricht dann ganz normal lesen, bzw. ihren Anhang speichern und ansehen.


    Seit neustem (ich nehme an mit Thunderbird 2.0.0.4), kommt nicht mehr der Hinweis, daß die Nachricht komplett vom Server geladen werden muss, sondern nur noch die Fehlermeldung "IMAP-Nachricht ist zu gross zum Enschlüsseln".


    Das kann zum einen nicht sein, weil es auch mit 300 KB Dateien nicht klappt... zum anderen, weil ich selbst alte Nachrichten, bei denen die Entschlüsslung/Speicherung schon funktioniert hatte, nicht mehr lesen/speichern kann.


    Sende ich die Nachricht mit Anhang unverschlüsselt, läuft alles ganz normal.


    Hat irgend jemand ne Idee woran das liegen könnte?


    Jargo

  • Ein Freund von mir hat das gleiche Problem. Ich habe ihm eine verschlüsselte eMail inkl. Anhang geschickt und er hat sich bei mir auch beschwert, dass er die Mail nicht lesen/entschlüsseln kann.
    Auch er benutzt TB 2.0.0.4 und IMAP.


    Andere Empfänger der eMail, die kein IMAP benutzen hatten das Problem natürlich nicht.


    Weiß da jemand Rat?


    EDIT:


    Ich habe die eMail mit der dritten Option hier verschlüsselt. Siehe Screenshot:


    http://www.rzuser.uni-heidelberg.de/~abuchner/screen.JPG


    Als ich ihm die eMail dann noch mal "mit der zweiten Option verschlüsselt" geschickt habe, konnte er sie öffnen.
    Aber das ist nicht so befriedigend, da man dann den Anhang immer extra entschlüsseln muss.

  • Zufällig habe ich jetzt die Lösung des Problems gefunden:


    In den Preferences von OpenPGP in TB --> Advanced --> Only download attachments when opened (IMAP only), diesen Punkt deaktivieren und dann sollte es klappen.

  • Bin zwar noch neu im Thema TB mit IMAP/PGP/GPG, aber gut den Thread gelesen zu haben - hätte sonst wieder wie der Ochs' vor'm Berg nach dem Fehler gesucht. ;-)