Gelöst: Von Win nach Ubuntu klappt nicht

  • Hallo liebes Forum,


    ich habe bereits mehrere Beschreibungen zu Migration meiner Mails von WinXP nach Ubuntu7.10 gelesen, leider scheitere ich trotzdem.
    Ich habe den kompletten Profilordner in .mozilla-thunderbird kopiert und in der ini Name und Path darauf "umgebogen".
    Starte ich nun Thunderbird, heisst es "Thunderbird is already running, but not responding. To open an new window, you must first close the excisting Thunderbird process, or restart your system."


    Nenne ich die profiles.ini in irgendwas anderes um, dann startet TB und erstellt eine eine ini. Ändere ich in dieser wieder den Pfad etc, startets wieder nicht weils angeblich schon laufen würde.


    Irgendwas im vom Win übernommenen Programmorder scheint zu zicken..?!

  • Hallo,

    "HeldImErdbeerfeld" schrieb:

    Hallo liebes Forum,
    Ich habe den kompletten Profilordner in .mozilla-thunderbird kopiert und in der ini Name und Path darauf "umgebogen".


    Welchen Thunderbird (und welche Version) hast du installiert, das Ubuntu-Paket?
    Was genau steht in der profiles.ini?
    Stimmen die Lese-und Schreibrechte für die Dateien im Profil?
    Stimmt die Verzeichnisstruktur, d.h. hast du den kompletten Inhalt aus
    C:\Dokumente und Einstellungen....usw...\thunderbird
    aus Windows nach
    /home/username/.mozilla-thunderbird kopiert?
    Gibt es im Profil eine Datei parent.lock oder .parentlock oder ähnlich? Diese löschen.


    HTH, muzel

  • TB-Version ist 2.0.0.6


    inhalt der ini:
    -----------
    [General]
    StartWithLastProfile=1


    [Profile0]
    Name=default
    IsRelative=1
    Path=2ra15g6j.default
    Default=1
    -----------


    der Ordner heißt dementsprechend 2ra15g6j.default (muss da kein slash dazu?!)


    den ordner hab ich mit allen dateien, also nicht nur dem unterordner Mail kopiert. nach diesen lock-dateien hab ich auch schon gesucht, gibts nicht.


    Ich laß in einem anderen forum, dass win-spezifische plugins stören können. ich hatte aber bisher nur Talkback installiert, habs vorsichtshalber runtergeworfen - auch keine änderung. :(

  • Tja, sieht alles richtig aus und müßte funktionieren, falls sich nicht irgendwo ein Tippfehler eingeschlichen hat.
    Die Version verrät Thunderbird im Hilfe-Menü oder wie jedes ordentliche Linux-Programm in der Konsole mit
    thunderbird (oder mozilla-thunderbird) --version.
    Die sollte nicht wesentlich von der Version unter Windows abweichen, allerdings ist wohl die Ubuntu-Version immer noch eine 1.5.*. Möglicherweise ist das das Problem.
    Vielleicht legst du einfach nochmal mit dem Profilmanager
    thunderbird -P
    ein neues Profil an, und kopierst die Profildateien da hinein.


    - m.

  • ne, wie nachgebessert, liegt die versionsnummer vom linux-tb bei 2.0.0.6


    ich hab nochmal die ini gelöscht, tb gestartet und in der neuen ini einfach den pfad auf den bestehenden ordner umgeändert. schon zickt es wieder rum.


    *seufz*


    gibts nicht einen *umständlicheren* weg, der aber erfolgversprechender ist? keine lust wochenlang einer lösung hinterher zu jagen..

  • möp, problem gelöst:


    Der Dateimanager hatte den kopierten ordner so im linux-fs hinterlegt, dass nur root schreib/lese-recht hat.
    tb konnte nicht zugreifen, habs eben geändert und nun ging es.


    ubuntu ist manchmal echt übervorsichtig, für jeden handschlag muss ich sudo eingeben *nerv*

  • "HeldImErdbeerfeld" schrieb:

    möp, problem gelöst:


    Der Dateimanager hatte den kopierten ordner so im linux-fs hinterlegt, dass nur root schreib/lese-recht hat.
    tb konnte nicht zugreifen, habs eben geändert und nun ging es.


    ubuntu ist manchmal echt übervorsichtig, für jeden handschlag muss ich sudo eingeben *nerv*


    Nö, ist schon richtig so. Deshalb hatte ich ja oben gefragt:

    Zitat

    Stimmen die Lese-und Schreibrechte für die Dateien im Profil?


    Daß das Profil dem User gehören muß, mit allen Rechten, hatte ich als Grundwissen vorausgesetzt ;)
    Na ja, Glückwunsch zum Erfolg, und vielleicht änderst du den Titel des Threads noch in [Gelöst:]...


    m.

  • Also wenn ich einen Ordner mit einem bestimmten User anlege, dann kann ich doch wohl davon ausgehen, dass dieser User auch drauf zugreifen kann..?!


    naja anyway, ich ändere mal den titel und dann hat sich die sache...