Probleme, Probleme und nochmal Probleme!

  • Habe mich jetzt mal hier angemeldet, weil ich mit meinen Fähigkeiten in Thunderbird einfach nicht mehr weiterkomme. Ich habe Thunderbird, GNUpgp 1.4.9 und Enigmail 0957 komplett installiert und alles nach Plan eingerichtet, das hat auch 2 Monate lang funtioniert. Ich habe die GnuPGP Daten auf meinen Usb Stick installiert und ebenfalls die Schlüsselpaare. Nun hat mein USB Stick aus welchen Gründen auch immer nen anderen Laufwerksbuchstaben zugeteilt bekommen und nix geht mehr. Ich habe in den OPEN PGP Einstellungen extra den Pfad geändert, aber trotzdem lässt sich kein Schlüssel importieren oder irgendwas dergleichen. Ich habe alles deinstalliert und nochmal draufgespielt aber es funktioniert nichts!

  • Hallo,
    versuchs mal unter OpenPGP-Einstellungen - Erweitert - zusätzliche Parameter mit
    --homedir =Laufwerk:\Pfad_zum_Schlüsselbund
    Gruß muzel

  • enigmail> H:\Programme\GNU\GnuPG\gpg.exe --charset utf8 --homedir =H:\Programme\ Schlüssel für PGP --batch --no-tty --status-fd 2 --with-fingerprint --fixed-list -mode --with-colons --list-keys gpg: Schlüsselblockhilfsmittel`=H:/Programme/Schlüssel\secring.gpg': Fehler bei m Ãffnen der Datei gpg: Schlüsselblockhilfsmittel`=H:/Programme/Schlüssel\pubring.gpg': Fehler bei m Ãffnen der Datei Aufruf: gpg [Optionen] [Dateiname]

  • Versuch die Meldung zu verstehen, so schwer ist es nicht.
    Der Pfad enthält ein Leerzeichen und wird genau dort abgeschnitten, denn die Schlüssel werden in H:/Programme/Schlüssel\ gesucht. Also Pfad ändern oder den Parameter in Anführungstriche (einfache oder doppelte, keine Ahnung, ob und welche Variante funktioniert...), also z.B.
    --homedir="H:\Programme\Schlüssel für PGP"
    verwenden.
    Natürlich kann man Leerzeichen (und Umlaute) in Datei- und Verzeichnisnamen verwenden, darf sich aber nicht über die Folgen wundern.

  • Jetzt kommt das!!! Ich werd verrückt!


    enigmail> H:\Programme\GNU\GnuPG\gpg.exe --charset utf8 --homedir="H:\Programme\ Schlüssel für PGP" --batch --no-tty --status-fd 2 --with-fingerprint --fixed-lis t-mode --with-colons --list-keys gpg: Schlüsselblockhilfsmittel`H:/Programme/Schlüssel für PGP\pubring.gpg': Feh ler beim Ãffnen der Datei gpg: fatal: H:/Programme/Schlüssel für PGP: Verzeichnis existiert nicht! secmem usage: 0/0 bytes in 0/0 blocks of pool 0/32768


    Kann mir jetzt endlich mal jemand helfen...in dem Ordern Schlüssel für PGP ist nur mein öffentlicher, geheimer und 2 öffentliche von anderen!

  • Versuchs doch mal mit einer Installation auf C:, sowohl für das Programm als auch die Schlüssel (Enigmail anpassen, --homedir-Eintrag löschen oder ändern), und vermeide dabei Leerzeichen und Umlaute im Pfad und in den Dateinamen.
    Wenn es funktioniert, verschiebe die Schlüssel auf den USB-Stick und ändere das homedir. Und laß dir etwas einfallen gegen die nächste Änderung der Laufwerksbuchstaben...