Verlust von EMails unter MAC auf USB Stick (+WinXP)

  • Hallo erstmal!
    Ich hab schon einiges hier durchgeschaut, hab aber nichts gefunden, das mein Problem löst....


    Meine Situation:
    Ich verwende TB unter MacOsX und speichere das Profil auf nem USB Stick
    Ich verwende den TB-portable unter WinXP um auch auf das Profil zuzugreifen (natürlich nicht gleichzietig;).
    Der USB Stick ist mit FAT32 formatiert.
    Virenscanner sind korrekt konfiguriert.
    Ich verteile die Mails auf zahlreiche Unterordner (so grob 50 Stück? - ich bekomme viele (vor allem geschäftliche) Mails....).
    Ich mache (glücklicher Weise) regelmässig backups.


    Mein Problem:
    Wenn TB auf dem Mac läuft gibt es manchmal Probleme beim Schreiben von EMails (sowohl beim Abholen als auch beim Senden). Der Ordner in dem TB die Mail speichern möchte scheint dann korrupt zu sein. Das äussert sich so:
    -Wenn ich Glück habe schreibt er, dass er die Mail nicht entsprechend der Regel verschieben konnte, da er nicht auf den Zielordner zugreifen konnte. In diesem Fall ist die Mail noch im Ursprungsordner verfügbar.
    -Wenn ich Pech habe 'speichert' er die Mail in dem korrupten Ordner. In diesem Fal erscheint die Mail in dem Ordner, wenn man sie anklickt hat sie aber keinen Inhalt, bzw den Inhalt der vorhergehenden Mail. Dies passiert ab diesem Zeitpunkt auch mit jeder weiteren Mail die in den Ordner verschoben wird. Diese Mails sind dann verloren: wenn ich TB neu starte oder die Index-Datei neu erstelle sind die EMails ganz verschwunden.


    Der Verlust bezieht sich also auf alle Mails, die in den Ordner verschoebn werden nach dem ersten Auftreten des Fehlers. Alte Mails sind davon nicht betroffen.


    Mein Workaround bisher:
    Neuen Ordner erstellen, alle nicht beschädigten Mails dorthin verschieben, Regeln auf den neuen Ordner anpassen, TB beenden, defekte Datei löschen (in TB lässt sich der defekte Ordner nicht löschen).


    Das geht bisher einigermassen, ist aber ziemlich lästig (Glücklicher Weise sehe ich ja meist noch welche Mails ich 'nicht bekommen' habe und kann sie mir nochmal schicken lassen). Ausserdem fürchte ich doch grösseren Verlust...


    Kurioser Weise passiert das nur am Mac (so etwa einmal im Monat), am WinXP Rechner hatte ich das noch nie.


    Es liegt nicht:
    Am USB Stick, den habe ich schon ein paar mal gewechselt
    An der Version des TB, ich habe das mit mehreren gehabt



    Ich hoffe ihr könnt mir helfen bzw habt eine Idee woran das liegen könnte....
    (Ich habe wichtige Infos vergessen -> Nachfragen;)


    Viele Grüße
    Mythran

  • Hallo,


    zum eigentlichen Problem kann ich wahrscheinlich mangels Mac-Kenntnissen nichts beitragen. Aber vielleicht kannst du einfach deine Strategie ändern. Du willst deine Mails auf zwei (oder mehr?) Rechner synchron halten. Dafür benutzt man eigentlich IMAP, möglicherweise bei deinem ungenannten Provider kostenpflichtig.
    Ich habe mit dem Portable Thunderbird auch gute Erfahrungen gemacht, er läuft bei mir unter Linux/Wine und manchmal noch Windows - man muß naturgemäß mit gelegentlichem Datenverlust rechnen und entsprechend oft Backups machen.
    Die dritte Möglichkeit, wenn nur POP3 geht, habe ich mal hier beschrieben.


    HTH, muzel

  • Hi!
    Danke für den Vorschlag, aber der aktuelle Weg ist für mich schon der 'Königsweg', wenn nicht dieses nervige Problem wäre...
    -Ich habe aus traditionellen/organisatorischen Gründen einige EMail-Provider (Trennung von anonymen, offiziellen, Vereins-, Verbands-, und geschäftlichen Mails etc). Bei einigen würde das mit IMAP gehen, bei anderen wäre es kostenpflichtig, oder mein Speicher einfach in kurzer Zeit voll...
    -Ich sortiere diese verschiedenen Accounts 'lokal' in eine gemeinsame Verzeichnisstruktur
    -Bei den wirklich wichtigen Account bleiben die Mails nach dem Abholen auf dem Exchange Server -> wichtige Daten gehen nicht verloren
    -Ich nutze noch Lightning, dessen Profil ich auch auf dem USB Stick habe
    -...
    -->Mit dem Stick habe ich eigentlich eine sehr gute All-In-One Lösung


    Es wäre evtl. möglich alles das umzustrukturieren (ich habs anfangs mal versucht, bin aber irgendwo hängen geblieben), wäre aber ein grösserer Akt fürchte ich



    Ein Nachtrag:
    Ich konnte bei dem Problem auch keinen Zusammenhang mit
    -Anzahl der Mails im Ordner
    -Anhängen der Mails
    erkennen.
    Es ging auch knapp ein Jahr lang gut, dann kamen die Probleme mit (zumindest gefühlt) steigender Frequenz.


    Ich habe evtl. Spotlight im Verdacht, auch wenn ich niemanden finden konnte der über Probleme geschrieben hat. Evtl. hat das einen ähnlichen Effekt wie Virenscanner?


    MacOsX sollte doch eigentlich keine grundsätzlichen Probleme mit FAT32 haben, oder?



    VG
    Mythran