[erledigt] erst upgrade, dann downgrade mit ubuntuzilla ...

  • Hi Leute,


    neugierig wie ich war, habe ich gestern sofort auf 3.1 upgedatet. Leider war aus den ubuntuzilla-Quellen das update noch nicht erhältlich. Also habe ich TB mit

    Code
    1. gksudo thunderbird &


    gestartet und manuell nach Updates suchen lassen
    Leider haben nicht alle Addons funktioniert, also habe ich dies bei einigen erzwungen (MR Tech Toolkit).
    Nachdem mir das aber alles nicht so ganz gefallen hat. Habe ich wieder ein downgrade gemacht, indem ich alle Pakete komplett entfernt habe und 3.0.5 aus den ubuntuzilla-Quellen erneut installiert. Das Profilbackup habe ich wieder ersetzt durch ein Backup kurz vor dem Upgrade.


    Jetzt bekomme ich allerdings beim Start eine Fehlermeldung, die ich nicht nachvollziehen kann:


    Code
    1. [Exception... "Cannot find interface information for parameter arg 1 [mozIStorageService.openDatabase]" nsresult: "0x80570006 (NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO)" location: "JS frame ::
    2. file:///home/xxx/.thunderbird/xxxxxxxxx.xxx/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm ->
    3. file:///home/xxx/.thunderbird/xxxxxxxxx.xxx/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calStorageCalendar.js ::
    4. anonymous :: line 194" data: no]


    Hoffe ihr könnt mir helfen.


    Ian


    update 1: Beim Starten, kommt jetzt keine Fehlermeldung mehr (habe noch mal komplett TB deinstalliert und mit gesichertem Profil neu aus den Quellen von ubuntuzilla aufgesetzt), mir wird nur ein Tab angezeigt, der aber komplett leer ist.
    Im Safe-Mode starte TB normal, ich kann Mails abrifen und versenden.

    Code
    1. thunderbird -safe-mode


    Ich habe dann alle Erweiterungen deaktiviert und versucht neu zu starten. Danach wird mir dann aber wieder ein leeres TB-Fenster angezeigt.


    Hat jemand einen Tipp? Ich kann leider keine Fehlerlogs finden, hat hierzu jemand einen Hinweis?

  • OK, alles wieder paletti.


    Scheint ein Problem mit dem in 3.0.5 installierten Sprachpaket zu sein. Nachdem ich das alte deinstalliert hatte, funkt der TB 3.1 wieder wie ein Uhrwerk. TB ist jetzt zwar in einem komischen Mix aus deutsch/englisch, aber sicher nichts was man nicht durch ein bisschen ausprobieren hinbekommt. HInweise sind sehr willkommen.


    Manche Addons bedürfen zwar noch eines Updates aber sonst alles OK. Neue Funktionen von 3.1 sind zwar ... *hüstel* überschaubar und ob sie wirklich sinnvoll sind muss ich noch testen.


    Viel Spaß


    Ian