"gelöst" PGP Enigmail funktioniert nach Backup nicht

  • Hallo ,
    ich verwende auf einem LINUX-System (Mandriva Spring 2010.1) Thunderbird mit Enigmail.
    Ich hatte das System geupdatet, dann meine Sicherung des TB und des gnupg Ordner wieder eingespielt.
    Thunderbird: Version 3.0.10, POP3-Konto mit Enigmail 1.0.1.
    Beim Verschlüsseln und dem Versuch der Entschlüsselung bekomme ich folgende Fehlenmeldung:


    Ich habe ein gültiges Schlüsselpaar, was in der Schlüsselverwaltung auch angezeigt wird.
    Kurzzeitig hatte es mal funktioniert, als ich in den Einstellungen auf den Button Zurücksetzen geklickt hatte.
    Jetzt erscheint dann folgende Meldung:

    Code
    1. Ihr System verwendet gpg-agent oder eine ähnliche Anwendung zur Passphrasen-Verwaltung (gpg-agent ist obligatorisch für GnuPG 2.0 oder neuer). Da gpg-agent das Zwischenspeichern der Passphrasen verwaltet, wird die zugehörige Einstellung von OpenPGP ignoriert. Um die Einstellungen des Passphrasen-Zwischenspeichers zu ändern, konfigurieren Sie bitte die gpg-agent Anwendung.


    Kurios ist, das die Passphrase gar nicht abgefragt wird.


    Gruß Jeanette

    Einmal editiert, zuletzt von jeanette ()

  • Hallo,
    gpg-Version?
    OpenPGP-Einstellungen (insbesondere unter "Allgemein" und "Erweitert")?
    Inhalt der gpg-agent.conf, vermutlich unter ~/.gnupg?
    Was ergibt

    Code
    1. env | grep GPG_AGENT_INFO


    und

    Code
    1. ps -ef | grep gpg-agent


    in der Konsole?
    Gruß, muzel

  • Hallo,


    hier die Angaben:
    Bei Öffen TB über Konsole:

    Code
    1. [jeanette@localhost ~]$ thunderbird
    2. /home/jeanette/.gtkrc-2.0:22: error: invalid string constant "xfdesktop-icon-view", expected valid string constant
    3. DOUBLE-CLICK: 250 --> -1 THRESHOLD: 8 --> -1 OpenOffice path is '/usr/lib/ooo'


    Code
    1. [jeanette@localhost ~]$ env | grep GPG_AGENT_INFO
    2. GPG_AGENT_INFO=/home/jeanette/.gnupg/S.gpg-agent:2529:1
    3. [jeanette@localhost ~]$


    Code
    1. [jeanette@localhost ~]$ ps -ef | grep gpg-agent
    2. jeanette 6229 6159 0 18:39 pts/0 00:00:00 grep --color gpg-agent
    3. [jeanette@localhost ~]$


    Bei OPEN PGP Einstellungen Allgemein:


    Gnupg wurde gefunden in /usr/bin gpg


    Erweitert:
    Verschlüsseln beim Antworten auf verschlüsselte Nachrichten
    Enigmail-Informationen zur Open PGP Signatur hinzufügen
    "--" als Unterschriften Trenner behandeln
    Die Zeichen"<" und ">" verwenden , um E-Mailadressen zu kennzeichnen


    Bei Schließen der Open PGP Einstellungen kommt folgende Meldung:

    Code
    1. Ihr System verwendet gpg-agent oder eine ähnliche Anwendung zur Passphrasen-Verwaltung (gpg-agent ist obligatorisch für GnuPG 2.0 oder neuer). Da gpg-agent das Zwischenspeichern der Passphrasen verwaltet, wird die zugehörige Einstellung von OpenPGP ignoriert. Um die Einstellungen des Passphrasen-Zwischenspeichers zu ändern, konfigurieren Sie bitte die gp


    Die gpg-agent.conf habe ich nicht gefunden, in der /gnupg ist sie nicht


    Ich hoffe, das hilft erstmal weiter.
    Gruß Jeanette

  • Ich habe jetzt meine Paketverwaltung nochmal durchforstet.
    Es gab einmal ein Paket gnupg und einmal gnupg2.
    Nachdem ich probehalber gnupg2 deinstalliert habe, kann ich meine Mails entschlüsseln.
    Kann das sein, das die beiden sich gegenseitig gestört haben?
    Da ich die Installation von CD gemacht hatte und da die Standardinstallation ausgewählt hatte, muss die Doppelung dabei passiert sein.
    Warum ich allerdings keine gpg-agent.conf finde, verstehe ich nicht so ganz.


    Grüße
    Jeanette

  • Wundert mich nicht. Die üblichen Probleme mit gpg2 (womit auch endlich die Frage nach der Version beantwortet wäre).
    Mit gpg 1.4.* braucht man keinen Agent, weil Enigmail sich allein um das Passwort kümmert.
    m.

  • Danke, zum Abschluß nur noch mal eine Frage.
    Wie kriege ich über Komandozeile die Version von gpg raus? Normalerweise nimmt man doch den Parameter -v, so das der Befehl doch lauten müsste: gpg -v
    Wenn ich den jedoch eingebe, kommt eine Meldung so ungefähr: Nun lass uns Texte eingeben, und ich komme aus der Geschichte dann nicht vernünftig raus. Weder q, exit, oder quit spricht an. Wie würde man hier das Terminal beenden?


    Viele Grüße Jeanette

  • Hallo nochmal,


    viele Programme unter linux/unix/..., so auch gpg (dieses auch unter Windows) erwarten eine Versionsabfrage in der Form

    Code
    1. gpg --version

    .

    Code
    1. gpg --help

    zeigt die wichtigsten Befehle und Optionen, und

    Code
    1. man gpg

    das komplette Handbuch.

    Zitat

    Wie würde man hier das Terminal beenden


    Strg+C
    Übrigens kann man normalerweise schon gpg und gpg2 parallel betreiben, in den OpenPGP-Einstellungen muß nur der richtige Pfad (zu gpg 1.4.* , wenn man ohne gpg-agent arbeitet, oder zu gpg2 (gpg 2.*) , wenn man es mit dem gpg-agent hinbekommt) eingetragen sein.


    Gruß, muzel

  • Danke Mutzel, jetzt bin ich wieder ein Stück klüger.
    Ich bleibe jetzt bei gpg1.4.10 und hoffe dass ich damit hinkomme.


    Viele Grüße
    Jeanette