HTML verschlüsselt - OpenPGP-Sicherheitsinfo+Zeichenfehler

Am 24.09.2018, werden in der Zeit zwischen 21:00 Uhr und 09:00 Uhr des folgenden Tages Wartungsarbeiten am Server durchgeführt. Daher wird die Webseite in dieser Zeit nur eingeschränkt erreichbar sein.
  • Hi Leute,
    ich habe SuFu und Internetsuche verwendet, aber da sich diese Problem auf vielerlei Art beschreiben lässt, kann ich nicht versprechen, nichts übersehen zu haben. Sollte dem so sein, bitte ich um einen kleinen Hinweis.
    Es handelt sich hierbei mehr um eine Unannehmlichkeit denn um ein Problem, aber dennoch:
    Wenn ich eine HTML-Mail in Thunderbird 3.1 mit Enigmail & GPG verschlüssele, wandelt Enigmail/GPG diese automatisch in eine Textmail um. Aus Links werden dabei folgende Konstrukte: "Linktext <Linkadresse>"


    Verschlüsseln klappt, entschlüsseln auch, es wird als Sicherheitsinfo aber "gpg Kommandozeile und Ausgabe:" in der Enigmail-"Statusleiste" mitgeliefert - allerdings u. A. so: "Ungültige ASCII-Hülle \n" oder "verschlüsselt mit 2048-Bit RSA Schlüssel"


    Wie kommt es zu diesen Zerhächslungen der rein deutschen Zeichen/Umlaute (die in anderen Fällen (anderer Text) problemlos in besagter Leiste dargestellt werden) und kann man das irgendwie beheben?
    Der erste von mir gepostete String scheint auf eine ASCII-Inkompatiblität hinzudeuten, kommt GnuPG mit dem deutschen Zeichensatz einfach nicht klar? Aber wenn dem so ist, warum gibt es dann eine deutschsprachige Kommandozeilenausgabe?


    Wie gesagt, kein wirkliches Problem, aber es sieht halt immer etwas befremdlich aus.


    EDIT:
    Es sieht nicht nur befremdlich aus, es führt auch definitiv zu Problemen:
    Wenn man eine HTML-Mail, die Links enthält, verschlüsselt, kommt beim entschlüsseln folgende OpenPGP-Sicherheitsinfo (auch in der "Enigmail-Statusleiste"):
    gpg Kommandozeile und Ausgabe:


    Wenn man nun in der "Enigmail-Statusleiste" auf "Details" und dann auf "Schlüssel unterschreiben" geht, kommt das "Schlüssel unterschreiben"-Fenster, allerdings steht bei Schlüsselname "- x0" und beim Fingerabdruck "?", dementsprechend geht das Unterschreiben dann auch schief. Wenn man diesen Schlüssel aus der Schlüsselverwaltung von Enigmail heraus unterschreiben möchte, zeigen sich keine Probleme.


    Hat irgendwer eine Idee, was da los ist?