Schlüsselerzeugung von Enigmail buggy [Erledigt]

  • Hi Leute: Frage zu Enigmail 1.3.3
    Kann es sein, dass die Schlüssel von GnuPG beim Erstellen irgendwie nicht sauber abgegriffen werden?
    Ich habe nämlich auf meiner eigenen und einer anderen Enigmailinstallation 1.3.3 (TB 8 ) das Problem, das die Schlüsselerstellung unendlich lange zu dauern scheint, bisher mussste ich sie bei meinen Tests jedes Mal abbrechen. Am Ende war der Schlüssel dennoch im Keyring, obgleich ich abgebrochen habe, bevor ich nach der Erstellung des Widerrufszertifikats gefragt wurde.
    Ist das Problem bei jemandem reproduzierbar?
    Mein Tipp ist, da GnuPG sich nicht verändert hat, dass Enigmail den zurückgegebenen, erzeugten Schlüssel irgendwie nicht korrekt entgegen nimmt und daher das Ende des Erstellungsvorgangs nicht mitkriegt. Weiß jemand näheres?

  • Hallo,
    kann nur bestätigen, daß es so ist, jedenfalls unter den unten genannten Linuxen mit gpg 1.4.* und 2.0.*.
    Da war wohl der Patrick mal wieder etwas in Eile beim Bauen der 1.3.3er Version für TB 8. Wie üblich im Enigmail-Forum oder Bugzilla melden...
    Gruß, muzel

  • Fixed on trunk, as I was told.


    Wollt' ich nur nochmal erwähnt haben.

  • Kann mir nur jemand kurz sagen ab welcher bis welcher Version das auftritt? Oder gilt das nur für 1.3.3 und Tb8?

  • Ist repariert und wird mit der nächsten Version released, das dürfte dann die 1.3.4 sein, oder was auch immer der 1.3.3 nachfolgen wird.

  • Hast du nicht das gleiche schon im dritten Beitrag geschrieben? :)


    Die Antwort auf meine Frage weiß keiner?

  • Ist meines Wissens mit der 1.3.3er (gibt's nur für TB8) aufgetreten und verschwindet mit der nächsten.

  • Probier's aus! Wenn die 1.3.4 bei der Schlüsselerzeugung hängen bleibt, nicht, wenn die Schlüsselerzeugung problemlos durchgeht, dann schon.
    Da ich momentan keinen Bedarf an neuen Schlüsseln habe, werde ich für meinen Teil warten, bis die 1.3.4 über die interne Updatefunktion verteilt wird.
    As I said: Try it yourself.


    Und dann sag mal Bescheid, was der Test ergeben hat.

  • Patrick schreibt mir heute u.a., daß auch dieser Fehler mit der 1.3.4 der Vergangenheit angehören sollte. Das kam in den release notes wohl nur nicht so eindeutig rüber.


    Alles bestens also ;)