Uhrzeitversatz 2 Stunden bei gesendeten Mails aus Ubuntu

Am 24.09.2018, werden in der Zeit zwischen 21:00 Uhr und 09:00 Uhr des folgenden Tages Wartungsarbeiten am Server durchgeführt. Daher wird die Webseite in dieser Zeit nur eingeschränkt erreichbar sein.
  • Thunderbird-Version: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.15) Gecko/20110419 Thunderbird/3.1.9


    Betriebssystem + Version: Medion Fastboot (Linux Ubuntu System 2.0 87256
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX): 1und1 (@oninehome.de


    Auf meinem Medion Notebook sind zwei Betriebsysteme installiert. Medion Fastboot auf Linux Basis und Windows 7.
    Der Usecase ist folgender
    Ich sende ein Mail an mich selbst aus Medion Fastboot um 16:32. Dies entspricht auch der angezeigten Systemzeit.
    Wechsele ich nun in den Windows-Modus und öffne den Posteingang, wird das Mail mit Uhrzeit 18:34 angezeigt. Die Systemzeit sagt mir aber, dass es erst 16:35 ist (Das Mail ist also quasi in der Zukunft erstellt).
    Ich habe auch schon Hinweise von Mailempfängern erhalten, dass meine Mails wohl einen falschen Zeitstempel haben.
    Im empfangenen Mail sind folgende Kopfdaten enthalten:
    In der rechten oberen Ecke ist der Zeitstempel 18:34 angegeben. (also rund 2 Stunden zu spät)
    In den weiteren Received-Abschnitten ist ersichtlich, dass die Received-Stempel bei 16:32 und 16:34 liegen.


    Und tatsächlich war das Mail ja auch schon um 16:35 in meinem Posteingang.
    Könnte das Verhalten mit einer Zeitzoneneinstellung zu tun haben.
    Bei den Received Daten wird z.B. 16:34 +0200 angezeigt.
    In der letzten Zeile ist die Uhrzeit mit 16:34 +0000 angegeben.


    Kann man die Zeitzone im Fastboot oder im Thunderbird prüfen und oder einstellen.
    Wie kann man z.B. Thunderbird in Linux updaten?
    Gibt es ein alternatives Mailprogramm, mit dem ich POP3 oder IMAP-Postfächer anbinden kann?


    Ich bin absoluter Linux-Analphabet.


    Vielen Dank im Voraus für Ihre Mühe!!

  • Hallo,


    das ist ein bekanntes Phänomen, welches bei paralleler Instalation von Unix und DOS, hier Linux und Windows, auftreten kann. Siehe Falsche Uhrzeit bei Windows-/Linux-Parallelinstallation (evtl. ein kleines Stück hochscrollen).


    Gruß


    Susanne


    P.S.: Fast vergessen, falls bei Dir Linux bereits mit lokaler Uhrzeit läuft (das kannst Du mit den Befehl "date" überprüfen), dann schau weiter oben in dem Artikel, wie man die Uhrzeit/Zeitzone einstellen kann.

  • Hallo Susanne,
    danke für die rasche Antwort.
    Ich habe versucht das Terminalfenster zu öffnen um "Date" einzugeben und bekomme die Fehlermeldung:
    There was an error creating the child process for this terminal
    getpt failed: Datei oder Verzeichnis nicht gefunden?
    Hast Du vieilleicht dafür eine Erklärung?
    Gruß
    Peter


    Den Tipp mit dem anderen Forumsbeitrag muss ich mir erst erarbeiten.

  • Hallo pesase,


    "pesase" schrieb:

    Hast Du vieilleicht dafür eine Erklärung?


    Nein, so auf Anhieb nicht. Möglicherweise hast Du ein Problem mit dem mount von /dev/pts.


    Aber halb so schlimm. Die Einstellungen für Datum und Zeit können, zumindest in der "normalen" Version von Ubuntu auch ohne Terminal über die Grafische Benutzeroberfläche vorgenommen werden. Wie Du in das Menu "Einstellungen" gelangst, ist je nach verwendeter Desktop-Umgebung unterschiedich. In Unity (das ist seit eniger Zeit unter Ubuntu die Standardoberfläche) gibt es in der Startleiste einen Launcher zu den Systemeinstellungen, in Gnome gibt es einen ähnliche Punkt im Menu. Ich weiß leider nicht, was genau sich hinter dieser Fast-Boot-Ubuntu-Distrubution verbirgt, die bei Dir installiert ist.


    Als

    "SusiTux" schrieb:

    absoluter Linux-Analphabet


    solltest Du besser diesen Weg über die Benutzeroberfläche gehen und das Terminal zunächst außen vor lassen. Wenn Du ein Terminal benötigst, versuche es einmal über die Tasten Ctrl-Alt-F1 bis Ctrl-Alt-F6. Da bekommst Du jeweils eine "klasissche" Linux-Session, zwischen denen Du hin- und herschalten kannst. Mit Ctrl-Alt-F7 kannst Du zurück zum Desktop schalten. Du musst Dich für jede Session anmelden und solltest sie dann auch wieder ordentlich beenden.


    Wenn Du dort folgenden Befehl eingibst


    Code
    1. mount | grep pts


    Dann sollte die Ausgabe etwa so aussehen:


    Code
    1. devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)


    Das hat jetzt aber nichts mit dem Datums- und Zeiteinstellungen zu tun, sondern dient lediglich der Überprüfung ob /dev/pts bei Dir korrekt gemountet ist. Da ist also nur dann interessant, wenn Du weiter nachforschen willst, warum Du zur Zeit kein Terminalfenster öffnen kannst.


    Gruß


    Susanne

  • Hallo,
    ich habe Launcher/Einstellungen/Datum Uhrzeit gefunden. Die Zeit ist richtig eingestellt, aber es gibt keine Möglichkeit die Zeitzone zu prüfen oder einzustellen.
    die Datei etc/default/rcs enthält die Einstellungen:
    TMPTIME=0
    SULOGIN=no
    DELAYLOGIN=no
    UTC=yes
    VERBOSE=no
    FSCKFIX=no
    Leider kann ich UTC nicht auf "no" einstellen, da mich gedit nicht editieren lässt. Ohne Terminal kann ich aber nicht auf Rootrechte umstellen.
    Das mit den Tastenkombis hat nicht zum Erfolg geführt. Offensichtlich ist Medion Fastboot ein sehr zusammengestrichenes System.


    Wie die Zeit synchronisiert wird kann ich auch nicht recht interpretieren:
    In NTPdate sind folgende Optionen
    # Set to "yes" to take the server list from /etc/ntp.conf, from package ntp,
    # so you only have to keep it in one place.
    NTPDATE_USE_NTP_CONF=yes


    # List of NTP servers to use (Separate multiple servers with spaces.)
    # Not used if NTPDATE_USE_NTP_CONF is yes.er
    NTPSERVERS="ntp.ubuntu.com"


    # Additional options to pass to ntpdate
    NTPOPTIONS=""


    Ich gehe davon aus. dass die Uhrzeit vom Server kommt?


    Falls Du noch eine Idee zum Terminal hast, wäre ich dankbar.
    Gruß
    Peter

  • Hallo Peter,


    "pesase" schrieb:

    ... aber es gibt keine Möglichkeit die Zeitzone zu prüfen oder einzustellen. ... Das mit den Tastenkombis hat nicht zum Erfolg geführt.


    Das ist komisch. Möglicherweise ist dies in der Tat eine sehr eingeschränkte Version. Das weiß ich aber nicht. Du kannst ja mal ein wenig googlen, beim Hersteller anfragen oder in einschlägigen Linuxforen nachfragen.


    "pesase" schrieb:

    Leider kann ich UTC nicht auf "no" einstellen, da mich gedit nicht editieren lässt.


    Klar, ohne entsprechend Rechte wird das nichts. Aber mit


    Code
    1. gksudo gedit


    und dem entsprechenden Root-Password wird es gehen.


    "pesase" schrieb:


    Ich gehe davon aus. dass die Uhrzeit vom Server kommt?


    Ja, aber eben nicht die Zeitzone.


    "pesase" schrieb:

    Falls Du noch eine Idee zum Terminal hast, wäre ich dankbar.


    Lieber nicht, am Ende wird's noch schlimmer. Das "halbierte" Fast-Boot-Linux ist mir nicht geheuer.


    Gruß


    Susanne



    Edit.: Susi, wo sind nur Deine Gedanken?! Ohne Terminal wird das natürlich nichts mit dem gksudo. Vergiss, was ich oben geschrieben habe. Ich habe gerade mal nach Medion Fastboot gegoogelt. Es scheint sich in der Tat um ein sehr eingeschränktes Ubuntu zu handeln. Selbst die Benutzerobfläche kommt offenbar von Medion. Ich habe folgende Kurzanleitung gefunden und sehe da gar keine Möglichkeit, ein Terminal zu starten. Wie hast Du denn das Terminal und gedit starten können?

  • Hallo Susanne,
    danke für die Kurzanleitung. Vielleicht schaue ich mal ob es schon eine neuere Version von Fastboot gibt.
    Neben den in der Kurzanleitung angegebenen Tasten im Launcher gibt es bei mir noch einen "APP"-Button. Mit dem kann man Applikationen, wie z.B. Officewerkzeuge , Editor und auch das Terminal erreichen, aber offensichtlich sind die nicht vollständig installiert.


    Was ich noch nicht verstanden habe:
    Öffne ich durch das Öffnen von Fastboot eine Session von Linux oder nennt man das öffnen eines Terminals eine Session. Was ist damit gemeint, dass man sich mit bestimmten Rechten in einre Session anmeldet?


    Aber zunächst mal vielen Dank für Deine Mühe. Ich werde in den nächsten drei Wochen keine Zeit für das Thema haben, da ich in Urlaub gehe. Also wundere dich nicht, wenn Du erstmal nichts mehr von mir hörst.


    Gruß
    Peter

  • Hallo Peter,


    "pesase" schrieb:

    Öffne ich durch das Öffnen von Fastboot eine Session von Linux oder nennt man das öffnen eines Terminals eine Session.


    Mit Session meinte ich folgendes: Wenn Linux (oder auch Windows) gestartet ist, können mehrere Benutzer angemeldet sein. Jeder Benutzer hat seine eigene Session, zu Deutsch Sitzung.
    Mich würde noch interessieren, welche Möglichkeiten das Medion-Fastboot-Ubuntu bietet, mit Admin- bzw. Rootrechten zu arbeiten. Die benötigst Du, um die Dateien zu bearbeiten, um die es Dir geht. Ubuntu bietet dazu Befehle wie "su", "sudo" bzw. "gksudo", allerdings benötigt man dazu ein Terminal. Und da beißt sich jetzt die Katze ... .
    Wenn Du den Rechner startest, wird Dir dann vom Bootloader angeboten, Fastboot mit Adminrechten zu starten? Oder gibt es im nächsten Schritt, also dann wenn Linux startet und der Anmeldedialog erscheint, die Möglichkeit, sich als Administrator anzumelden? Irgendeine Möglichkeit müssen die Entwickler bei Medion doch geschaffen haben, das Fastboot-Ubuntu zu administrieren.


    Schönen Urlaub


    Gruß


    Susanne