Problem mit S/Mime - Ständige Nachfrage nach Zertifikaten

  • Hallo,


    ich habe ein Problem mit der S/MIME Verschlüsselung im Thunderbird. Was habe ich gemacht:


    1. Von trustcenter.web.de das Root Zertikat und das Email Zertifikat runtergelden und im Thunderbird importiert.
    2. Mein persönliches Zertifikat imüportiert (.p12 Datei)
    3. Eine Email geschrieben und "Digital signieren" ausgewählt
    Es kommt die Nachfrage: Sie müssen ein oder mehrere persönliche Zertifikate einrichten, bevor Sie diese Sicherheitsfunktion verwenden können. Wollen Sie dies jetzt machen?
    4. Ja geklickt
    5. Mein Zertifikat aus Schritt 2 ausgewählt bei Digitale Unterschrift und auf Nachfrage auch das selbe zum Ver- und Entschlüsseln eingetragen. OK gedrückt.
    6. Haken bei Standardmässig digital unterschreiben gesetzt.


    Nun dachte ich, es sollte gehen, aber die Nachricht wurde NICHT signiert. Bei der nächsten Testnachricht nochmal im Menü S/MIME "Digtal unterschreiben" gewählt und wieder kommt die Nachfrage aus 3. Ich sehe die zertifikate sind ausgewählt und auch bis 2014 gültig. Die Nachfrage kommt nur dauernd, aber die Nachricht wird nicht digital signiert.


    Kann mir einer verraten was ich falsch mache? Oder funktionieren die web.de Zertifikate nicht mit Thunderbird?


    Danke schon mal für jeden Hilfe,
    Frank


    Thunderbird-Version: 17.07
    Betriebssystem + Version: Win7 Pro 64Bit
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX): web.de
    SMIME oder PGP: SMIME

  • Ein bisschen rumklicken hat mich der Lösung etwas näher gebracht. Ich muss dem Root Zertifikat noch explizit vertrauen.


    Jetzt hat sich bei meinem persönlichen Zertifikat der Status von "konnte nicht verifiziert werden" auf freigegeben für u.a. Email Unterzeichner Zertifikat und Email Empfänger Zertifikat geändert. das klingt ja schon mal gut.


    Nur leider das Spiel mit der Aufforderung Zertifikate einzutragen, hat sich nicht geändert. Ich habe die Zertikate mal rausgenommen, Thunderbird neu gestartet und wieder bei der nächsten Testmail noch mal neu gesetzt wie oben beschrieben.


    Hat nichts gebracht, die Nachricht wird nicht signiert, jedesmal wenn ich das machen möchte, kommt wieder die Aufforderung, Zertifikate auszuwählen...