Enigmail/OpenGPG Mails nicht mehr korrekt ver-/entschlüsselt

  • Thunderbird-Version: 24.0.1
    Betriebssystem + Version: Windows XP
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): GMX
    S/MIME oder PGP: PGP


    Hallo,


    hatte sehr lange keine Probleme mehr mit dem Thunderbird und PGP-Verschlüsselung. Ich benutze die Verschlüsselung lediglich um mir wichtige, aber eben nicht für Spioneure und Sabogenten gedachte Informationen jederzeit über die Archivfunktion des Thunderbird bereitzustellen. Wichtige Passwörter und Zugangsdaten sowie passwortgezippte Dokumentenanhänge sende ich mir auf diese Art und Weise seit vielen Jahren verschlüsselt zu.


    Seit dem letzten Thunderbirdupdate jedoch kann ich die Anhänge nicht mehr wie früher mittels der Mailentschlüsselung mit entschlüsseln. Früher war es so, wenn die Mail entschlüsselt war, dann wurde auch der bzw. die Anhänge mit entschlüsselt und konnten als normale Dateien wieder abgespeichert werden.


    Nun ist es so, dass Thunderbird schon beim Versenden der Mails fragt wie Anhänge verschlüsselt und unterschrieben werden sollen. Angeboten werden drei Möglichkeiten. Unverschlüsselt, völliger Schwachsinn in meinen Augen, "Jeden Anhang einzeln verschlüsseln/unterschreiben und Nachricht mittels Inline-PGP senden" oder aber "Nachricht als Ganzes verschlüsseln/unterschreiben und mittels PGP/MIME senden".


    Und hier liegt der Knackpunkt. Früher konnte ich stets über die dritte Option die komplette Nachricht inklusive Anhang verschlüsseln und unterschreiben lassen. Jetzt kommt bereits beim Sendeversuch eine Fehlermeldung mit folgendem Wortlaut "Senden der Nachricht fehlgeschlagen. Bitte überprüfen Sie Ihre Konteneinstellungen, und wiederholen Sie den Vorgang."
    Es erscheint erst gar nicht das Feld zur Passworteingabe für die Verschlüsselung. Habe ich allerdings kurz vorher noch eine bereits geladene, als alte verschlüsselte Mail von mir angeschaut und die Passwortphrase ist somit noch im Speicher/Cache, erlaubt er das Versenden von verschlüsselten Mails mittels "Nachricht als Ganzes verschlüsseln/unterschreiben und mittels PGP/MIME senden". Aber nur dann, lösche ich die Passwortphrase aus dem Cache kommt beim Versendenn von Mails automatisch wieder die Fehlermeldung von oben.


    Versende ich nun aber Mails mit Anhang über die Option "Jeden Anhang einzeln verschlüsseln/unterschreiben und Nachricht mittels Inline-PGP senden" habe ich wunderbar lesbare Mails mit nach wie vor verschlüsselten Anhängen. Macht ja eher keinen Sinn für meine Konstellation bzw. meine Nutzung.


    Das Phänomen besteht mittlerweile auf mehreren Rechnern, auf denen die neueste Thunderbirdversion installiert ist. Kann jemand das Problem verifizieren und hat vielleicht eine Lösung außer dem von mir beschriebenen Workaround parat?


    Vielen Dank schon mal im Voraus für Eure Hilfe.


    So Long

  • Hallo,
    welche Enigmail- und welche gpg-Version verwendest du?
    Wie sind die OpenPGP-Einstellungen (allgemein im OpenPGP-Menü und kontenspezifisch unter "Konteneinstellungen")?
    Ist bei letzterem PGP-MIME aktiviert?
    Gibt es Fehlermeldungen im Logfile oder in der Konsole?
    Du schreibst, daß kein Passworteingabedialog erscheint. Es gibt mitunter den Effekt, daß dieser hinter dem aktuellen Fenster versteckt ist (?)
    Gruß, muzel

  • Hallo,


    erst mal eine Entschuldigung, dass ich noch nicht geantwortet habe, war vom Umfeld doch sehr stark eingebunden.


    Heute morgen hatte ich endlich wieder Zeit und konnte auf einem Rechner, nach dem Update auf die neueste Thunderbird-Version, feststellen, dass das Ver- und Entschlüsseln wieder tadellos funktioniert. Ist eigentlich schade, dass solche Update-Fakte(n) nicht in den Versionshistorien erwähnt werden. Kann mir nicht vorstellen, dass nur hier bei meinen 4 Rechnern, in Worten, vier (!), etwas falsch eingestellt gewesen sein soll.


    Sei 's drum, jetzt funktioniert alles wieder wie gewünscht.


    Danke für Deine Rückmeldung und Nachfragen.


    So Long