[Gelöst]Gesamten Schlüsselbund exportieren

  • Thunderbird-Version: 24.5
    Betriebssystem + Version: Ubuntu
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX): t-online.de
    S/MIME oder PGP:PGP


    Hallo,
    ich habe mir in einer VirtualBox Ubuntu 14.04 installiert.
    Nun möchte ich für PGP auch meinen Schlüsselbund aus dem Host z.B. via Shared_Folder übertragen.
    Leider finde ich keine Möglichkeit, den gesamten Schlüsselbund mit einem Ruck zu exportieren.
    Ich muß jeden einzelnen Schlüssel einzeln exportieren, dann in den Gast übertragen und dort dann importieren.


    Gibt es eine Möglichkeit, das einfacher zu gestalten?


    Gruß
    Ch. Hanisch

    Einmal editiert, zuletzt von Hanisch ()

  • Moin,
    warum exportieren? Kopieren und importieren!
    Einfach die Dateien pubring.gpg und secring.gpg aus ~/.gnupg auf den Zielrechner kopieren und dort importieren - oder direkt an den Bestimmungsort kopieren, wenn noch kein Schlüsselpaar dort existiert.
    HTH, muzel

  • Hallo,

    "muzel" schrieb:

    Moin,
    warum exportieren? Kopieren und importieren!
    Einfach die Dateien pubring.gpg und secring.gpg aus ~/.gnupg auf den Zielrechner kopieren und dort importieren - oder direkt an den Bestimmungsort kopieren, wenn noch kein Schlüsselpaar dort existiert.


    Mit dem Kopieren hat etwas nicht funktioniert mit den Berechtigungen. Ich habe den Ordner ~/.gnupg aus dem Host in den Gast via Shared_Folder kopiert, aber es funktionierte dann im Gast nicht.
    pubring.gpg und secring.gpg einzeln zu kopieren und dann im Gast zu importieren habe ich jetzt probiert.
    Wenn ich das mit dem Kopieren und Importieren mache, kann ich die Schlüssel nicht mehr unterschreiben.

    Code
    1. Mit diesem Schlüssel unterschreiben:==================


    zeigt keinen Schlüssel zur Auswahl mehr an.
    Das hat sich inzwischen positiv verändert, nachdem ich das Besitzervertrauen für alle Schlüssel neu festgelegt hatte.


    Ich kann aber jetzt nur verschlüsselt oder unterschrieben senden, beides geht nicht.
    Folgende Meldung, wenn ich beides angebe:

    Code
    1. Senden der Nachricht fehlgeschlagen.
    2. Bitte überprüfen Sie Ihre Konten-Einstellungen, und wiederholen Sie den Vorgang


    Gruß
    Ch. Hanisch

  • Hi,
    was sagt die Logdatei (unter OpenPGP - Fehlersuche)?
    Gruß m.

  • "muzel" schrieb:

    Hi,
    was sagt die Logdatei (unter OpenPGP - Fehlersuche)?
    Gruß m.


    Wo gebe ich da den Dateinamen für die Log-Datei ein?
    Ich habe nur 'Konsole' anzeigen' .

    Code
    1. Initializing Enigmail service ... EnigmailAgentPath=/usr/bin/gpg enigmail> /usr/bin/gpg --version --version --batch --no-tty --charset utf-8 --display-charset utf-8 gpg (GnuPG) 1.4.16 Copyright (C) 2013 Free Software Foundation, Inc. License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> This is free software: you are free to change and redistribute it. There is NO WARRANTY, to the extent permitted by law. Home: ~/.gnupg Unterstützte Verfahren: Öff. Schlüssel: RSA, RSA-E, RSA-S, ELG-E, DSA Verschlü.: IDEA, 3DES, CAST5, BLOWFISH, AES, AES192, AES256, TWOFISH, CAMELLIA128, CAMELLIA192, CAMELLIA256 Hash: MD5, SHA1, RIPEMD160, SHA256, SHA384, SHA512, SHA224 Komprimierung: nicht komprimiert, ZIP, ZLIB, BZIP2 enigmail> /usr/bin/gpg --charset utf-8 --display-charset utf-8 --batch --no-tty --status-fd 2 --decrypt --passphrase-fd 0 --no-use-agent enigmail> /usr/bin/gpg --charset utf-8 --display-charset utf-8 --batch --no-tty --status-fd 2 --decrypt --passphrase-fd 0 --no-use-agent enigmail> /usr/bin/gpg --charset utf-8 --display-charset utf-8 --batch --no-tty --status-fd 2 --comment Using GnuPG with Thunderbird - http://www.enigmail.net/ -a -t --encrypt -r 0x6C4877A5E53DF487 -u 0xE53DF487


    Liegt es an '--no-use-agent enigmail'?


    Gruß
    Ch. Hanisch

  • Zitat

    Wo gebe ich da den Dateinamen für die Log-Datei ein?


    OpenPGP-Einstellungen - Fehlersuche (und dann irgendwas, wo du Schreibrecht hats, also z.B. /tmp).
    m.

  • Hallo,


    jetzt funktioniert es, nachdem ich in OpenPGP -> Einstellungen -> Senden -> Haken rein bei "Zusätzlich mit eigenem Schlüssel verschlüsseln"


    Gruß
    Ch. Hanisch

  • Hallo,

    "Hanisch" schrieb:

    Hallo,
    jetzt funktioniert es, nachdem ich in OpenPGP -> Einstellungen -> Senden -> Haken rein bei "Zusätzlich mit eigenem Schlüssel verschlüsseln"


    das sollte man zwar grundsätzlich immer so einstellen, um seine eigenen verschlüsselt gesendeten Mails lesen zu können, es hat aber IMO mit dem Problem nichts zu tun.
    Gruß m.

  • Edit: Vollzitat gelöscht! Bitte zum Antworten die Buttons Antworten oder SchnellAntwort verwenden bzw. bei Einsatz des Buttons Zitieren nur das unbedingt Notwendige aufführen! Mod. graba


    Jedenfalls funktioniert es jetzt. Ob ich da noch andere Einstellungen verändert habe?


    Gruß
    Ch. Hanisch