Enigmail-Passwortdialog

  • Hallo zusammen,


    weiß jemand, wie man die Standardeinstellung, daß im Passwortdialog das Häkchen bei "Diesen Schlüssel beim Anmelden automatisch entsperren" gesetzt ist, ausschalten kann (s. Screenshot)? Vergißt man einmal, das Häkchen wegzunehmen, sieht man es nie wieder. Nebenbei bemerkt, ist der Dialog so penetrant im Vordergrund, daß man nicht mal einen Screenshot machen kann (weil die Hotkeys daktiviert sind), nur mit der Kamera.
    Irgendwelche Einstellungen für die Cache-Zeit für das Passwort funktionieren auch nicht (weder in der gpg.conf noch in Enigmail), es wird immer unendlich gecacht.
    Es läuft der gnome-keyring-daemon.


    TB 38.5.1
    Linux Ubuntu 14.04 LTS
    Enigmail 1.8.2 (Addon)
    Gnupg 2.0.22


    Grüße, muzel



  • Hallo muzel,

    weiß jemand, wie man die Standardeinstellung, daß im Passwortdialog das Häkchen bei "Diesen Schlüssel beim Anmelden automatisch entsperren" gesetzt ist, ausschalten kann

    ich weiß es leider nicht. Ich war bisher nicht in dieser Situation.

    Es läuft der gnome-keyring-daemon

    ich kann mir vorstellen, dass dies Dein Problem ist. Bei mir läuft inzwischen der gpg-agent. Der benutzt für die Passworteingabe pinentry. Ich habe also einen ganz anderen Dialog.
    Ich kann mich nicht mehr erinnern, ob der Umstieg auf den gpg-agenten mit dem Upgrade auf Ubuntu 14.04 einherging, oder ob das mit der nachträglichen Installation von GnuPG 2.0.x passierte. Ich vermute das kam mit GnuPG.
    Mit den gpg-agenten funktioniert dann auch die eingestellte Zeit für das Passwort-Caching.


    Gruß


    Susanne

  • Moin Susanne,


    man kann ja den keyring-daemon nicht einfach deinstalleiren, dann fällt das ganze Kartenhaus von Abhängigkeiten zusammen. Irgendwie deaktivieren und den gpg-agent aktivieren kriegt man vermutlich hin, aber erfahrungsgemäß wird man irgendwann (bei irgendeinem Update) dafür bestraft, wenn man etwas "umbiegt", was die Ubuntu-Herrscher dem dummen Anwender vorschreiben wollen.
    Welche von den vielen installierten pinentry-Varianten benutzt wird, erschließt sich mir auch nicht so richtig.
    Bei Mint ist übrigens das Häkchen standardmäßig nicht gesetzt, sonst ist das Verhalten aber genauso.
    Irgendwie habe ich gerade nicht soviel Zeit zum Basteln, will einfach nur ein benutzbares System haben.
    Trotzdem Danke für deine Tipps,


    Grüße,
    muzel

  • Hallo muzel,


    bei mir läuft pinentry-gtk2 0.8.3.


    in der gpg-agent.conf findet sich kein Eintrag, der explizit pinentry für die Passworteingabe vorsieht. Erwartet hätte etwas wie
    pinentry-program /usr/bin/pinentry-gtk-2


    aber da ist nichts. In der gpg.conf gibt es einen Hinweis für Ubuntu:


    Das erklärt zwar, dass neuerdings der gpg-agent benutzt wird. Dass der dann wiederum pinentry zur Eingabe benutzt, steht dort aber nicht. Ich vermute deshalb, dass dies vom gpg-agenten her standdardmäßig so vorgesehen ist. Nur wer eine andere GUI zur Eingabe haben will, muss das dann wohl explizit in der gpg-agent.conf eintragen.

    man kann ja den keyring-daemon nicht einfach deinstalleiren,

    Ich denke, das brauchst Du auch nicht. Falls nötig, einfach den gpg-agenten und pinentry nachinstallieren, den Eintrag "use-agent" in der gpg.conf einkommentieren und das sollte es dann gewesen sein.
    Diese Schritte musste ich allerdings nicht ausführen. Entweder kamen der gpg-agent und pinentry gleich mit der Installation von 14.04 oder mit GnuPG 2.
    Hast Du Dein 14.04 frisch installiert oder ein Upgrade gefahren? Ich hatte frisch installiert, weil ich bei Upgrade stets Ärger mit dem Treiber von AMD habe.


    Gruß


    Susanne

  • Hallo Susanne,


    pinentry war in Form von pinentry-gtk2 und -..qt4 installiert (pinentry war zu letzterem ein Link), und war es vermutlich von Anfang an, genau wie der gnupg-agent (2.0.22). Deinstalliert man pinentry-qt4 und aktiviert damit pinentry-gtk2, ändert sich nichts.

    Zitat von SusiTux

    bei mir läuft pinentry-gtk2 0.8.3.

    Bei mir jetzt auch.


    Die Einträge "user-agent" in der .conf bewirken nichts, entscheidend ist doch eher, daß irgendwo beim Systemstart per Script der agent oder daemon gestartet und bekanntgemacht wird?


    Das Ubuntu 14.04 war eine Neuinstallation auf einem Acer Aspire Netbook, auf dem vorher ein Schrott-Linpus-Linux war, das ich plattgemacht habe.


    Also mal eben Neuinstallation...
    Da ich mich nicht mehr genau an alle Klimmzüge erinnern konnte, die ich machen mußte, damit Ubuntu überhaupt bootet (Secure Boot usw.), damit WLAN und Grafik funktioniert, bin ich jetzt erst einmal mit der Neuinstallation grandios gescheitert, der Login-Dialog gestaltet sich als Endlosschleife (bei richtigem Passwort, bei falschem wird es bemängelt) - sicher ein Grafikproblem.
    Alle Menüpunkte, die man auswählen kann, wenn man im Grub advanced options (oder so..) wählt, hängen sich auf, auch so vielversprechende wie "Run in failsafe graphics mode".
    Ich bin immer begeistert, wenn nach einer erfolgreichen Installation alles funktioniert, und nach dem Reboot nichts mehr. Da kein Netzwerk, geschweige denn ssh geht, komme ich auch nicht von außen ran.


    Na gut, ich hab ja zum Glück parallel installiert und kann die Partitionen einfach löschen.
    Vielleicht warte ich auf die 16 LTS, oder versuchs auch hier demnächst mal mit Mint, auf dem PC läufts ja ganz gut.


    Grüße, muzel

  • Hallo muzel,


    Das Ubuntu 14.04 war eine Neuinstallation auf einem Acer Aspire Netbook, [...] Da ich mich nicht mehr genau an alle Klimmzüge erinnern konnte, die ich machen mußte, damit Ubuntu überhaupt bootet (Secure Boot usw.) ...

    Du fürchtest Dich offenbar vor nichts. Netbook + UEFI, da kann Linux schon eine Herausforderung sein. Mein Rechner ist noch eine BIOS-Kiste. Da hast Du mir eine Erfahrung voraus.

    ... entscheidend ist doch eher, daß irgendwo beim Systemstart per Script der agent oder daemon gestartet und bekanntgemacht wird?

    Richtig, wenn der Agent nicht läuft, wird die benötigte Umgebungsvariable nicht gesetzt. Für den Autostart sollte eigentlich bereits bei der Installation des Agenten ein Startscript mitkommen. Siehe https://wiki.ubuntuusers.de/GPG-Agent/


    Schau mal unter "Startprogramme", ob der Agent dort eingetragen ist.


    Gruß


    Susanne

  • Ja, Susanne, es sieht bei mir genauso aus, aber hinter den Kulissen wird doch nur wieder der keyring-daemon gestartet.
    #

    (der Haken war unsprünglich drin. wenn ich ihn rausnehme, geht nix mehr).
    Man muß also noch bei "Befehl" /usr/bin/gpg-agent --daemon eintragen, obwohl der ja eigentlich schon über
    /etc/X11/Xsession.d/90gpg-agent gestartet werden müßte (den Eintrag gibts).
    Aber nun wird wieder gar nichts gecacht, man muß jedesmal die Passphrase eingeben, trotz der default- und max-cache-ttl Einträge in der gpg-agent.conf.
    Alles nix für Otto-Normalverbraucher.


    Gute Nacht,
    muzel


    P.S. Nachtrag: Ich hatte noch ein selbst compiliertes GnuPG 2.0.27 unter /usr/local/bin, und ich vermute, daß sich der agent von dort "vorgedrängelt" hatte, ungeachtet der Pfadangabe in Enigmail. Nach Löschen dieser Installation funktioniert nun auch das Paßwort-Caching.

    Einmal editiert, zuletzt von muzel () aus folgendem Grund: P.S....

  • Hallo muzel,


    fein, dass es nun klappt.

    Ich hatte noch ein selbst compiliertes GnuPG 2.0.27 ...

    In den meisten Fällen, in denen ich feststelle, dass in meiner Installation irgendetwas nicht ordnungsgemäß funktioniert, liegt es an genau solchen Dingen. Gerade erst neulich wieder einmal mit Eclipse. :-)
    Wir testen Änderungen dieser Art zunächst in einer VM. Allerdings wurden diese Testumgebung sowie ein Clone davon ganz schleichend schon schon fast zu Hauptsystem. Jedenfalls wird diese VM längst nicht so oft zurückgesetzt, wie wir das eigentlich geplant hatten.
    Manchmal ist es vielleicht doch besser, man hält es wie

    Otto-Normalverbraucher

    Nur entgeht einem dann schon der eine andere Spaß.


    Viele Grüße


    Susanne

  • Nebenbei gabs noch ein Problem - wahrscheinlich das Hauptproblem: in der gpg-agent.conf stand ein falscher Eintrag ("use-agent", was aber in die gpg.conf gehört), und DER verursachte die Endlosschleife beim Start.
    Ich hatte es nochmal mit Mint 17.3 versucht, aber diesmal rechtzeitig den ssh-server installiert, und so kam ich wenigstens an die Kiste ran. Irgendwie war es $FRÜHER einfacher, in Linux auf eine Konsole zu kommen.
    Viele Grüße, muzel

  • aber diesmal rechtzeitig den ssh-server installiert, und so kam ich wenigstens an die Kiste ran. Irgendwie war es $FRÜHER einfacher, in Linux auf eine Konsole zu kommen.

    Hat das auch mit z.B. Strg + Alt + F1 nicht geklappt?

  • Hat das auch mit z.B. Strg + Alt + F1 nicht geklappt?

    Peinlich, da hätte ich natürlich zuerst dran denken können, statt Strl+ALT+<-- u.ä.
    Danke für die "Auffrischung".


    muzel