Posts by McSeafield

    Was unter diesem Thread für Fritz!Box-Einsteiger oder TB-Anfänger (wie mich) noch fehlt, ist der Verweis auf Peter´s legenendäre Erläuterung zu telnet und die bebilderten Zusätze in der TB Hilfe:


    http://www.thunderbird-mail.de/forum/viewtopic.php?t=19540
    http://www.thunderbird-mail.de…konto_telnet.php#aufrufen


    Bleibt für Anfäger eigentlich nur noch die Frage, was ist eigentlich telnet
    http://de.wikipedia.org/wiki/Telnet


    Einfacher erklärt unter Systemsteuerung > Leistung und Wartung > Verwaltung > Dienste > Telnet:


    „Ermöglicht einem Remotebenutzer, sich an diesem Computer anzumelden und Programme auszuführen. Unterstützt verschiedene TCP/IP-Telnetclients, einschließlich UNIX-basierten und Windows-basierten Computern. Wenn dieser Dienst angehalten wird, ist der Remotezugriff möglicherweise nicht mehr verfügbar. Wenn dieser Dienst deaktiviert wird, können alle Dienste, die explizit von diesem Dienst abhängen, nicht mehr gestartet werden.“


    Pfad zur EXE-Datei: C:\WINDOWS\System32\tlntsvr.exe


    Hierzu ein zusätzliches Zitat von:
    http://www.microsoft.com/germa…ecurity/tcg/tcgch07n.mspx


    „Mit dem Dienst Telnet für Windows können ASCII-Terminalsitzungen zu Telnet-Clients ausgeführt werden. Er unterstützt zwei Authentifizierungstypen und die folgenden vier Terminaltypen: ANSI (American National Standards Institute), VT-100, VT-52 und VTNT.


    Der Dienst Telnet ermöglicht außerdem eine Remoteanmeldung am Computer und die anschließende Ausführung von Konsolenprogrammen über die Eingabeaufforderung. Ein Computer, auf dem der Dienst Telnet ausgeführt wird, unterstützt Verbindungen von verschiedenen TCP/IP-Telnet-Clients, einschließlich UNIX- und Windows-basierter Computer. Der Dienst Telnet ist auf Windows XP- und Windows Server 2003-Computern standardmäßig installiert, aber deaktiviert. Bei Updateinstallationen wird der Starttyp des Dienstes Telnet in der vorherigen Windows-Version beibehalten.


    Wenn der Dienst Telnet angehalten wird, ist kein Remotebenutzerzugriff auf Programme über den Telnet-Client möglich. Remotebenutzer können zu diesem Computer keine Verbindung über das Telnet-Protokoll herstellen. Außerdem können Benutzer keine Verbindung zum Computer herstellen oder konsolenbasierte Anwendungen ausführen.“


    Und für telnet-Experten ein Beispiel wie man z.B. einen Teamspeak-Server per Telnet administriert (beachte dort auch den Link auf das interessante telnet-Tool Putty):
    http://docs.teamspeak-einstieg.de/telnet/


    McSeafield

    Sorry lieber Werner,


    Du hast unmissverständlich erklärt, dass es nicht geht. Bereits Sjfm hat geschreiben: "das kannste mal knicken". Auch das war klar. Dieser Thread ist aber mit "Anfänger Verständnis Frage" betitelt und zum Verständnis gehört nun mal auch warum es nicht geht. Ich habe 23 Jahre PC-Erfahrung und beherrsche einige Programmiersprachen. Und trotzdem kann ich nur eins sagen: "Je mehr man weiß, umso mehr weiß man, dass man nichts weiß". Leider habe ich mich viel zu spät mit TB und FF beschäftigt, und bin bei diesen Programmen nachwievor ein Anfänger. Für mich ist die ganze Thematik rund um die Profil-Verzeichnisse und die damit zusammenhängende Arbeitsweise von TB absolutes Neuland. Gleiches gilt übrigens auch für FF. Jetzt habe ich eine Vorstellung wie TB arbeitet und kann mir den Rest natürlich schnell zusammenreihmen.


    Trotzdem Danke auch an Dich, ich wollte Dir nicht nicht auf den Slips treten und habe es - glaube ich - auch nicht getan.


    McSeafield

    Was ich auf alle Fälle schon mal dazugelernt habe ist, wie man auf einem Rechner mit zwei Nutzern (Administrator und regelmäßiger Nutzer mit eingeschränktem Konto) lokal nur ein Profil einrichten braucht. Danke lieber Abacus für Deinen Hinweis.


    Das gleiche sollte natürlich funktionieren, wenn man dieses eine Profil-Verzeichnis im Netz auf einen anderen Rechner legt und entsprechend, wenn man diese Lösung im Netz vervielfältigt. Bleiben also nur die Fragen offen, was passiert, wenn zwei Nutzer gleichzeitig auf ein Profil-Verzeichnis zugreifen oder - wahrscheinlich noch problematischer - wenn zwei Nutzer gleichzeitig einen zetral installierten TB starten.


    Ich hoffe, dass zu diesen Fragen noch ein Experte Stellung bezieht. Andernfalls werde ich das Ganze bei Gelegenheit einfach ausprobieren.


    McSeafield

    Ich weiss, das gehört eigentlich nicht hierher. Aber wer das obige
    alles gelesen hat, verdient jetzt noch eine gewaltige Mozilla-Belohnung. Die bekommt er u.a. auf folgender Seite:


    http://www.at2907.net/extensions/index.php?q_id=9


    (betrifft: die Nutzung von avast 4.7 home im FF Download-Manager)


    http://www.at2907.net ist Road-Runner´s page (Peter Lehmann`s Kollege at http://www.firefox-browser.de) - eine wahre FF-Schatzgrube.


    "IM VERHÄLTNIS ZUM VERGLEICH IST DIE BASIS ZUM FUNDAMENT DIE GRUNDLAGE".


    Unglaublich, was man von Mozilla Profis alles geboten bekommt.
    Danke!!! DANKE!!! Danke!!! DANKE!!! Danke!!! DANKE!!! Danke!!!


    McSeafield

    Hallo Herbert,


    ich habe zwar auch keine Ahnung und es noch nie probiert, aber ich würde es einfach (ohne Garantie) wie folgt versuchen:


    1) Installiere TB auf einen Rechner, auf den alle zugreifen können und lege für alle Nutzer testweise imap Mail-Konten an. Wenn das klappt, hast Du m.E. schon gewonnen (Multiuser- und Multitasking Betriebssystem vorausgesetzt).


    2) In den Nutzer-Profiles Verzeichnissen werden alle Kontendaten und eMails gespeichert. Diese Verzeichnisse kannst Du m.E. notfalls beliebig verschieben. Damit TB diese Verzeichnisse findet, mußt Du wahrscheinlich nur in about:config die Verzeichnis-Parameter richtig setzen. Schau Dir dazu die Einträge unter mail.root.imap und mail.server.serverX.directory an. Um diese Einstellungen zu finden und zu ändern brauchst Du das TB Add-On about:config (bei TB Erweiterungen downloaden).


    3) Damit TB nicht anfängt zu spinnen, darfs Du nie einen Virenscanner etc. über die TB-Nutzer-Profiles jagen. Da mag TB überhaupt nicht. Damit sind wir beim nächsten Problem, Du brauchst einen Virenscanner, der die eMails bereits beim Eingang scannt. Schau dir dazu z.B. das Angebot von avast.com an. avast 4.7 home wird nicht reichen. Du brauchst vermutlich im Netz die Professional-Version, die leider etwas kostet.


    Lass mir bitte wissen, ob mein Vorschlag klappt. Ich selbst hab TB im Netz jeweils lokal installiert. Bei geringem eMail-Aufkommen ist das ja auch kein Problem.


    McSeafield

    Lieber Peter,


    zunächst möchte ich mich öffentlich für Deine private umfangreiche eMail und die damit zusammenhängende Zeit und Arbeit bedanken. Damit Alle davon profitieren, erlaube ich mir Deine eMail zusammenzufassen und wie nachfolgend komprimiert zu veröffentlichen.


    Vorausschicken darf ich noch, dass Peter wahrscheinlich recht hat und der Quality Feedback Agent (QFA) nicht das Problem darstellt. Das war in meinem Fall vermutlich zufallsbedingt der Fall und die Umstände kann ich nicht mehr nachvollziehen. Jedenfalls hat auf einem zweiten PC im Netz die Standardkonfiguration mit TB und der Fritz!Box unter etwa gleichen Voraussetzungen problemlos geklappt.


    Problemlösung nach Peter Lehmann (gilt generell für alle Anwendungen und Router):


    1) Immer zuerst sämtliche mögliche Fehlerquellen "abschalten":


    a) Firewall, Virenscanner etc. deaktivieren


    b) bei TB ggf. sämtliche Erweiterungen deaktivieren oder deinstallieren
    oder zumindest den TB im Safe-Mode (=ohne Erweiterungen) starten. Die Erweiterungen werden von externen Programmierern (also außerhalb der Qualitätskontrolle von Mozilla) geschrieben. Da passieren schon mal Pannen ... .


    c) Nutzerprofil ggf. umbenennen (vgl. unten zu 4)


    d) Programmcode ggf. neu aus einer sauberen Quelle holen


    e) Anwendung ggf. neu installieren


    2) Verbindungen mit bewährten Bordmitteln testen, z.B. mit telnet (siehe Forum).


    a) mit telnet keine Verbindung
    dann brauche ich TB oder andere Anwendungen erst gar nicht starten.


    b) wenn Verbindung klappt, dann kann ich mit telnet nicht nur die Verbindung testen, sondern sogar eine komplette Anmeldung am jeweiligen Server einschließlich Abholen und Versenden von E-Mails durchführen. Und alles ohne jegliche Konfiguration und auf der Kommandozeile. Auf diese Weise kann man sehr genau eingrenzen, ob das Problem in der Anwendung (also dem TB) oder in tieferen Schichten liegt.


    3) Schrittweise den Firewall und den Virenscanner wieder aktivieren.


    4) Der Router (gleiches gilt für Fritz!Box Protect - ein sehr empfehlenswertes Programm!) lässt im Lernmodus alle ausgehenden Pakete nach entsprechender Rückfrage durch. Bei jeder Frage gründlich nachdenken, bevor man sich ja oder nein entscheidet. Diese Fragen kommen bei jedem Update immer wieder neu. Ein durch Update geänderter TB ist nicht der gleiche wie vorher. Damit wird verhindert, das sich ein Programm (Trojaner) unter dem Namen eines anderen Programmes verstecken kann.


    Wenn alles mit telnet funktioniert und nur mit TB nicht, dann einfach das komplette Nutzerprofil umbenennen und den TB neu starten. TB legt dann ein neues Profil an und damit einen sauberen Ausgangszustand zum testen. Entsprechend sollte man bei jedem Versionsupgrade (von 1.x zu 2.x) vorgehen. Bei imap kein Problem und die wenigen erhaltenswerten Daten sind schnell rüberkopiert.


    Weitere Hinweise von Peter


    1) zum Thema: > Als erstes eine Erweiterung installieren, die eine echte "de-DE" locale (Sprache) enthält. Am besten Sie installieren MagicSLR ... Das ist überholt. TB ist schon lange komplett in viele Sprachen übersetzt. Für uns macht das übrigens "thunder", welcher auch das Forum betreibt. Er ist übrigens der Autor von MagicSLR. Ich sagte schon, mein "Pflichtprogramm", weil eine sehr wertvolle Erweiterung.


    2) Zum Thema Qualtity Feedback Agent könnte eine Fehlerursache sein.
    Möglich ist alles. Es kann unter bestimmten Bedingungen schon vorkommen, dass mehrere Probleme sich irgendwie "potenzieren". Aber den QFA als alleinige Ursache eines Problems möchte ich ausschließen. Klar läuft da ein Prozess zusätzlich, der nicht unbedingt für die Funktion gebraucht wird. Aber für mich überwiegen die Gründe, dieses Hilfsmittel nicht zu deinstallieren.


    3) Zum Thema Kontakt zu den Entwicklern. Jeder kann dem Mozilla-Team Probleme mailen. Den Link findest du auf unserer Seite. Und du kannst und solltest dir auch vorher deren Problemliste ansehen, ob der evtl. Bug nicht schon gemeldet wurde. Bei Doppelmeldungen werden sie etwas "bissig". Und dann soll man natürlich die Bugs in feinstem Englisch melden ... .


    4) Zum Thema Router allgemein: Normalerweise darfst du einen Router überhaupt nicht "spüren". Diesem mit den Zugangsdaten konfigurieren, dem eigenen Rechner möglichst eine feste IP verpassen (192.168.178.2 und folgende) und als Standard-Gateway sowie als DNS-Server die Router-IP eintragen (192.168.178.1), sowie im Internet-Explorer unter Verbindungen "keine Verbindung wählen" einstellen - das wars schon. Unter Netzwerkeinstellungen alle alten Wähl-Verbindungen löschen. Und ja keine PPPOE-Verbindung einstellen - das Wählen übernimmt ja der Router. Du brauchst also lediglich die LAN-Verbindung und möglichst, aber nicht zwingend, mit der o.g. IP. Wenn du jetzt auf der Konsole den Router anpingst, musst du diesen mit > 1ms erreichen. Wenn du eingibst "ping http://www.ard.de", musst du auch dort sofort ein sauberes Echo erhalten.



    Abschließend darf ich mich im Namen aller Leser bei Peter bedanken. Diese Ausführungen haben mir sehr geholfen und ich habe einiges dazugelernt. Ich denke dass andere Leser entsprechend davon profitieren werden.


    McSeafield

    Lieber Peter,


    Deine Antwort kommentiere ich in Kurzform wie folgt:


    zu 1) Derzeit kann ich natürlich nicht mit 100%iger Sicherheit behaupten, dass der Quality Feedback Agent dass Problem darstellt. Für eine solche Behauptung wären aufwändige zusätzliche Tests unter gleichen Bedingungen erforderlich. Ich empfehle aber, die Installation dieses Agenten als mögliche Fehlerursache in Erwägung zu ziehen. In meinem Fall waren jedenfalls alle Fehler verschwunden, nachdem ich die Installation nicht mehr zugelassen habe. Im übrigen verweise ich zur Rechtfertigung meiner Behauptung auf:


    http://www.thunderbird-mail.de/hilfe/faq1.5/#install_cleanup


    zu 3) Es kann sein, dass der MS-PnP Dienst nur im Fall der Fritz!Box
    zwingend aktiviert (nicht gestartet) sein muß. Bitte immer Ereignisprotokoll
    in der AVM-Protect Software nachsehen. Für andere Router habe ich keine
    Tests durchgeführt.


    Gruß
    McSeafield

    Auf vielen Websites ist von Problemen beim Absenden von eMails mit Thunderbird im Zusammenhang mit der AVM Fritz!Box und der Windows-Firewall (XP SP2) die Rede. Auch ich habe zunächst massive Probleme damit gehabt und lange daran rumgedoktert, den Grund zu finden.


    Ich gebe nun meine Erfahrung wie folgt an andere Nutzer weiter.


    Problemlösung:


    1. Thunderbird 1.5.0.10 benutzerorientiert installieren. Dabei das Häckchen
    für das erste Add-On, das sonst automatisch mitinstalliert wird,
    entfernen. Als erste Add-Ons für deutsche Nutzer MagicSLR 1.2.2 und
    MagicSLR Pinstripe Theme installieren. ACHTUNG: Wer diese
    Empfehlung nicht beachtet, hat einen BUG im Programm, der zu
    schwerwiegenden weiteren Konsequenzen führt.


    2. Bei der Kontenanlage in Thunderbird darauf achten, dass unter
    Extras > Konten > Kopien & Ordner die Speicherung von Kopien
    von eMails, Entwürfen und Vorlagen im lokale Ordner erfolgt, nicht
    im sent-Ordner des eMail-Providers (z.B. Freenet.de).


    3. Wenn 1. und 2. beachtet wird, gibt es mit Thunderbird und AVM Fritz!Box
    keine Firewall-Probleme. Bei meiner Installation habe ich alle
    Empfehlungen von http://www.ntsvcfg.de/sitemap.html befolgt.
    Wer die Windows-Dienste entsprechend dieser Empfehlung konsequent
    abstellt, sollte vielleicht darauf achten, dass der Universelle Plug & Play-
    Gerätehost-Dienst unter Windows-XP nicht deaktiviert sein darf,
    sonst ist Thunderbird nicht in der Lage beim ersten Versenden von
    eMails das Passwort zu verifizieren. Der Dienst muß nicht gestartet sein,
    es reicht, die Einstellung Manuell.


    4. Bei allen Antivirus-Sannern ist darauf zu achten, dass der Scanner nicht
    das Thunderbird Profiles Directory --> C:\Dokumente und Einstellungen\
    "Benutzername"\Anwendungsdaten\Thunderbird mitscannt. In der
    Thunderbird Hilfe finden sich hierzu weitere Hinweise. Ich benutze
    folgende Sanner, die ideal mit Thunderbird zusammenarbeiten und
    kostenlos sind:

    avast 4 home http://www.avast.com/
    Ad-Aware SE Personal http://www.lavasoft.de/


    Bei beiden Scannern kann man einstellen, dass das Thunderbird Profiles
    Verzeichnis nicht mitgescannt wird.


    Ich wünsche allen Anwendern viel Spass mit Thunderbird. Es ist ein tolles Programm, sobald es richtig installiert ist.


    McSeafield