Posts by Clio1

    Gut, danke für Eure Antworten.

    Dann muß etwas bei meinem System kaputt gegangen sein, ärgerlich,

    aber ich werde es schon finden.


    Übrigens habe ich einen Bugreport zu diesem Thema gefunden, meinen Wunsch habe ich gleich mal mit angefügt, aber ich glaube nicht wirklich,

    daß sich das nochmal ändert.

    Bug #1731186

    So, also definitiv ist das ein Bug. In der Beta 94.0b3 tritt dieses Verhalten nicht auf.

    Schon der zweite Bug, den ich melden muß. Der erste #1734413 betraf das Tab schließen im Tab Context Menü. In der jetzigen Beta wurde das bereits behoben.

    Na ja, auf ein Neues, nur so kann der 91esr was werden...;))


    Eigentlich könnte ein Mod das ja nach "Anpassungen" verschieben, da paßt es wohl besser.

    dharkness21

    Du hast Recht, bei meinem 27" Monitor ist das Feld ziemlich mittig.

    Aber auch mit Deinem Code läßt es sich nicht so anpassen, wie man sich das wünscht. Alles sehr widerspenstig...

    Schade auch, aber ich fürchte, da kommen wir nicht weiter.


    Was mir aber durch diese Testerei aufgefallen ist:

    Beim Verfassen einer Mail mit einem Anhang sieht alles noch gut aus, und zwar mit Deinem und mit meinem Code.

    Aber beim Empfang und dem Öffnen der Mail verschiebt sich alles und das Anhangfeld zieht sich über den ganzen Monitor. Soll heißen,

    wenn z.B. fünf Zeilen Text sind, wird der ganze Platz darunter vom Anhangfeld belegt. Das sieht äußerst unschön aus.

    Nun habe ich gedacht, das käme von den CSS Änderungen, aber nein, auch mit dem Auskommentieren des chrome Ordners und auch mit einem neuen Profil bleibt dieses merkwürdige Verhalten bestehen.

    Kannst Du das bestätigen?


    Falls ja, würde ich einen Bugreport erstellen, aber vorher möchte ich ganz sicher sein, daß es nicht an meinem System liegt.

    Ich habe auch danach gesucht, und habe dann letztlich eine Möglichkeit mit CSS gefunden. Zwar nicht ganz so wie beim 78er, aber fast.

    Das Feld ist jetzt unten, aber begrenzt und umrahmt. Da ich ein dunkles Systemtheme (Linux Debian Sid) nutze, sind die Farben entsprechend,

    das muß man natürlich an die eigenen Farben anpassen.


    Hier der Schnipsel für die userChrome.css:

    CSS
    #attachmentView 
    { visibility: visible !important;
    background-color: transparent !important;
    min-height: 100px !important;
    margin-right: 1600px !important;
    border: 1px solid #3f525f !important;
    }

    Ich kenne ein solches Verhalten bei Thunderbird nur, wenn Javascript deaktiviert ist.

    Tatsächlich, wenn ich Javascript aktiviere, bekomme ich auch den Button zu sehen. In all den vielen Jahren, in denen ich schon TB verwende, hatte ich aber immer Javascript ausgeschaltet, daher war mir nur das Installieren aus einer Datei bekannt.

    Danke für den Hinweis.

    Thunder hat das Für und Wider schon erwähnt, also lasse ich es jetzt eingeschaltet.

    dharkness21

    Das ist schon so, wie ich geschrieben habe. Ich kann ein Addon herunterladen, entweder direkt von der HP oder über besagten Button, und dann aus TB heraus das Verzeichnis wählen und das Addon installieren.

    Wir sprechen aber schon von Thunderbird und nicht vom Firefox, denn dort funktioniert das direkte Installieren?

    Ich nutze übrigens Linux Debian, aber ich glaube nicht, daß das einen Unterschied macht.

    In die userChrome.css diesen Schnipsel einfügen:


    * {
    background-color: #fff !important;
    color: #000 !important;
    }


    Ob das allerdings für alle Ansichten taugt, mußt Du probieren.

    Sonst den Vorschlag von MSFreak übernehmen.


    OT: Du solltest die Datei richtig benennen. Die falsche Schreibweise ist sehr irritierend, zumal auch andere Forenteilnehmer mitlesen.

    Nachfolgender Code gehört in die userContent.css, falls noch nicht vorhanden, mußt Du die neu anlegen.

    Das gilt noch für Vers. 68, in Vers. 78 wurde das in die userChrome verlegt, später dran denken.


    #abResultsTree treechildren::-moz-tree-row
    { color: #000 !important; }

    #abResultsTree treechildren::-moz-tree-row(selected)
    { color: #000 !important; }


    Damit wird die Schrift schwarz. Willst Du was anderes, mußt Du das mit der gewünschten Farbe überschreiben.

    Soll auch der Hintergrund geändert werden, heißt der Parameter background-color:


    Noch zwei Hinweise:

    -moz-appearance: none ist überflüssig. Das none ist der Standard, also braucht man den Parameter nur, wenn man auch was ändern will.


    Xul gibt es in Vers. 78 nicht mehr, dafür steht dann der Wert xhtml.

    Das mußt Du in Deiner userChrome ändern, wenn Du die 78er verwendest.

    Eine grundlegende Voraussetzung für einen Linuxuser ist es, das Paketmanagement der installierten Distribution zu nutzen, und keinesfalls - wie Du es gemacht hast und auch von Windows gewohnt bist, einfach irgendwas zu installieren, was dazu führt, daß solche Fehler passieren.

    Linux ist kein Windows!

    Schaue in die Paketverwaltung von MX, dort werden sicher auch die passenden Sprachpakete für TB zu finden sein.

    Ich habe kein MX, aber soweit ich weiß, gibt es dort apt und wahrscheinlich auch synaptic.

    Wenn Du das richtige Paket gefunden hast, deinstalliere vorher das von Dir zusätzlich installierte.

    Das gilt für alle Software in MX. Niemals am Paketmanager vorbei installieren, und als Anfänger schon gar nicht. Da fehlen die Kenntnisse, um das zu überblicken.


    In die FAQ sollte so ein falsches Verhalten für Linuxanwender auf keinen Fall aufgenommen werden!

    Durch das extrahieren der .xpi wird die Signatur zerstört und die Extension ist kaputt, also nicht mehr installierbar.

    Extensions werden heruntergeladen, im Addons-Manager den Button "aus Datei installieren" wählen und der Vorgang startet.

    Das war aber schon immer so, ist also nichts Neues.

    Vielen Dank für Deine Antwort.

    Das Anwendungsmenü öffnet sich durch einen Klick auf den Hamburgerbutton.

    In TB 60 war es noch zweiseitig, in TB 68 ist nun alles auf einer Seite. Wenn Du im Anwendungsmenü auf den Menüpunkt Extras klickst, öffnet sich ein weiteres Menü mit z.B. dem Inspector.

    Dieses Extramenü ist auch über die F10 Taste aufrufbar.

    Bei mir funktioniert die Alt-Taste leider nicht, warum auch immer. Das hat schon in TB 60 nicht funktioniert, evtl. liegt es am OS. Ich vermute, Du setzt ein Windows ein. Ein paar kleine Unterschiede gab es schon, sollte zwar nicht sein, ist aber wohl doch so.

    Ich kann also mit einem Rechtsklick die Menüleiste anhaken und habe dann auch die Auswahl Hamburgerbutton (Anwendungsmenü) und Extramenü.

    Na ja, damit kann ich sicher leben, aber nur eine Taste wäre halt schöner.

    Hallo allerseits,

    ich bin auf der Suche nach einer Tastenkombi, um das Anwendungsmenü über die Tastatur zu öffnen, analog der F10 Taste für das Extramenü. Mit Vers. 68 wurde das Anwendungsmenü ja komplett angepaßt, daher funktioniert die Alt-Taste leider nicht mehr, wie noch z.B. im Firefox.

    Die Menüleiste ist ausgeblendet, ebenso der Hamburger-Button. Sicher könnte ich den Button wieder sichtbar machen, aber eine Taste wäre für mich optimal, da ich die Maus weniger benutze.

    Ich würde auch eine Änderung in der omni.ja in Betracht ziehen, wenn es aber einen anderen Weg gibt, wäre das auf jeden Fall besser.

    Hat hier vielleicht jemand einen Hinweis dazu?

    Schau direkt in den Einstellungen von about:config, also

    Einstellungen - Erweitert - Reiter Konfiguration bearbeiten. Dann als Suchbegriff color eingeben.

    Dort sind alle Farben, die einzeln verändert werden können.

    Der Parameter dürfte msgcompose.text_color sein.

    Bei mir (unter Linux) wird hin und wieder mal

    - der Kalender nicht vollständig geladen (Tabbeschriftung "Kalender" fehlt, Tage mit Termin im Minikalender nicht fett, ...)

    - Terminbeschriftungen ggf. unsichtbar u.s.w.

    Da hilft auch kein "Restart", der Code macht einfach Probleme.

    Das kann ich bestätigen. Das passiert, wenn ich die Hintergrundfarbe, die Schriftfarbe und die Ränderfarbe gesondert angebe, so wie oben beschrieben.

    Das passiert nicht, wenn ich "-moz-appearance: textfield" angebe, dann werden die Farben des Themes umgesetzt. In meinem Falle sind es die gleichen Farben, daher macht es keinen Unterschied.

    Hm, bei mir funktioniert das so, ich habe allerdings in meiner userChrome.css als ersten Eintrag generell die Border ausgestellt:

    CSS
    * { border: none !important; }


    Ich habe eine Menge Anpassungen und setze Ränder ganz gezielt ein. Evtl. verschwinden dann bei Dir einige davon, mußt Du mal testen.

    So sieht das bei mir aus.

    Vielleicht mußt Du das Systemtheme auch mal ändern, möglich, daß es die Farben verändert.


    Sind die Umlaute denn jetzt sichtbar, das kann man in Deinem Screenshot nicht erkennen.