Posts by NumLock

    Die gute Nachricht lautet: Der Bug ist gemäß Bugzilla gefixt!


    Was dann noch so eine Schattendiskussion soll, muss ich nicht verstehen, oder? Klar ist doch, es handelt sich um einen Bug im Thunderbird. Nachzulesen hier: https://bugzilla.mozilla.org/show_bug.cgi?id=1601905 . Dort steht unter anderem


    Quote from Toshihito Kikuchi

    This caused a regression that if a filepath contains whitespaces, we pass it to a target application without quoting it ...


    Interessant auch

    Quote from Jorg K

    Frankly, I'm on TB 68.3.1 where the bug is not fixed so far and I've never experienced it despite opening attachments left, right and centre. But it only affects certain applications; I can open PDFs with spaces in their name with PDF XChange Viewer with no problem ... EDIT: And .odt and .doc(x) in LibreOffice (EDIT 2: version 5.4) and images in Windows Photo Viewer.


    Dies bestätigt, dass der Fehler nicht bei jedem auftritt/-trat. Bei mir funktionierte das auch stets einwandfrei.

    Warum taucht nun im Pfad system32 auf? Ich vermute, das ist eine unmittelbare Folge des Bugs. Unter System32 liegt die Komponente, die innerhalb Windows aufgerufen wird, wenn ein Programm ein anderes starten oder ihm Daten übergeben möchte. Ähnlich, wie es bei OLE oder früher DDE war. Irgendein Windows Dienst/Server muss das ja erledigen. Selbst wenn die Benachrichtigung an das Programm über COM stattfinden würde, ginge es nicht ohne die zugehörige Windowskomponente.

    Wenn mehrere Mails (oder ein Thema/eine Diskussion) selektiert sind und das R-Klick-Menü "Speichern unter.. " benutzt wird, fällt die Wahl des Speicherformats im Dialogfenster weg

    Das ist auch unter Windows so. Der Grund dafür ist einfach. Der Dialog, der zum Speichern benutzt wird, ist der allgemeine Dialog von Windows.

    Wenn man in Windows mehrere Dateien markiert, haben diese in vielen Fällen unterschiedliche Formate.

    Durchaus nachvollziehbare Gründe.


    Aber hey, was lehrt uns der Artikel noch? Die Bayern leben immer noch alle auf dem Dorf und haben natürlich was gegen Schwule. In Sachsen wiederum leben nur Nazis. Klar, dass die dort von den Behörden gedeckt werden. Da hat der eine demokratische Schüler einen schweren Stand.

    Herr Reuter wollte bestimmt nur lustig sein. Ha, Ha, ... selten so gelacht. Starker Journalismus, muss ich schon sagen.

    Du machst es gerade etwas schwierig, weil du in zwei Reihen postest. Ich gehen immer noch davon aus, dass ein automatisches Ausführen in einen lokalen Ordner nicht vorgesehen ist.

    Dir bleibt aber das manuelle Ausführen. Kannst ja einen Button dafür hinlegen. Dann ist es nur ein Klick.

    Oder du sparst dir den Zwischenschritt mit dem Ordner Newsletter und lässt die Mails gleich aus dem Posteingang in die endgültigen Ordner einsortieren. Das ginge dann automatisch.

    Wieso meint ihr, das Versand nicht ginge?

    Ganz einfach, ich kannte diese Option für das Versenden nicht. Ich weiß nicht, seit wann es sie gibt. Bestimmt schon seit Jahren. Nur habe ich nicht darauf geachtet.

    Hab's ausprobiert - funktioniert. Ebenso wie bei eingehenden. Ich kann dir nicht sagen, warum die bei dir nicht gehen. Wenn du sicher bist, dass die Regel korrekt ist, würde ich zum Testen mal ein neues Profil anlegen. Es gibt auch Log für die Filter. Da kannst du auch mal reinschauen.

    Soweit ich weiß werden die Filter nur für den Posteingang automatisch ausgeführt. Für anderen Ordner müsste das manuell erfolgen. Die Kriterien werden jedenfalls angeboten: Status ist gelesen und Alter ist größer als. Allerdings in Tagen, nicht in Stunden.


    Du könntest mal prüfen, ob FiltaQuilla es erlaubt, Filter auch auf andere Ordner automatisch anzuwenden.

    Du findest in diesem Forum irgendwo eine Anleitung, wie man mit Hilfe des Inspectors die Elemente identifizieren kann, um sie dann per css anpassen zu können. Suche mal danach. Vielleicht hilft dir das weiter.

    Zur Putzfrau, ... . Es sind immer die selben 3 oder 4 Typen, die hier wie im Firefoxforum die ewig gleiche Show abziehen. Das nervt dermaßen ... .

    Probiere es doch mal so ...

    Erstelle einen Test-Benutzer unter Windows. Den kannst du später wieder löschen. Tut also nicht weh. Darin startest du Thunderbird und bekommst ein neues Profil. Aber eben nur diese eine, d.h. auch in der profiles,ini und sonstwo wird es für diesen Benutzer nur dieses eine geben. Dann richte ein IMAP-Konto ein und teste dein -compose. Geschätzter Testaufwand: 15 Minuten.

    Ich will ja nicht das Spiel verderben, doch irgendwas passt nicht. Die Endung mab ist normalerweise kein bekannter Dateityp. Das heißt, es sollte völlig egal sein, ob man das Häkchen setzt oder nicht. Die Endung wird, so vorhanden, in jedem Fall angezeigt.

    Hab's sicherheitshalber selbst nochmal ausprobiert. Sie erscheint in beiden Fällen.


    Außerdem handelt es sich um eine reine Anzeigesache ohne Auswirkung auf Typ oder Funktion. Es wäre ja schlimm, wenn das anders wäre. Es ist egal, ob die Endung angezeigt wird oder nicht. Wenn sie vorhanden ist, dann erkennt der Thunderbird den Typ auch. Gleiches gilt für die bekannten Dateitypen. Windows erkennt den Typ selbstverständlich auch dann, wenn die Endung ausgeblendet ist. Kann jeder leicht überprüfen. Man erkennt es ja schon am Symbol.


    Erstellt man eine Datei Test.txt und blendet die Endung aus, erscheint sie nur als Test. Benennt man sie in diesem Modus um in Test.mab, dann bleibt es trotzdem eine Textdatei mit dem Bezeichner Test.mab.txt. Auch das kann jeder ganz leicht selbst ausprobieren.

    das reicht nicht.

    Das sollte nicht so nicht sein, schließlich hat der Hersteller die Kontrolle über seine Software. Es trifft aber leider bei manchen Produkten zu. Grund können zum Beispiel veränderte Verbindungseinstellungen, die beim Deaktivieren nicht rückgängig gemacht werden. Das fällt eher in die Rubrik Fehler, Nichtwollen oder Schlamperei.

    Wenn es so einfach wäre, könnte das auch problemlos jede Mailware.


    Diese Begründung wird oft abgeschrieben und nachgeplappert, sie stimmt aber nicht. Eine Minute nachdenken genügt, um das zu erkennen.

    Selbstverständlich kann ein Programm jede Funktion die es besitzt auch wieder deaktivieren. Das heißt noch lange nicht, dass ein anderes Programm oder ein Angreifer das ebenfalls kann. Dazu wäre eine Privilegieneskalation nötig. Das wiederum wäre ein schwerer Bug.

    Hätte ein Angreifer aber Systemrechte erlangt, dann kann er sowieso alles machen, auch all das, was Uninstaller macht.

    Ja klar, das stimmt schon. Wenn man es nicht meldet, sollte man sich nicht beschweren oder eine Erwartung aufbauen. Ich werde mich aber nicht weiter engagieren. Wenn das jemand, also ein Entwickler, untersuchen soll, der es nicht selbst reproduzieren kann, benötigt er ausreichend Daten. Das alles hat mich aber locker bereits 15 Stunden Zeit gekostet, die ich wirklich besser hätte verbringen können. Da werde ich nicht nochmal von vorn beginnen und all die erforderlichen Daten generieren. Ich bin im Moment halbwegs zufrieden mit der Lösung, die ich am Laufen habe.

    Es kommt noch was hinzu. Das mit der Offline-Unterstützung ist wohl nur Teil eines der verschiedenen Probleme, denn bei Papierflieger trifft es ja nicht zu. Jedoch liest man seit Jahren, auch hier, dass es damit immer wieder mal hakt. Genauer untersucht hat das anscheinend in all der Zeit niemand oder nicht vollständig oder was auch immer.

    Das ist bitte kein Vorwurf an irgendjemanden. Ich weiß ja um die im Vergleich zu Firefox sehr begrenzten Ressourcen und Mittel.

    starte ich TB68 über die Konsole, erscheinen dort Fehlermeldungen wie diese, wenn ich Kalendereinträge synchronisieren:

    Ich hatte auch Meldungen in der Konsole. Die konnte ich aber nicht interpretieren. Eine richtig lesbare Fehlermeldungen, wie bei dir, habe ich nicht gesehen.

    Hast du mal nachgelesen, ob gemäß RFC

    Code
    VALUE=DURATION:-PT30M

    erlaubt ist? Das - erscheint mir schon komisch. Steht das überhaupt so in dem Termin?


    Der Schuldige ist einwandfrei TB68!

    Schuldig ist vielleicht etwas zu stark formuliert. Es spricht jedoch tatsächlich alles dafür, dass hier die Ursache liegt.

    Oder du machst es wie ich und gehst wieder zu TB60 zurück. damit läuft es einwandfrei.

    Mit der 60 läuft es einwandfrei. Das ist richtig. Einfach nicht upzudaten ist aber auch keine gute Idee. Ich hoffe ja immer noch, dass jemand den oder die Fehler findet und beseitigt.

    Golem.de schreibt:

    Quote

    Die Sicherheitslücke steckt laut Mozilla in der Browserkomponente Ionmonkey, ein Just-in-time-Compiler für Javascript.


    Gemäß gHacks hat Mozilla die Unterstützung für Javascript in Mails bereits vor Jahren komplett entfernt. Bleiben also nur noch Feeds und Erweiterungen, für die Javascript noch aktiv ist.

    In diesem Zusammenhang stimmt die Doku nicht mehr oder ist zumindest sehr missverständlich:

    Quote

    JavaScript ist in Thunderbird standardmäßig aktiviert. Es gibt im Einstellungen-Dialog seit Thunderbird 2 keine Option mehr, um JavaScript zu deaktivieren. Dies geht nur noch für fortgeschrittene Anwender mit einer versteckten Option per Konfigurations-Editor.