Posts by Toby

    Hallo edvoldi,


    vielen Dank für die schnelle Antwort.
    Aber ein bisschen blind war ich doch: mir ist erst jetzt aufgefallen, dass man in der Minimonatsansicht oben auf den Monat und die Jahreszahl klicken kann... Nicht ganz so gut, wie ein eigenes Eingabefeld, aber deutlich besser, als x-mal auf den Pfeil nach rechts zu klicken.


    Grüße
    Toby

    Hallo Forum,


    bin ich einfach nur blind? Ich finde bei Lightning keine Möglichkeit, in der Ansicht zu einem bestimmten Datum zu springen also ein Goto-Button. Über das Minimonth-Feld ist das nicht so komfortabel, wenn man einen Termin für das nächste Jahr plant.


    Früher hatte ich lntplus (https://addons.mozilla.org/de/thunderbird/addon/ltnplus/), aber das funktioniert nicht mehr. Kann mir jemand helfen?


    Grüße
    Toby


    Thunderbird-Version:17.0.7:
    Win8:
    Lightning-Version: 1.9.1:

    Hallo,


    meine Frau hat das gleiche Problem/ ein sehr ähnliches Problem mit Mails von einer Freundin.
    Wenn die Freundin direkt schreibt ist es kein Problem, wenn Sie aber Mails beantwortet/ diese weiterleitet wird nur das Originalmail in TB angezeigt, der neue Text ist weg.


    Die Freundin schreibt online mit web.de - sie schreibt sie hätte "das neue web.de" und würde immer mit HTML schreiben, das ließe sich auch nicht umstellen.
    Meine Frau nutzt TB 7.0.1, WinVista, AVG als Virenscanner, Mail werden per POP abgeholt.
    Es scheint ein Problem von TB mit der Interpretation der Mail zu sein: andere Mailprogramme zeigen es richtig an + wenn man den Quelltext der Mail etwas anpasst zeigt auch TB alles an (siehe unten).
    Daran ändert sich nicht durch Umstellung zwischen Nachrichtenansicht "Original HTML"/ "Vereinfachtes HTML" oder "Reiner Text".


    Leider kann ich das Problem nicht ganz nachstellen - vermutlich, weil ich nicht "das neue web.de" nutze. Leider konnte ich bisher auch nicht rausfinden, was es mit dem neuen web.de auf sich hat. Daher gibt es leider auch kein Minimalbeispiel, sondern nur ein Kürzung und Anonymisierung der Mail, die ich hatte...


    Aber der Quelltext der Mail ist ganz interessant: Es gibt zwei Teile

    1. einen HTML-Teil mit ziemlich viel Formatierungskram (sieht fast so schlimm aus, wie HTML aus Word...), der sowohl die Originalnachricht, als auch den Antworttext enthält.
    2. einen Plain-Text-Teil, der aber nur den Originaltext enthält, nicht die Antwort.



    Interessant finde ich, den Teil im Header

    Code
    1. Content-Type: multipart/alternative;
    2. boundary="----=_Part_6120038_913932478.1319395564760"


    Das Mail ist mehrfach unterteilt durch

    Code
    1. ------=_Part_6120038_913932478.1319395564760


    Unten steht der Plain-Text:


    Wenn ich die Nachricht speichere und den Quelltext mit einem Text-Editor ändere, in dem ich den Plain-Text-Teil lösche wird alles angezeigt.


    Wenn die Mail also so aussieht, dann klappt es (Änderung ganz am Ende):


    Hat jemand eine Idee, wie man TB dazu bewegen kann, den HTML-Teil zu interpretieren, auch wenn der zweite Teil da ist?
    Ist das ein Bug in TB oder hält sich TB an die Norm und web.de macht einfach Mist (scheint mir bei dem Quelltext nicht unwahrscheinlich...).


    Gruß
    Tobias

    Hallo,


    Quote from "mrb"

    Welche genau möchtest du denn übernehmen?


    um das heraus zu finden wollte ich ja die aktuellen Einstellungen anschauen und wenn ich das richtig verstanden habe müssten die ja auch alle in der prefs.js stehen. Da sich über die Jahre einiges angesammelt hat weiß ich nicht mehr genau, was ich gemacht habe und will es deshalb dieses mal auch soweit möglich in die user.js packen.
    Konkret fallen mir z.B. Einstellungen zum Threading, zur Darstellung von plaintext Mails, aber ich weiß eben nicht, was ich sonst noch eingestellt habe.


    Viele Grüße
    Toby

    Quote from "mrb"

    Hallo,


    Das widerspricht sich.
    entweder du machst ein neues Profil und damit alle Kontoeinstellungen noch einmal und hast also ein frisches unverbrauchtes Profil (empfehlenswert) oder du übernimmst das alte mit allen seinen Macken.


    Ich will ja nicht alles übernehmen, aber die sinnvollen Einstellungen, die per GUI nicht eingestellt werden können möchte ich übernehmen.


    Quote from "mrb"

    Einstellungen für das Layout in TB stehen in der localstore.rdf.


    Danke für den Hinweis und auch für die anderen Antworten!


    Grüße
    Toby

    Hallo Joke,


    danke für die Antwort!
    Die meisten Fragen sind damit beantwortet. Was ich noch nicht ganz verstanden habe ist, wie about:config eigentlich genau funktioniert: welche Einstellungen werden angezeigt, wo werden die Dinge gespeichert und kann man alles was man hier ändert auch in der user.js ändern?


    Gruß
    Toby

    Hallo,


    nach ca. 5 Jahren muss mein Profil endlich mal neue gemacht werden und da kommen ein paar Fragen auf: wie kann ich alle Einstellungen finden, die ich über die Jahre gemacht habe und wie hängen prefs.js, user.js und about:Config genau zusammen?

    • Wie genau funktioniert about:Config -- wo werden die Einstellungen genau gespeichert/ geändert?
    • Wie kann ich herausfinden, was ich in about:Config geändert habe?
    • Stehen alle Einträge, die ich in about:Config geändert/ hinzugefügt habe auch in der prefs.js?
    • Wie funktioniert die user.js: werden die Einträge dauerhaft in die prefs.js kopiert? Falls ja: wann (bei jedem Start von TB)?
    • Was passiert, wenn ich einen Eintrag in der user.js lösche, muss ich den dann auch in der prefs.js löschen, damit sich etwas verändert?
    • Welche Einstellungen habe Vorrang (user.js vor prefs.js habe ich in der Dokumentation gefunden, aber wie ist es mit about:Config)? Wenn z.B. ein Eintrag sowohl in der user.js gemacht wurde als auch in der about:Config verändert wurde: welche Einstellungen gelten dann?
    • Für das neue Profil: kann ich alle Einstellungen, die man in about:Config macht auch in user.js machen, so dass ich das nächste mal nur die user.js kopieren muss bzw. nur in die user.js schauen muss, um zu sehen, welche Einstellungen auf meinem Mist gewachsen sind?


    Viele Fragen, für die ich im Forum und der Dokumentation hier leider keine Antworten gefunden habe und bei denen sich einige wahrscheinlich erübrigen, wenn eine andere Frage beantwortet ist, aber bevor ich nachher doch noch Fragen habe stelle gleich alle, die mir gerade einfallen.


    Schon jetzt vielen Dank für alle Hinweise.


    Gruß
    Toby

    Hi AJ2,


    bei dem Adressbuch/ den Adressbüchern ist es wichtig, dass sie richtig geschrieben sind (ohne Adressbuch kommt auch keine Warnung, weil dann der Sinn der Extension sowieso hinfällig ist).
    Ist die Empfängeradresse (also Deine eigene Private) evtl. im Adressbuch? Versuch es mal mit einer nicht existierenden wie z.b. kasdkfjaskjfaskjdfasdf@asdfkle.dekdlajlkdj da sollte auf jeden Fall eine Warnung kommen.


    Evlt. kommt auch eine Fehlermeldung in der "Error Console", falls ja wäre die für mich interessant.


    Ansonsten könnte ich mir im Moment nur vorstellen, dass sie die Extension mit einer anderen installierten Extension nicht verträgt (könntest Du testen, indem Du ein neues Profil erstellst und dort nur diese Extension installierst).


    Toby

    Diese Aussage ist leider zu ungenau, um eine Lösung zu finden:

    - ist die Extension richtig installiert?
    - sind alle Einstellungen richtig?

    * Oben die privaten eMail-Adressen durch Komma getrennt
    * Unten die Namen der Privaten Adressbücher durch Komma getrennt - z.B. "Persönliches Adressbuch,Meine Privaten Adressen" (ohne Anführungszeichen, wenn zusätzlich zum "Persönlichen Adressbuch" ein Adressbuch "Meine Privaten Adressen" bei der Warnung nicht berücksichtigt werden soll wurde)

    - kommt immer ein Warnung oder nie?
    - ...

    Hallo,


    nur falls es nochmal jemanden interessieren sollte: ich habe das Problem jetzt so gelöst, dass ich kein prefwindow mehr nehme - das macht die Sache zwar etwas aufwändiger - aber dafür funktioniert es...


    Hier der Code:



    Gruß, Toby

    Hallo Thunder,


    danke für die Antwort. In dem Fall wird es aber eher an Windows Vista liegen - oder hast Du auch mit Vista getestet? Ich habe gerade ein neues Profil aufgesetzt und habe das gleiche Problem...


    Viele Grüße, Toby

    Hi Talula,


    hast Du mit der "MessageID" oder mit "Betreff und Empfänger" gesucht? Beide kann etwas dauern, bei "Betreff und Empfänger" können natürlich noch einige Nachrichten kommen, die nichts damit zu tun haben aber zufällig mit dem gleichen Betreff an die selbe Person geschickt wurden, bei "MessageID" dürften nur die echten Antworten als Ergebnis kommen.


    Mehr weiß ich aber nicht, da ich die Extension eigentlich nicht nutze - ich wusste nur, dass es sie gibt.


    Viele Grüße, Toby

    Hallo Thunder,


    in Tb 1.5 funktioniert es auch bei mir wunderbar, nur mit 2.0 nicht (daher habe ich die MaxVersion auch noch auf 1.5).
    Wie kann ich ändern, dass die Adressen in UTF-8 kodiert werden, vielleicht hilft ja das?


    Gruß, Toby

    Hallo,


    ganz sicher war ich mir ja nicht, in welches Forum ich diese Frage am besten posten sollte – habe mich dann aber entschieden, dass Erfahrungen mit der Übersetzung wahrscheinlich am ehesten weiterhelfen.
    Ich habe bei meiner eigenen Extension (privateID) mit TB 2.0 RC1 unter Windows Vista (ob das auch bei anderen Windows Versionen so ist kann ich leider gerade nicht sagen) das Problem, das Umlaute in den Einstellungen nicht mehr richtig funktionieren: wird zum Speichern der Einstellungen und das Optionen Fenster (siehe Code unten) genutzt, dann werden die Umlaute anscheinend nicht richtig gespeichert: aus „Persönliches Adressbuch“ wird „Persönliches Adressbuch“.


    Wird die Einstellung gegenüber den Code

    Code
    1. gprefs = Components.classes["@mozilla.org/preferences-service;1"]
    2. .getService(Components.interfaces.nsIPrefBranch);
    3. gprefs.setCharPref("extensions.privateid.adrBook",adrBookToSet);


    gespeichert, dann erscheinen die Umlaute in prefs.js richtig und mit

    Code
    1. gPrefs.getCharPref("extensions.privateid.adrBook");


    kann man die Optionen auch richtig auslesen, allerdings können diese Optionen von Code des Optionen-Fensters nicht gelesen werden und erscheinen dort auch nicht.
    Kann mir jemand sagen, was ich ändern muss, damit auch Umlaute wieder richtig geschrieben und gelsen werden?



    Viele Grüße, Toby