TLS/SSL-Verschlüsselung mit Beta2

  • Hallo


    Kann es sein, das TB 2.0 noch nicht richtig mit den Zertifikaten umgehen kann?
    Ich kann nämlich meine zertifikate nicht dauerhaft speichern sondern werde bei jedem Start nach der richtigkeit des Zertifikates gefragt.
    Mit TB 1.5 geht es jedoch ohne Probleme.


    mfg manuel

  • Danke für die Antwort


    So wie es aussieht liegt der Fehler wohl darin, dass sich mein Provider ein eigenes Zertifikat erstellt hat.


    Aber warum funktioniert es dann bei TB1.5?


    Werde mal nachforschen

  • Hi,


    sollte das Zertifikat wirklich nicht vorhanden sein, dann kannst du es jederzeit aus der 1.5.x exportieren und in der 2.x importieren. Vergiss die Vertrauenseinstellungen nicht.


    Und immer daran denken: Es ist eine BETA-Version!
    Ich kann jedem nur empfehlen, sich nur dann mit Vorversionen zu befassen, wenn er mit den daraus resultierenden Fehlermeldungen, Abstürzen und sonstigen Effekten leben und umgehen kann. (Auch wenn das evtl. nicht unbedingt für dich zutreffen muss, aber man kann das nicht oft genug sagen.)


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hi


    Da es ja eine Beta ist, dachte ich, ich meld das mal einfach damit man das Problem (falls es eins ist) auch lösen kann für die ofizielle Version.


    Nun noch zu meinem Problem:
    Ist es normal das ich im Zertifikat-Manager das Zertifikat nur unter Websites angezeigt bekomme?


    manu

  • Ja, das ist "normal".
    Die root-Zertifikate (Herausgeberzertifikate) siehst du unter "Zertifizierungsstellen". Dort gehören sie auch hin.
    Ein kleiner aber unbedeutender Bug ist trotzdem drin (zumindestens bis zur 1.5,x, für die 2.x hatte ich noch keine Zeit zum Testen): Wenn du ein Benutzerzertifikat hinzufügst (Import unter "Zertifikate anderer Personen") dann ist es nach dem Einstellen des Vertrauens auf einmal "verschwunden". Dafür taucht es unter "Websites" wieder auf. Allerdings ohne Vertrauen. => also noch einmal Bearbeiten und Vertrauen einstellen. Du kannst auch gleich ein Personenzertifikat nach Websites importieren. Sparst dir damit die zusätzliche Runde.
    Das ist, wie gesagt meiner Meinung nach ein Bug. Aber ein bedeutungsloser. Im Endeffekt ist es egal, wo die Zertifikate angezeigt werden.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!