Ordner-Problem

  • Hallo!


    Ich habe folgendes Problem:


    Ich würde gerne meine Emails in einem verschlüsselten Bereich meiner Festplatte ablegen.


    Standardmäßig befinden diese sich unter "C:\Dokumente und Einstellungen\[Nutzer]\Anwendungsdaten\Thunderbird\Profiles\...".


    Gehe ich nun in Thunderbird und stelle in den Konteneinstellungen (Extras - Konten - Servereinstellungen) unter "Lokales Verzeichnis" dieses um (z.B. auf "D:\Emails") und starte Thunderbird neu, habe ich für jedes Email-Konto neue Ordner im Fenster "Alle Ordner". Die sind allerdings in der ursprünglichen Einrichtung nicht zu sehen.


    Woran liegt das?
    Wie kann ich das beheben?


    Ich möchte, dass mein Thunderbird im Fensterbereich "Alle Ordner" lediglich den "Lokalen Ordner" anzeigt und sonst nichts. So wie er es normal auch macht. Nur sollen die Emails eben auf der Festplatte woanders gespeichert werden.

  • Hallo,
    habe eigentlich auch erwartet, dass jemand hier vorbeischaut.
    Schön, dass man es im Snap gut erkennen kann, nur habe ich derartiges noch nie gesehen.
    Und das Merkwürdige, ich habe in meinem Testprofil das gleiche gemacht, es passiert aber gar nichts, der neu platzierte Ordner ist immer noch leer und neue Mails gehen in den alten Ordner.
    Was passiert, wenn du diese Ordner unterhalb von lokaler Ordner löscht?
    Mache vorher eine Sicherung der betr. Mbox-dateien (die ohne Namen) oder verschiebe evtl. Mails in andere Ordner.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Zitat von "mrb"

    Was passiert, wenn du diese Ordner unterhalb von lokaler Ordner löscht?


    Es passiert gar nichts - sie lassen sich nicht löschen.


    Ich habe schon den kompletten Ordner "Profile" verschoben, aber auch dann ergibt sich das Problem.

  • Hallo comlar,


    gibt es einen Grund, warum du nicht das gesamte Profil in den verschlüsselten Ordner legst? Wenn man total paranoid ist, kann man auch das Profil aus der Profiles.ini löschen und sich eine kleine Batch für dieses Profil zurecht legen....z.b.


    "%programfiles%\Mozilla Thunderbird\thunderbird.exe" -profile t:\thunderbird\comlar


    wenn in "t:\thunderbird\comlar" die Prefs.js des Profils liegt.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Wie gesagt:
    Ich habe schon den Ordner "Profile" umkopiert mit dem gleichen obigen Ergebnis.

  • hmm... ich hatte ein ähnliches Problem als ich das jetzt mit der Befehlszeile getestet habe... nach einem Neustart von TB über den normalen Weg war das dann wieder weg.... ich bin da auch ein bisschen ratlos da das bei einem IMAP-Ordner war, in welchem dann bisher noch nie gesehende Ordner auftauchten und neben den Ordnern waren Fragezeichen. Vermutlich gibt es da ein Problem mit den Indexdateien... sehr merkwürdig.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Bleibt die Frage, wie ich das beheben kann... Und natürlich, wofür es die Möglichkeit gibt, einen Pfad einzutragen bei den Konten-Einstellungen, wenn dies gar nichts bewirkt bzw. solche seltsamen Phänomene auftreten?


    Leider ist es auch kein Ausweg, TB in den verschlüsselten Bereich zu installieren, da auch dann die Profile wieder unter "C:\Dokumente und Einstellungen\..." zu finden sind.

  • dafür kannst du das profil mit dem profilmanager im verschlüsselten ordner anlegen. Ich habe das auf einer meiner beiden installationen auch so gemacht und keine Probleme. Das es Probleme beim Batchstart eines Profiles mit dem Profile - Parameter gibt muss aber auch neu sein.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Profilmanager? Stehe gerade auf dem Schlauch?

  • im Startmenü oder über "%programfiles%\Mozilla Thunderbird\thunderbird.exe" -p


    vielleicht soltest du dir auch mal die Doku ansehen (siehe oben links der link Dokumentation) :wink:


    schöne Grüße


    Toolman


    Ach ja, Thunderbird darf nicht laufen da sonst nichts passiert wenn du den Link im Startmenü oder den Befehl in Start>Ausführen eingibst.


    Für das Anlegen separater profile habe ich auch eine Anleitung geschrieben.
    http://agsm.de/index.php?optio…task=view&id=20&Itemid=40

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Doku ist nicht nötig. War nur ein wenig verwirrt.


    Eventuell kann man das wirklich über den Profilmanager lösen. Aber eine Möglichkeit das Profil "default" zu ändern gibts dort wohl nicht oder? Ich sehe nur "Profil erstellen", "Profil umbenennen" und "Profil löschen".

  • na ja , profil kopieren und mit dem Profilmanager darauf verweisen... ich mach das aber lieber anders herum. Profil erstellen und das alte profil dann in das neue kopieren. In beiden Fällen solltest du die Profiles.ini danach aufräumen. Ist zwar nicht zwingend aber es ist einfach sauberer...

    Zitat

    Doku ist nicht nötig. War nur ein wenig verwirrt.


    echt? ich hab aber immer mehr das Gefühl, als ob das in deinem Fall angebracht wäre. Denn auch diese Information findest du dort noch einmal zum nachlesen.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Stand wirklich nur ein wenig auf dem Schlauch. Habe es inzwischen verstanden, wie das Problem gelöst werden kann - eigentlich ganz einfach. Da hätte ich auch selbst drauf kommen können. Manchmal sieht man den Wald vor lauter Bäumen nicht...


    Danke!