Klickbare Netzwerlinks in der Mail !?

  • Hallo,


    mir ist gerade aufgefallen das eine Mail (bereits Gesendet) keine klickbaren Netzwerlinks anzeigt...


    z.B: \\server\test.zip


    Im Verfassen Fenster ist auch "www.test.zip" erstmal schwarz. Aber unter "Entwurf" dann nicht mehr. IMHO ging das doch mal... *kopfkratz*


    Wer kann helfen?

  • "c303" schrieb:

    mir ist gerade aufgefallen das eine Mail (bereits Gesendet) keine klickbaren Netzwerlinks anzeigt...


    z.B: \\server\test.zip


    Das ist ja auch kein richtiger Link, probier es mal mit "file://///server/test.zip".


    "c303" schrieb:

    Im Verfassen Fenster ist auch "www.test.zip" erstmal schwarz. Aber unter "Entwurf" dann nicht mehr. IMHO ging das doch mal...


    Wenn du deine Mails im Textformat schreibst dann ist das völlig normal und das war auch noch nie anders. :wink:


    Gruß
    Werner

  • Zitat


    Das ist ja auch kein richtiger Link, probier es mal mit "file://///server/test.zip".

    Selber mal getestet? Das geht nicht.


    Zitat

    Wenn du deine Mails im Textformat schreibst dann ist das völlig normal und das war auch noch nie anders. :wink:

    HTML... vor 14 Jahren oder so das letzte mal. War ein versehen.


    Was ich möchte ist einen simplen Link im Intranet verschicken das auf eine z.B. *.zip Datei führt.


    Firefox z.B. behandelt jene als solche: "file://///server/test.zip" wird akzeptiert. Kann ich dem Thunderbird beibringen diesen Link auch auszuführen? Sprich: Firefox (oder was auch immer) öffnet sich beim Empfänger, und die *.zip Datei wird zum Download angeboten.


    Als Link wird sie zumindest schon mal angezeigt. Beim draufklicken passiert aber nichts.

  • Hallo c303,



    ich hab das Problem auch, hab mal die Fehlerkonsole von TB angeworfen - zuerst kommt ein:


    Sicherheitsfehler: Inhalt auf mailbox:///D|/Thunderbird1/Mail/test/Drafts?number=4055 darf file://///servername/d$ nicht laden oder verlinken.


    und dann ein:
    Fehler: uncaught exception: Load of file://///Servername/d$ from mailbox:///D|/Thunderbird1/Mail/test/Drafts?number=4055 denied.


    Die Zeilen:

    Code
    1. user_pref("capability.policy.policynames", "localfilelinks");
    2. user_pref("capability.policy.localfilelinks.sites","imap://username@mail.example.com:143");
    3. user_pref("capability.policy.localfilelinks.checkloaduri.enabled", "allAccess");


    siehe auch:
    http://kb.mozillazine.org/Link…C_SeaMonkey_1.0_and_newer



    hab ich natürlich gleich als erstes in die Prefs.js gesetzt - bringt aber anscheinend nichts.


    hmm... eigentlich schade, aber da muss man dann wohl mit batch-Dateien oder anderen Krücken arbeiten.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

    Einmal editiert, zuletzt von Toolman ()

  • Mit IMAP kann ich das nicht testen, aber bei POP-Konten funktioniert es einwandfrei wenn man Thunderbird beendet, die folgenden Einträge in die user.js übernimmt und Thunderbird neu startet.

    Code
    1. user_pref("capability.policy.policynames", "localfilelinks");
    2. user_pref("capability.policy.localfilelinks.sites","mailbox://");
    3. user_pref("capability.policy.localfilelinks.checkloaduri.enabled", "allAccess");


    Quelle: http://kb.mozillazine.org/Links_to_local_pages_do_not_work


    Diese Änderungen können nicht mit dem Konfigurationseditor vorgenommen werden, vermutlich sind deshalb auch die Einträge in der prefs.js wirkungslos.


    Gruß
    Werner

  • Hallo Werner,


    tja, wie sagt man so schön: kaum macht man es richtig - schon funktionierts..:-)


    in der Prefs.js scheinen die Zeilen nichts zu bringen.


    Danke und schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • "Toolman" schrieb:

    in der Prefs.js scheinen die Zeilen nichts zu bringen.


    Das habe ich gar nicht ausprobiert weil ich im Firefox-Wiki den Hinweis gelesen hatte dass die capability-Einträge bei about:config nicht angezeigt werden, interessanterweise stehen jetzt aber exakt die drei Zeilen die ich vorhin gepostet habe in meiner prefs.js. :o


    Gruß
    Werner

  • Hoi zäme


    Einträge in die user.js werden in die prefs.js übernommen. Deshalb muss man solche die man weghaben will, auch an beiden Orten löschen.


    Grüsse, Bruno

  • "Toolman" schrieb:

    tja, wie sagt man so schön: kaum macht man es richtig - schon funktionierts..:-)

    Wie genau? Hier kommt nur der Dialog ob ich die externe Anwendung starten will. Tue ich dies, passiert nichts.


    In der user.js steht nun:

    Code
    1. // Links in E-Mails öffnen "\\server\test\test.zip"
    2. user_pref("capability.policy.policynames", "localfilelinks");
    3. user_pref("capability.policy.localfilelinks.sites","mailbox://");
    4. user_pref("capability.policy.localfilelinks.checkloaduri.enabled", "allAccess");
  • also in meinem Fall hatte ich einen Test-link auf z.B.


    file://///servername/d$/test.txt als mail geschrieben und in den Vorlagen abgespeichert (zum testen halt). Obwohl die Datei existiert ging dann nur der Explorer auf und zwar mit \\servername\d$ - weiter nicht... ich vermute dass das Dollarzeichen stört, hab das aber nicht weiter ausprobiert.


    Vielleicht kannst du ja mal schreiben wie dein Link aussieht - sind Sonderzeichen oder Leerzeichen dabei, die u.U. in HTML-Tags eingeschlossen werden müssen, ect...


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • "Toolman" schrieb:

    Vielleicht kannst du ja mal schreiben wie dein Link aussieht - sind Sonderzeichen oder Leerzeichen dabei, die u.U. in HTML-Tags eingeschlossen werden müssen, ect...

    Der Link zum Testen lautet in der Windows-Welt ganz simpel einfach nur:


    "\\server\1.zip"


    Wenn ich dies im TB unter Entwürfe anklicke, sollte sich der Browser öffnen und der Browser sollte diese *.zip Datei wie jede andere aus dem Web handeln können...
    Wohl einfacher als es aussieht.

  • Hallo c303,


    "c303" schrieb:

    Der Link zum Testen lautet in der Windows-Welt ganz simpel einfach nur:


    "\\server\1.zip"


    ich bezweifel dass das so "in der Windows-Welt" funktioniert.


    denn auch hier muss man den "\\servername\Freigabenamen\datei" verwenden.


    das heißt nach deinem Beispiel:


    nicht \\server\1.zip sondern \\server\freigabe\1.zip


    und wie du den vorangegangenen Postings entnehmen kannst, musst du den Link dann so schreiben:


    file://///server/freigabe/1.zip


    Windows kann übrigens mit beiden Konventionen umgehen - gib den Pfad mal in Start>Ausführen ein (kann man gut zum testen verwenden) :wink:


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Zitat


    nicht \\server\1.zip sondern \\server\freigabe\1.zip

    Ja meinte ich ja. Hab mich vertippt.


    Also:


    "file://///server/temp/1.zip" geht. Kann das jemand mit Outlook oder andere Mail Clients dann genau so öffnen wie ich es mit TB kann?

  • wie sagt man so schön - probieren geht über studieren:


    - speichere eine Testmail als entwurf und diese dann als eml-Datei ab(rechtsklick in der Mailübersicht auf die Mail>Speichern unter...)... dann öffnest du oe und öffnest die eml-Datei unter OE. Dann probierst du den Link einfach mal aus.... :wink:


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro