Senden langer E-Mails mit Verschlüsselung schlägt fehl

  • Ich habe vermutlich ein Problem mit Enigmail (Thunderbird 2.0.0.6, Enigmail 0.95.3, WIN32) und bereits als Entwurf gespeicherten (langen) E-Mails:


    * Beim ersten Mal kam die Frage, ob ich die E-Mail als Entwurf immer verschllüsselt speichern will. Ich dachte mir "Wieso nicht?" und habe zugestimmt.


    * Bei langen Mails kann ich während dem Schreiben die E-Mail problemlos in den Entwürfen speichern.


    * Nun ist es so, dass ich beispielsweise nach einer Stunde Mailschreiben die E-Mail in den Postausgang legen oder direkt absenden will.


    Dann erhalte ich jedoch die Fehlermeldung, dass die "Konteneinstellung überprüft werden" soll und die Nachricht nicht abgespeichert werden könne.


    * Speiche ich diese "nicht sendbare" E-Mail bei den Entwürfen ab, so kann ich sie bei den Entwürfen öffnen und dann direkt (als neue Instanz der E-Mail) versenden.


    Dieser Fehler ist reproduzierbar und taucht auch bei einer Freundin von mir mit genau dem gleichen Verhalten auf.


    Mein Lösungsansatz wäre jetzt gewesen, die Verschlüsselung der Entwürfe auszuschalten - jedoch finde ich keine Möglichkeit dazu... :(


    Hat jemand eine Idee oder ist zufällig mit dem gleichen Problem konfrontiert (gewesen udn hat eine Lösung parat)?


    Ich habe bereits ausprobiert ob ein Deaktivieren mit anschließendem Aktivieren der GnuPG-Option für das verwendete Mailkonto die Frage ob "Entwürfe verschlüsselt gespeichert werden sollen" erneut erscheinen lässt - leider nicht. :(


    TIA, Martin

  • Hallo Martin,


    das solltest Du überprüfen:

    • Sind die Mails in "Entwürfe" wirklich verschlüsselt?
    • Ist die Einstellung "Nachrichten standardmäßig verschlüsseln" unter Extras\Konto\OpenPGP-Sicherheit ausgewählt?


    Was passiert, wenn Du nach dem Starten von TB eine Mail an Deine Freundin schreibst, keine Passphrase eingegeben hast und "Speichern/Entwurf" wählst?


    Bei mir erscheint der Dialog:


    OpenPGP-Bestätigung
    Möchten Sie die Nachricht verschlüsseln vor dem Speichern?
    [ ] Antwort merken und in Zukunft nicht mehr fragen


    in Abhängigkeit vom Wert des entsprechenden Schlüssels in der userprefs.js
    Setze den mal zurück auf "0".


    Aus der Hilfe zu Enigmail


    ---- Anfang ----
    Show "save draft encrypted" message (and remember selected state)
    user_pref("extensions.enigmail.saveEncrypted",0);


    JS: When saving a message that is to be sent encrypted as a draft, Enigmail checks if you would like to save the draft as an encrypted message.
    On by default
    ---- Ende ----


    Ändern kann man den Status über
    Extras-->Einstellungen--> Erweitert-->Konfiguration bearbeiten


    Mit der rechten Maustaste auf dem Schlüssel "extensions.enigmail.saveEncrypted" das Kontextmenü aufrufen und ändern wählen.


    Gruß Jürgen

  • Zitat von "JürgenB"
    • Sind die Mails in "Entwürfe" wirklich verschlüsselt?
    • Ist die Einstellung "Nachrichten standardmäßig verschlüsseln" unter Extras\Konto\OpenPGP-Sicherheit ausgewählt?


    Ja, die Mails in den Entwürfen sind wirklich verschlüsselt - zumindest mit meinem eigenen Key (sonst könnte ich sie ja nicht mehr öffnen und bearbeiten :) ).


    Nachrichten werden nicht standardmäßig verschlüsselt, die Antworten werden verschlüsselt, da die eingehende Mail verschlüsselt war (entsprechende Option im TB augewählt).


    Zitat von "JürgenB"


    Was passiert, wenn Du nach dem Starten von TB eine Mail an Deine Freundin schreibst, keine Passphrase eingegeben hast und "Speichern/Entwurf" wählst?


    Sie wird verschlüsselt abgespeichert - mit meinem public key. Daher ist auch keine Eingabe der Passphrase notwendig.


    Zitat von "JürgenB"


    Bei mir erscheint der Dialog:


    OpenPGP-Bestätigung
    Möchten Sie die Nachricht verschlüsseln vor dem Speichern?
    [ ] Antwort merken und in Zukunft nicht mehr fragen


    Diese kam bei mir auch, dort hatte ich eben bestätigt das er nicht mehr fragen soll.


    Zitat von "JürgenB"


    in Abhängigkeit vom Wert des entsprechenden Schlüssels in der userprefs.js
    Setze den mal zurück auf "0".


    [...]


    THX, jetzt kommt wieder das Auswahlfenster. Dann lasse ich die Entwürfe mal nicht verschlüsseln, mal sehen ob der Fehler dann auch weg ist.


    edit


    Hat leider nicht hingehauen. Gleicher Fehler wieder... :-(


    Grüße, Martin

  • Zitat von "X_FISH"


    Hat leider nicht hingehauen. Gleicher Fehler wieder...


    Schade, wäre zu einfach gewesen. ':?'


    Bei dem Versuch Dein Problem nachzustellen, konnte ich Deine Fehlermeldung mitunter reproduzieren. Leider nicht konstant.


    Der Fehler trat dann bei mir auf, wenn ich

    • in den TB-Einstellungen "Alle x-Minuten automatisch speichern" eingestellt hatte und
    • das Schreiben der Mail länger dauert, als die Gültigkeit der Passphrase.
      OpenPGP-Einstellung: "Passphrase für y-Minuten im Cache behalten".
    • Dabei x<y


    Sicher keine Beseitigung der Fehlerursache aber wenn nur Du Zugriff auf den Rechner hast, verlängere doch die Gültigkeit der Passphrase auf ein ausreichend große Zeit z.B. 120 min. Wenn die Schreibdauer dann kleiner 2h ist, dann gibt es das Problem bei mir nicht mehr.


    Ach ja, wenn ich die Passphrase manuell gelöscht habe, gab es das Problem auch nicht.


    Gruß Jürgen

  • Würde Sinn machen mit der Gültigkeitsdauer. Jedoch hatte ich da auch schon mal probiert gehabt und eben kurz vor dem Sendeversuch eine andere Mail angeklickt. Dort musste ich dann natürlich meine Passphrase eingeben.


    Anschließend der Versuch die Mail abzuschicken - auch ein Fehler... Oder ich habe bei dem Test irgendwas anders gemacht.


    Habe übrigens inline-Signieren auch noch aktiv, könnte ja auch noch irgendwie beim Fehler "mitmischen".


    Meine derzeitige Lösung: Auf "Mail beantworten" klicken und sofort die Verschlüsselung unten rechts "ausklicken".


    Dann gibt's auch keine Probleme mehr - bis jetzt jedenfalls.


    Obwohl ich den Dialog von wegen "Mails verschlüsselt in Entwürfe speichern" mit "Nein" bestätigt habe, kam ja die Fehlermeldung.


    Na, mal sehen ob's noch weiter vorkommt. Strg+C ist derzeit eben mein Freund beim Mailschreiben. ;)


    Grüße, Martin