TLS Verschlüsselung läuft nicht [erledigt]

  • Hallo,
    ich habe Thunderbird mit IMAP und SMTP von einem PC auf einen anderen mit Mozbackup kopiert. Auf dem alten PC war IMAP (SSL) korrekt eingerichtet und auch das Senden mit SMTP (TLS Verschlüsselung) klappte nach dem akzeptieren des Certifikates von unserem Mailserver problemlos. Jetzt habe ich die Einstellungen kopiert. Thuderbird meldet sich auch erfolgreich am IMAP Server an und importiert alle Ordner und Einstellungen (Paswort ist das Gleiche wie bei SMTP). Alle Mails werden empfangen. Beim Senden gibt Thunderbird mir erst den Hinweis, dass das E-Mail Prüfprogramm eine verschlüsselte Mail gefunden hat (er zeigt aber an das er mit dem Mailserver verbunden ist); nach klicken von OK erscheint die Meldung, dass ein Fehler beim senden der NAchricht vorliegt: Es konnte nicht per StartTLS mit dem SMTP server (Servername) Kontakt aufgenommen werden, da er StartTLS nicht in Verbindung mit Ehlo unterstützt. Bitte überprüfen Sie die Servereinstellunge.
    Wie gesagt, sind die OK. Auf einem anderen Rechner in Netzwerk funktioniert das problemlos. Betriebssystem auf beiden PCs ist Windows CP SP2 mit allen Updates, identisch sozusagen. Auch eine Deinstallation von Thunderbird (mit allen Profilen im Verzeichnis Dokument und Einstellungen und eine anschließende Neuinstallation brachte keine Änderung. Firewall so konfiguriert (Windows Firewall) das alle entsprechenden Ports (25 bei SMTP und 993 bei IMAP) sind freigeschaltet.


    Ich weiss nicht mehr weiter. Kann mir einer helfen?
    Viele grüße
    neelsen01

  • Hi neelsen01,


    und willkommen im Forum.
    Ich habe mich gerade mal bei euch umgesehen, aber leider keine Angaben über die erforderliche Konfiguration euerer Mailclients gefunden ... .
    Also muss ich doch etwas raten.


    Zuerst verwundert mich euer "E-Mail Prüfprogramm". Du verschlüsselst die Verbindung zum hauseigenen (??) Mailserver mit TLS, und willst gleichzeitig mit einem "E-Mail Prüfprogramm" die Mails prüfen? Was ist das für ein Programm? (Symantec Mailgateway?)
    Bei solchen Programmen können schon Effekte dieser Art auftreten. Wirkt es als Gateway (also TLS bis zum GW, Scannen, neue Verschlüsselung bis zum MTA?) oder ist es so konfiguriert, dass es den verschlüsselten Verkehr nur meldet, aber nicht prüfen kann?


    Ist das Zertifikat des SMTP ein "offizielles", also eines einer im Zertifikatsmanager eingetragenen CA, oder ein selbstzertifiziertes Serverzertifikat. Wenn letzteres, ist das root-Zertifikat dieser CA importiert? Dessen Vertrauen eingestellt?


    In solchen Fällen ist meine Vorgehensweise:
    - die Konten ohne Verschlüsselung zum Laufen bringen
    - mit TLS testen
    - wenn es nicht funktioniert, mit SSL testen
    - wenn auch das nicht geht, dann bietet der Provider eben beides nicht an.
    (dass "TLS wenn möglich" Blödsinn ist, erklärt sich von selbst.)


    Da ihr ja selbst der Provider seid, muss eben dann dort weiter gesucht werden. (s. oben)
    Wobei ich mich wirklich frage, wozu ich bei einem hauseigenen MTA innerhalb des Intranet unbedingt TLS machen muss ... .


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter,


    vielen dank für Deine Hinweise. Ich werde das mit dem Virenscanner überprüfen. Da läuft Symantec AntiVirus Corporated Edition, der eben auch Mails checkt. Kann sein, das da was ist. Hatte nur vorher noch nie derartige Probleme. Warum TLS zum eigenen Mailserver weiss ich leider auch nicht. Hat der Mailadmin so festgelegt; leider weiss der auch keinen Rat. Ich melde mich sobald ich die Einstellungen überprüft habe.
    Viele Grüße
    neelsen01

  • Hallo Peter,


    habe tatsächlich den Virenscanner als Verursacher des Übels ausfindig gemacht. Seltsam, dass bei anderen PCs mit Thunderbird und IMAP und SMTP diese Probleme nicht auftraten.
    Vielen Dank noch ein Mal. Ansonsten kann ich allen Usern von Thunderbird (natürlich auch von Firefox) das Tool Mozbackup empfehlen, damit kann man (normalerweise..) schnell und sicher BAckups erstellen und auf einem anderen PC wieder einspielen.


    Schöne Grüße
    neelsen01 :P