OpenPG-Schlüssel nicht akzeptiert trotz Schlüsseltausch ok

  • Hallo,


    Ich nutze die neuesten Versionen von Thunderbird (2.0.0.9), GnuPG (1.4.8) und Enigmail (0.95.6) auf meinen MAC (OS X 10.4) und habe erfolgreich die öffentlichen Schlüssel mit dem Mail-Partner getauscht.



    Trotzdem sagt mit gpg:
    1. usr/local/bin/gpg --charset utf8 --batch --no-tty --status-fd 2 -d
    gpg: Passphrase kann im Batchmodus nicht abgefragt werden


    2. gpg: verschl"usselt mit 2048-Bit ELG-E Schl"ussel, ID xxx, erzeugt 2007...
    "Name <name@xxx.de>"
    gpg: Entschl"usselung mit Public-Key-Verfahren fehlgeschlagen: Falsche Passphrase
    gpg: Entschl"usselung fehlgeschlagen: Geheimer Schl"ussel ist nicht vorhanden


    Sowohl Schlüssel-ID als auch E-mail-Adressen sind korrekt.
    Meine Gegenseite kann meine Mails lesen.
    Mein Schlüsselpaar im Schlüsselbund zeigt private und public key an.




    Hintergrung-Info:
    Derzeit holt Thunderbird meine Mails bei meinem Mail-Provider ab. Dort lagern Mails, die mir von einem anderen Mailserver dorthin geforwarded werden. Das Versenden von Mails erfolgt anders: meine Mails werden via Thunderbird mit dem Mail-Provider synchronisiert und danach direkt an Dritte verschickt (u.a. an den Mailserver, wo meine Original-Mails ankommen und gespeichert werden)


    Wer kann mir helfen??


    Gruss
    macony

  • Hallo,


    dann poste mal bitte alle Enigmail-Einstellungen, insbesondere aber:
    - Passphrase (nicht) abfragen ?
    - Agent (nicht) verwenden ?


    Privater Schlüssel: Gültigkeit, Vertrauen etc. gesetzt?


    Gruß, muzel

  • Hallo muzel,


    Danke für den instant reply.
    Habe Settings in Enigmail geändert und es geht. Perfekt !!!


    Hast Du auch einen Tip wie die Sonderzeichen "ä, ö, ü, ß" richtig angezeigt werden können.
    Unter welchem Stichwort kann ich hier nachsehen (bin ein echter Laie bei PCs).


    Gruss
    macony