Bug in Undo-Funktion / Ordnerkomprimierung zerstört Mails?

  • Hallo,


    ich habeTB Version 2.0.0.12 (20080213) und mir ist folgendes aufgefallen, ich schildere mal:


    Wenn ich den TB Junk-Filter manuell auf einen Ordner anwende, so werden einige Mails als Junk identifizert, entsprechend markiert und in den Ordner "Junk" verschoben. Außerdem läuft danach die automatische Ordnerkomprimierung durch. Soweit so gut.


    Wenn ich danach mit Strg+Z den Verschiebevorgang rückgängig mache, dann wandern die vom Junk-Filter verschobenen Mails wieder in ihren alten Ordner und bleiben weiterhin als Junk markiert. So soll es sein.


    Nun das Problem: Nach dem Zurückverschiebenen sind fast alle zurückverschobenen Mails korrupt! Der Inhalt ist entweder zerstückelt oder TB zeigt ein einfach nur ein leeres weißes Fenster an, der Quelltext besteht dann nurnoch aus einem großen Zeichensalat (ohne Header!), auch nach einem Programm-Neustart!


    Glücklicherweise mache ich häufig Backups, sodass ich alle Mails wiederherstellen konnte. Ich habe das ganze dann mehrmals wiederholt, mit verschiedenen Ordnern und jedes mal waren die meisten Mails am Ende korrupt (vielleicht auch alle, hab mir nicht die Mühe gemacht auf jeden einzelnen Buchstaben zu verifizieren). Jetzt habe ich mal scharf nachgedacht und die automatische Ordnerkomprimierung abgeschaltet - das Problem tritt seitdem nicht mehr auf!


    Also vermute ich mal, dass die Undo-Funktion nicht die Aktivitäten der Ordnerkomprimierung berücksichtigt, sondern einfach die Daten an ihre alte Stelle zurückschiebt und sie dadurch korrumpiert, oder so. Vielleicht sollte sich das ein TB-Programmierer mal genauer anschauen, wäre ja schon ein ziemlich übles Problem!