.doc-Anhänge werden nicht richtig angehängt/versendet

  • Hallo zusammen!
    Erstmal vorweg: Habe schon das Forum durchsucht, bin jedoch zu keiner Lösung gekommen. Mein Problem ist folgendes:


    Wenn ich .doc-Dateien an eine Mail anhänge und die Mail dann versende, ist der Anhang sowohl beim Empfänger als auch in meinem Sent-Ordner in die Mail eingefügt und es stehen die wirresten Zeichen drin. Das ursprüngliche Word-Dokument ist dann nichtmehr extra als Anhang dabei sondern halt nur so seltsam im Text eingefügt.


    Benutze Windows XP mit Office 2007 und Thunderbird 2.0 mit nem AOL-IMAP-Account.
    Allerdings tritt das Problem nur auf, wenn ich die Dateien als kompatibel mit Word 97-2003 speichere und nicht, wenn ich sie als Word 2007-Dokument speicher. Das liegt vermutlich daran, dass die Dateien in 2007 automatisch als .docx gespeichert werden und nicht als .doc.


    Ich hoffe, dass hier jemand ne Lösung parat hat, ist nämlich sehr wichtig.
    Schonmal besten Dank,
    Ropei

  • Hallo,
    könntest du mal den Header von jeweils der Mail, die Ok ist und die, die nicht OK ist hier posten?


    Ich vermute hier Unterschiede in der Deklarierung.


    Korrekt aussehen müsste der Quelltext (strg+U) so:


    Content-Type: application/msword;
    name="Formular Veranstaltung.DOC"
    Content-Transfer-Encoding: base64


    Handelt es sich wirklich um eine *.doc und nicht um ein umbenannte *.rtf?


    Wurde die Datei direkt aus Word verschickt oder normal angehängt.
    Format war Rein-Text oder HTML?
    Es befinden sich keine Umlaute/Sonderzeichen im Namen des Anhangs?
    In der Registry deines Systems unter:
    HKEY_CLASSES_ROOT\.doc
    steht unter content type was?


    Beende TB und lösche die Datei mimetypes.rdf im TB-Profil.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Noch etwas:
    ändere mal unter Extras, Einstellungen, Erweitert, Eigene Konfiugration
    den Eintrag
    mail.content_disposition_type auf 1


    Neustart von TB erforderlich.
    Damit fehlt Mails der Zusatz "inline", womit einige Mailklienten/Systeme nicht klar kommen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw