Unterordner verschwunden

  • Hi Leute!
    Ich habe eine sehr komische Erfahrung mit meinem schönen Thunderbird gemacht...
    Gott sei Dank ist es mittlerweile kein Problem mehr, da ich zufällig eine Sicherung hatte.


    Das ganze verlief so:
    Habe in einem Konto einen Ordner Angelegt, und darin mehrere Unterordner, um mal etwas Ordnung zu schaffen.
    Die Strucktur sah dann etwa so aus:

    Code
    1. Konto-X
    2. -> Ordner
    3. -> UOrdner1
    4. ->eMail1
    5. ->eMail2
    6. -> UOrdner2


    Und wie ich heute TB wieder starte, waren irgendwie die Unterordner weg. Hab jetzt nur noch einen Ordner "Ordner" in dem sich gar nichts befindet.
    Hab dann mal ins Profilverzeichnis geguggt. Dort sind die Dateien "Ordner" und "Ordner.msf" vorhanden, aber ein Ordner "Ordner.???" fehlt.


    Kann mir jemand erklären, wie es dazu kommen konnte, dass mir sowas nicht nochmal passiert?


    Kann es daran gelegen haben, dass ich den Ordner "Ordner" von Konto-X in die Local-Folders verschoben habe? (also in TB)
    Das war auch etwas komisch, er hat das Ganze wohl erst kopiert, und ich hab dann den Ordner in Konto-X einfach gelöscht...


    Alles sehr komisch irgendwie ;)


    Ich bin für jeden Kommentar und Erklärungen dankbar. Wenn euch was einfällt, was hierzu interessant sein könnte, wie sich TB verhällt, schreibts einfach rein.


    Grüße
    Daniel

    4 Mal editiert, zuletzt von Kenny ()

  • Hallo und guten Tag Daniel,


    eine Möglichkeit ist, dass die neuen Ordner mit Unterordnern von TB im System (z.B. Win) als Ordner.sbd angelegt werden und erst mal 0 Bytes haben. Und dann gibt es nette Tools, die O Byte Ordner/Dateien als Müll entsorgen.

    Zitat von "nuja"

    Ja, zur Ursache sollte man noch erzählen, dass immer wieder Ordner verschwinden, in denen NUR Unterordner und keine Mails liegen. Das Problem liegt dabei in den sogenannten Datenbereinigungstools, die oftmal gnadenlos alle Dateien mit 0 K Größe als überflüssig ansehen und löschen.


    TB braucht aber die 0 K großen Dateien mit dem Namen <ordnername> um damit die Verbindung zum Unterordner <ordnername>.sdb herzustellen, der wiederum die MboxDateien der Unterordner enthält.

  • Ja, das habe ich hier im Forum auch schon gelesen.
    Allerdings wüsste ich nicht, dass ich ein solches Tool im Einsatz habe. Bei mir läuft eigentilch nur der Virenscanner, der aber wohl kaum was gegen 0 Byte Dateien haben sollte, und bei dem ich auch nirgends etwas finden konnte, dass er was in Quarantäne hätte oder so. (AV-Scanner ist Avast!)

  • Verbiete dem Scanner auf jedem Fall das Scannen im Profilverzeichnis.
    Antivirus-Software - Datenverlust droht!
    Siehe dir dazu den Link unter "Vermeidung von.." an
    Und dafür

    Zitat

    , da ich zufällig eine Sicherung hatte.

    sollte nicht zufällig, sondern regelmäßig gesorgt werden.
    Ich sicher täglich beim herunterfahren, privat je nach Mailaufkommen und indiv. Stand langt vielleicht auch alle 3-4 Tage oder wöchentlich.
    Stell dir einfach die Frage: wenn morgen beim Start alles weg ist, ist das schlimm..? und entscheide selbst.

  • Jaja, das ich öfter Sicherungen machen sollte weiss ich ja ;) (wozu studier ich Informatik und will mich auch noch in die Richtung spezialisieren ;))
    Aber auch beim hochfahren hätte mir die Sicherung nichts gebracht, die eMail war noch vom gleichen Tag.


    Ansich ist es mir ja auch grad mal egal ob das nu weg is,.. 1. weiss ich ja, dass ich selbst schuld bin, wenn mal was verschwindet, 2. hatte ich ja mal wieder Glück :)
    Mir gehts eigentlich viel mehr darum zu erfahren warum das Ganze so passiert ist, wie es eben passiert ist.


    Mir fällt grad auf, dass ich oben gar nix von irgendwelchen Mails geschrieben hab, ich werd das mal grad noch ergänzen (falls es noch geht)


    Grüße
    Daniel

  • Hi, guten Tag Daniel,

    Zitat

    Kann es daran gelegen haben, dass ich den Ordner "Ordner" von Konto-X in die Local-Folders verschoben habe? (also in TB)
    Das war auch etwas komisch, er hat das Ganze wohl erst kopiert, und ich hab dann den Ordner in Konto-X einfach gelöscht..

    vermutlich hat da beim Verschieben etwas nicht geklappt und wenn du den Ordner löschst, sind auch die Inhalte futsch.

    Zitat

    (kann mir wer sagen, wie das so schön ohne die "_" gehen würde?)

    nun, du kannst aus der Formatzeile den Code-Button nutzen, sieht dann so aus

    Code
    1. Konto-X
    2. -> Ordner
    3. -> UOrdner1
    4. ->eMail1
    5. ->eMail2
    6. -> UOrdner2

    oder halt tricksen, dann sieht es so aus:
    Konto-X
    ...-> Ordner
    ......-> UOrdner1
    ............->eMail1
    ............->eMail2
    ......-> UOrdner2


    Geh mal auf zitieren und schau dir das getrickste an ;)

  • Ja, wundert mich halt, dass da beim verscheiben was schief gegangen sein sollte, weil nachdem ich bemerkt hab, dass er den Ornder nur kopiert hat, hab ich nochmal bei beiden nachgeschaut, es waren die Mails in beiden drin.
    Dann hab ich den ursprünglichen gelöscht, und in dem neuen war trotzdem noch alles da.


    Hat da TB vielleicht mehr oder weniger ne Verknüpfung erstellt anstatt zu kopieren?
    Kann sich irgendwer erklären was da passiert sein könnte?


    Vielen Dank übrigens für die erklärung mit dem "code"-Tag. Ich werd das oben gleich mal einbauen. (hätt ich ja auch mal selbst drauf kommen können, is ja nich so als wäre mir BBCode komplett unbekannt)
    btw: der Trick is cool ;) aber ich werds dann wohl doch lieber sauber machen

  • Hallo und guten Morgen Daniel,


    wobei, na ja, da fängt mein Morgen ja gut an, lese ich doch da

    Zitat


    btw: der Trick is cool ;) aber ich werds dann wohl doch lieber sauber machen


    raus, ich würde mit schmutzigen Tricks arbeiten :pale: :redface: ;)