Thunderbird startet langsam und about:config [erledigt]

  • Hallo,


    ich nutze den TB 2.0.0.16. auf XP und habe ein paar Fragen warum mein Profile so langsam geladen wird und was das für komische, alte Einträge in der about:config sind.


    Beschreibung
    Habe in meinem Profile 2 IMAP-Konten eingebunden. Eines davon war zuvor ein POP-Konto.
    Hatte das Profile zuerst lokal und hab es dann ein paar Wochen auf einem NAS im Netzwerk gelegt.
    Klar hat da der Start ein paar Sekunden gedauert.


    Jetzt habe ich das Profile wieder lokal auf den PC geholt und dennoch dauert das erstmalige Laden ungewöhnlich lange (teil über 10 Sekunden).


    Hab mir dann erstmals die about:config angeschaut (Extras/Einstellungen...) weil ich da Altlasten vermutete.
    Dabei sind mir mail.server.serverX.directory Einträge aufgefallen, die auf Pfade zeigen die es gar nicht gibt.
    z.B.
    H:\'meinname'\thunderbird_profile_guen\5e4sg5fy.default\Mail\Local Folders (H: ist ein CD-Laufwerk)
    C:\WIN98\Anwendungsdaten\Thunderbird\Profiles\5e4sg5fy.default\News\host-news.franken.de (ich nutze XP und es gibt keinen Win98-Ordner).


    mail.server4.... und mail.server6.... Einträge stimmen.
    Sehen etwa so aus:
    D:\Mail\thunderbird_profile\5e4sg5fy.default\ImapMail\imap.strato.de (für das Strato-Konto)


    Kann ich diese offensichtlich alten(?) Einträge einfach löschen?


    Danke

  • Hallo Blackman,


    mache doch eine Profil-Kopie und danach lösche die Einträge raus.

    Zitat


    Habe in meinem Profile 2 IMAP-Konten eingebunden. Eines davon war zuvor ein POP-Konto.

    hast du das "umgestrickt" oder hast du ein neues Konto angelegt und das alte POP gelöscht.
    Umstricken gibt meist Probleme.

  • Hallo Rum,


    ups.
    Habe eine Kopie des Profiles erstellt und wollte die Einträge löschen - geht nicht.
    Ich kann die Einträge nicht löschen. Nicht mit der "Entf"-Taste. Und einen Löschbutton gibts nicht (auch nicht im Kontextmenü).


    Bei der Änderung des Kontos von POP auf IMAP musste ich sogar ein neues Konto anlegen. Soweit ich gesehen habe, kann man kein vorhandenes Konto von Typ umstellen.
    Ich hab jetzt noch gesehen das ich 2 (uralte) Newskonten habe. Da hol ich halt nie was ab.
    In den Kontoeinstellungen (Extras / Konto) sehen die aber korrekt aus. Der Speicherort ist auch da wo ich ihn erwarte.
    Ich hab mal eins davon gelöscht. Es sind aber genausoviele mail.server.server-Einträge vorhanden als davor (nach TB-Neustart).


    Danke

  • HAllo und guten Morgen Blackman,


    du musst die prefs.js bei beendetem TB mit einem Editor öffnen und bearbeiten.

    Zitat


    Bei der Änderung des Kontos von POP auf IMAP musste ich sogar ein neues Konto anlegen. Soweit ich gesehen habe, kann man kein vorhandenes Konto von Typ umstellen.

    darum fragte ich nach "umstricken". Man kann die prefs.js "verbiegen", aber das führt schnell zu völlig unklaren Fehlern, deshalb ist es auch in deinem Fall eigentlich sinnvoller, mit einem neuen Profil für klare Verhältnisse zu sorgen.
    In deiner prefs.js stehen scheinbar mail.server.server Einträge aus den alten Konten drin, die auf Grund der Pfadangaben zu Verzögerungen führen, da versucht wird auf Netzwerklaufwerke zuzugreifen. Entfernst du nun alle mail.server.serverX für nicht mehr vorhandene X Einträge, kann das, muss aber nicht die Abhilfe bringen. Ist sie es nicht, die alte prefs.js wieder aktivieren und dann halt ein neues Profil mit dem Profilmanager erstellen.

  • Hallo rum.


    als ich die prefs.js bearbeiten wollte, ist mir aufgefallen das ich parallel zum Profileordner noch einige Dateien die Eigentlich in den Profileordner gehören da rumstehen hatte. Vermutlich durch ganz frühe Versuche von Profileverschiebungen.
    Dabei war eine weitere prefs.js.
    Diese alten Dateinen hab ich mal gelöscht.
    Die richtige prefs.js hat keine ungewöhnlichen Einträge zu falschen Links.
    hmm. und jetzt startet das Profile wieder schnell. Muss ich zwar noch mal nach Reboot bzw. längerer Wartezeit erneut probieren, aber scheinbar waren diese Dateien für die Verzögerung zuständig.
    Über Extras / Einstellungen / about:config sind die erwähnten falschen Links auch nicht mehr vorhanden.
    Scheinbar habe ich durch die überflüssigen prefs.js TB etwas irritiert. Sollte aber auch nicht sein.


    Alles klar.
    Danke rum für die Hilfe!

  • Hi, guten Tag blackman,


    na, dann ist das wohl die eleganteste Lösung.
    Danke für dein Feedback!


    PS: Schön wäre es, wenn du als Threadersteller in deinem ersten Beitrag per Ändern-Button (oben rechts am Beitrag) dem Titel ein "[gelöst]" oder "[erledigt]" anfügst, denn dann wissen Forensucher dass es für dieses Frage eine Lösung gab