Darstellung der Umlaute und des "ß"

  • Ich verwende TB in Version 2.0.0.19, mein Betriebssystem = Win XP Home SP3


    Auf die Gefahr hin, dass das Problem schon besprochen ist ( :flehan: :flehan: ich konnte aber trotz ca. zweistündigem schmökern im Forum keine passende Antwort finden?? :nixweiss: ) hier mein Problem:


    Bei einigen mails, die ich erhalte sind die Umlaute durch alle möglichen kryptische Zeichen ersetzt, so dass sie zum Teil kaum noch lesbar sind. z.B.:


    "> Bite teilen Sie mir die Handelspartner mit, die den im600 verl�ᅵ�Ō��ᅵ�€sslich in
    > neuer Version liefern k�ᅵ�Ō��š�Ō�nnen: Internet und ggf. Gesch�ᅵ�Ō��ᅵ�€fte vor Ort!! "


    Leider weiß ich nicht mehr wann das Problem zum ersten mal auftrat. Es scheint aber damit zu tun zu haben , dass die Empfänger / Versender irgendwie im Ausland sitzen. Es gibt auch mails da wird der Umlaut im Betreff falsch, im Text dann aber richtig dargestellt ...


    Es wäre schön, wenn ich erfahren könnte woran das liegt und wie das Problem behoben werden kann!


    MfG Michael

  • Hallo und willkommen im Forum!
    Kann nicht immer vermieden werden. Wenn deine Einstellungen für das automatische Erkennen des richtigen Zeichensatzes richtig sind, hat der Absender den schwarzen Peter. Entweder sind die Mails falsch deklariert (meistens der Fall) und/oder es werden exotische (alte)Zeichensätze verwendet.
    Dabei können auch veraltete Server eine Rolle mitspielen und alte Tastaturen..
    Überprüfe bei dir:
    Unter Extras, Einstellungen, Ansicht, Formatierung, Schriftarten und Kodierung wird kein Haken gesetzt bei den unteren beiden Kästchen.
    "Nachrichten erlauben andere Schriftarten zu erlauben", sollte angehakt sein.
    Außerdem sollte im Hauptfenster unter Ansicht, Zeichenkodierung, "Automatisch bestimmen" auf "universell" stehen.
    Ist das alles richtig eingestellt, kannst du versuchen - falls die Deklaration falsch ist - diese temporär zu korrigieren, unter Ansicht, Zeichenkodierung.
    Oft reicht das Umstellen auf UTF-8 oder auf ISO-8955-1 bzw-15.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb


    Danke für die Auskunft! Habe alles was du angeben hast eingestellt. Hat leider nicht zum erwünschten Erfolg geführt. Habe dann auf dem Hauptfenster unter Ansicht usw. die fünf angebotenen Optionen probiert; das Aussehen war jedesmal anders aber immer sehr verworren! Siehe z.B. die automatische mail vom Forum:


    "Guten Tag Saurier,


    Sie erhalten diese Benachrichtigung, weil Sie das Thema �Darstellung der
    Umlaute und des "�"� auf �Thunderbird Mail DE� beobachten. Seit Ihrem
    letzten Besuch wurde zu diesem Thema eine neue Antwort erstellt. Sie können
    den folgenden Link benutzen, ....... "


    MfG Michael

  • Hallo,
    poste mal bitte die Deklarierung dieser Mails und ,mache privates unkenntlich.
    Mich interessieren nur diese Einträge:


    Content-Type: text/plain; charset=ISO-8859-15
    Content-Transfer-Encoding: 7bit


    Diese können mehrfach vorhanden und anders lauten.


    Kopiere sie aus dem Quelltext (strg+U) und kontrolliere dort gleich auch, ob dort die Darstellung des Nachrichtentextes korrekt ist.
    Ist das nicht der Fall, kann TB es auch nicht anders Darstellen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • hallo mrb!


    Hier die gewünschten Infos, wenn ich es richtig gemacht habe. :gruebel: :


    letzt mail vom Forum:



    Message-ID: <48e680c9615a2347bdc21bdfabe8475e@http://www.thunderbird-mail.de>
    Date: Thu, 12 Feb 2009 22:37:51 +0100
    Content-Type: text/plain; charset=UTF-8
    Content-Transfer-Encoding: 8bit


    Guten Tag Saurier,


    Sie erhalten diese Benachrichtigung, weil Sie das Thema „Darstellung der
    Umlaute und des "ß"“ auf „Thunderbird Mail DE“ beobachten. Seit Ihrem" ... usw.


    Hier im Text stimmt übrigens die Darstellung ?????


    Hier noch die Angaben einer anderen, älteren mail:


    In-Reply-To: <49776561.000002.20358@utilsc01.int.rightnowtech.com>
    Content-Type: text/plain; charset=UTF-8; format=flowed
    Content-Transfer-Encoding: quoted-printable


    Altec Lansing Support schrieb:" usw.


    Im Voraus herzlichen Dank, Michael

    Einmal editiert, zuletzt von Saurier ()

  • Hallo,
    bei der Mail mit der Deklarierung:
    Content-Type: text/plain; charset=UTF-8
    Content-Transfer-Encoding: 8bit


    wenn du diese markierst und unter Ansicht Zeichenkodierung schaust, welcher Zeichensatz ist dort eingestellt?
    Ich hatte noch eine Einstellung übersehen, die andere gemachte überschreiben kann.
    Kontrolliere im Kontextmenü der betr. Ordner, Eigenschaften, ob dort unter Allgemein ein gesetzt ist.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb!


    ich war heute leider den ganzen Tag nicht online.


    Hier noch mal alle Angaben zu einer verunstalteten mail:


    Ansicht:
    > bitten um Ihr Verst���¤ndnis.
    > Wir w���nschen Ihnen ein frohes neues Jahr.


    Content-Type: text/plain; charset=UTF-8; format=flowed
    Content-Transfer-Encoding: quoted-printa


    Die Textdarstellung ist auch anders:
    > > Leider ist unser Kundenservice bis zum 5. Januar geschlossen, alle
    > > Nachrichten k=C3=84=EF=BF=BD=C4=B9=EF=BF=BDnnen erst ab diesem Zeitp=
    unkt bearbeitet werden. Wir
    > > bitten um Ihr Verst=C3=84=EF=BF=BD=C3=82=C2=A4ndnis.
    > > Wir w=C3=84=EF=BF=BD=C4=B9=C5=9Fnschen Ihnen ein frohes neues Jahr.


    Unter Ansicht, Zeichencodierung ist angegeben: unicode(UTF-8)
    Im Kontextmenü des zugehörigen Ordners steht:
    Standarzeichenkodierung = unicode(UTF-8); und es ist kein Häkchen im folgenden Optionenfeld!


    PS: Es handelt sich hier um eine mail, die mehrmals mit Zitat hin und her ging!??


    Übrigens: bei der Benachrichtigungsmail vom Forum (s.u.)ist die Darstellung nach der Umstellung inzwischen in Ordnung!! :D


    Wenn ich das jetzt richtig verstanden habe, dann waren meine Einstellungen nicht optimal. Ich fasse zusammen ( vielleicht hilft das auch anderen Lesern weiter):
    Unter Extras, Einstellungen, Ansicht, Formatierung, Schriftarten und Kodierung wird kein Haken gesetzt bei den unteren beiden Kästchen.
    "Nachrichten erlauben, andere Schriftarten zu erlauben", sollte angehakt sein.
    Außerdem sollte im Hauptfenster unter Ansicht, Zeichenkodierung, "Automatisch bestimmen" auf "universell" stehen.
    Im Kontextmenü des betr. Ordners einer mail sollte unter: Eigenschaften / Allgemein, am besten unicode(UTF-8) ausgewählt sein und kein Häkchen im folgenden Feld "Standard .... zuweisen"!
    Wenn dann doch eine mail falsch dargestellt wird, sollte man im Hauptfenster unter Ansicht, Zeichenkodierung ausprobieren welcher Code am besten darstellt ( geeignet = westlich ISO8859-15 oder mitteleuropäisch ISO8859-2)


    Stimmt das so? :gruebel: Bitte kontrollieren!!??


    Ich habe jetzt noch mal einige meiner gespeicherten Mails durchgesehen, bis auf oben zitierte mail werden jetzt alle, die ich angesehen habe korrekt dargestellt!! :D


    Gruß Michael :hallo:

  • Hallo,

    Zitat

    Im Kontextmenü des betr. Ordners einer mail sollte unter: Eigenschaften / Allgemein, am besten unicode(UTF-8) ausgewählt sein und kein Häkchen im folgenden Feld "Standard .... zuweisen"!


    Nein, so weit ich es sehe, hat die Einstellung dort keine Auswirkung, solange der Haken nicht gesetzt wurde.Vermutlich tritt sie dann ein, wenn die Mail überhaupt keine Deklarierung hat.
    Wenn im Quelltext so etwas steht:
    "Nachrichten k=C3=84=EF=BF=BD=C4=B9=EF=BF=BDnnen e"
    und quoted printable kodiert wurde, müsste es im Nachrichtentext OK sein.

    Zitat

    Unter Ansicht, Zeichencodierung ist angegeben: unicode(UTF-8)


    Dann entspricht die Deklarierung der Anzeige, ist OK.

    Zitat

    Wenn dann doch eine mail falsch dargestellt wird, sollte man im Hauptfenster unter Ansicht, Zeichenkodierung ausprobieren welcher Code am besten darstellt ( geeignet = westlich ISO8859-15 oder mitteleuropäisch ISO8859-2)


    Ja, das wirkt sich aber nur temporär aus und springt bei anderen Mails wieder um auf den in der Mail deklarierten Zeichensatz.
    Berücksichtige bitte auch, dass mal ein Server Mist bauen kann. Das Problem in der Benachrichtungsmail ist sicher ein solcher Fehler.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb


    Ich bin an dieser Stelle zufrieden. Für weiter informationen,Tipps zum Thema würde ich mich freuen! :)


    Für Deine ausführlichen, hilfreichen Informationen den allerherzlichsten Dank! :zustimm: :top:


    Herzlichen Gruß Michael