[Bug?] Attachment per Kommando Zeile /Umlaute

  • Ich denke ich haben einen Bug entdeckt.


    Und zwar habe ich ein Skirpt geschrieben das per Kommando Zeile Attachments an eine neue Mail einfügen kann. Das Anhängen funktioniert immer. Beim Senden erscheint aber eine Fehlermeldung wenn im Dateinamen der Datei/en ein Umlaut vorkommt. Die Meldung lautet:

    Zitat

    Temporäre Datei konnte nicht geöffnet werden. Überprüfen sie ihre Einstellungen für " temporärer Ordner"


    Wenn ich auf dem normalen Weg eine Datei mit Umlaut anhänge, dann funktioniert das Senden. Habt ihr ne Idee?

  • Hallo,


    du hattest ja auch schon ein anderes Problem mit Parameterübergabe, wo - meine ich - auch schon leider keiner was wusste.


    Ich habe den Eindruck, als versuchtest du auf einer Webseite ein mailto mit umfassenden Angaben und angehängten Dateien zu produzieren. Nur für Thunderbird oder für alle E-Mail-Clienten?


    Einzige Idee, die ich habe: Bist du sicher, dass das der geeignete Weg ist? Ist nicht ein serverseitiges Absenden über die Webseite selbst als Formular besser?

  • Hi.
    ja genau der bin ich^^. http://www.thunderbird-mail.de…iewtopic.php?f=32&t=39609


    Der Hintergrund sieht so aus: man surft und findet nen interessanten Link den man an seine Freunde schicken möcht. Dazu muss man den Link kopieren, Mail Programm öffnen, auf Verfassen klicken, Link wieder einfügen- viel unnötiges Geklicke. Es geht aber auch einfacher: ich markiere den Link oder Text mit der Maus, tippe dann in http://www.launchy.net/ "email" ein und schon wird ne email verfasst. Genauso mit Attachments. Dateien im Explorer markieren, Launchy -> "email" und zack hängen die Dateien an der Mail.


    Dabei gibt es eben zwei Probleme:
    a) Texte grösser 887 Zeichen werden einfach abgeschnitten
    b) Attachments mit Umlauten können zwar angehängt werden, aber NICHT versendet werden.


    Gibt es nicht irgendwie ein Entwicklerforum oder so? Das sind ja nicht unbedingt oft vorkommende Probleme die ich habe.

  • "Jpeg" schrieb:

    Der Hintergrund sieht so aus: man surft und findet nen interessanten Link den man an seine Freunde schicken möcht. Dazu muss man den Link kopieren, Mail Programm öffnen, auf Verfassen klicken, Link wieder einfügen- viel unnötiges Geklicke.


    Ich kenne ja deinen Brwowser nicht, aber


    - in Firefox nehme ich dann im Menü Datei > Link senden ...
    - im Internet Explorer: Seite > Link über Email senden ...

  • Jep, Firefox. Hehe kannte ich noch gar nicht. Ist mir aber nicht universell genug. Kann ausserdem keinen Text senden und auch nicht aus Word etc und hilft mir jetzt auch nicht bei meinem Problem.

  • Danke für die Links. Du hast jedoch den Link zu meiner Problemlösung vergessen ;) . Mir wärs am liebsten wenn ich das Problem lösen könnten, anstatt es zu umgehen.


    Zitat

    Aus Word selbst heraus sollte man sowieso nicht e-mailen.


    Wieso das denn nicht?

  • "Jpeg" schrieb:

    Danke für die Links. Du hast jedoch den Link zu meiner Problemlösung vergessen ;) . Mir wärs am liebsten wenn ich das Problem lösen könnten, anstatt es zu umgehen.


    Tja, ich schrieb ja oben schon, dass da anscheinend keiner was weiß. Du hast statistisch gesehen einen recht ungewöhnlichen Wunsch ;)