Profil will nicht auf dem Mac v. USB laden, v. HD geht [erl]

  • Moin,


    folgende Ausgangslage: Es ist ein PC-Notebook mit ein paar GB Mails unter Outlook vorhanden. Außerdem ein Macbook mit Entourage, wo aber außer ein paar versehentlich abgeholten noch keine Mails drin sind. Beide sollen auf denselben Datenbestand zugreifen können, und das auch in der Pampa, wenn kein Netz vorhanden ist, daher scheidet IMAP schonmal aus.
    Vorarbeit: Outlook-Ordner erstmal von über 3 auf unter 2 GB gebracht.


    Meine Idee war, die Daten auf dem PC in einen Thunderbird Portable auf USB-Stick zu importieren, was auch (anscheinend) vollständig geklappt hat, und diesen Stick dann bei Bedarf an den Mac umzustecken und per ebenso frisch installiertem MacOS-Thunderbird auf das Profil zuzugreifen. Die profiles.ini ist entsprechend angepaßt (relativer Pfad abgeschaltet, Profilpfad auf /Volumes/Stickname/ThunderbirdPortable/Data/profile gesetzt).


    Problem: Der Thunderbird-Prozeß startet, wächst in wenigen Sekunden auf 3507MB virtuelle Speicherbelegung an und verreckt dann nach ein paar Dutzend malloc-Fehlern gerade wenn das Fenster aufgeht und noch bevor da irgendwas drinsteht.


    Der größte Ordner im Thunderbird-Profil hat 1,1 GB und stammt aus dem Archivordner von Outlook. Die Indexdatei dazu, vom Thunderbird Portable interessanterweise erst im zweiten Durchgang geschrieben, ist 2,8MB groß. An Erweiterungen sind LookOut und die deutsche Wortliste drin.
    Versucht der MacOS-Thunderbird irgendso was komisches wie alle Maildateien gleichzeitig zu mmap()en oder so?


    Ich habe auch schon versucht, den Thunderbird Portable via Darwine laufen zu lassen, aber leider zeigt der wine-helper da ein komisches Verhalten: In dessen Konsolenfenster tauchen etliche Meckermeldungen auf, dann hängt wine-helper, aber sobald man wine-helper per "Sofort beenden..." umbringt, geht das Thunderbird-Fenster auf, und soweit ich das sehen kann funktioniert dann alles ... aber das kann man einem Endbenutzer ja so nicht zumuten.


    Irgendjemand eine Idee?



    Edith:
    Kopiere ich den Profilordner auf die Mac-Festplatte, ohne sonst irgendwas zu ändern, außer dem Anfügen an die profiles.ini natürlich, funktioniert das Profil problemlos ohne irgendwelche Fehler :wall: Aber bei jedem Rechnerwechsel 3,4GB vom bzw. auf den Stick zu kopieren ist nun wirklich nicht drin.


    Jetzt ist natürlich die Frage, ist das ein Bug in Thunderbird oder in MacOS X?
    Hat Apple da im VFAT-Code bzw. in der Implementation von mmap() was verbockt?
    Oder ist das Handling von nicht-relativen Profilen in Thunderbird kaputt?
    Ich tippe eher auf ersteres, den Profilpfad per Softlink auf den Stick umzubiegen führt nämlich zu genau dem gleichen Fehler.


    Der auftretende Fehler scheint google zufolge auch in anderen obskuren Zusammenhängen vorzukommen:


    thunderbird-bin(4957,0xa0651080) malloc: *** mmap(size=16777216) failed (error code=12)
    *** error: can't allocate region
    *** set a breakpoint in malloc_error_break to debug
    und das etliche Male hintereinander, bis er dann endgültig rausfliegt mit
    what(): St9bad_alloc
    und der OSX-CrashReport aufgeht.

    :help: :?:

  • Moin,


    war offensichtlich ein MacOS X-Fehler, Update auf 10.5.6 und was sonst noch so neues da war hat nämlich geholfen.