Fehler bei Deaktivierung des Adressbook Synchronizer [erl.]

  • Habe seit heute ein äußerst rätselhaftes Problem mit dem TB-Addon Addressbook-Synchronizer, welches ich bisher eigentlich gar nicht genutzt habe, das aber leider plötzlich zu Fehlfunktionen bei TB führt.


    *****************************************************************************************************


    Die Beschreibung des Fehlers ist genauso einfach wie mysteriös:


    In dem Moment, wo ich das Add-On Addressbook Synchronizer deaktiviere oder deinstalliere, werden beim nächsten Start von TB meine Mails einfach nicht mehr angezeigt.


    Aktiviere bzw. installiere ich das Add-On wieder, so erscheinen die Mails wie eh und je.


    *****************************************************************************************************


    Dass die eigentliche Ursache des Problems möglicherweise ganz woanders liegen könnte, ist mir natürlich auch klar - schließlich gibt es oberflächlich gesehen keinerlei plausiblen Zusammenhang zwischen diesem Addon und der Sichtbarkeit der Mails.


    Ich habe vor dem ersten Auftreten ziemlich viel herumgebastelt und dabei verschiedene andere Fehler ausgelöst und wieder beseitigt. Da die Vorgeschichte evtl. zur Lösung beitragen könnte, hier ein paar zusätzliche Hintergrundinformationen:


    Ursprünglich hatte ich versucht, den Speicherort des TB-Ordners zu ändern, indem ich mithlife des Profilmanagers ein neues Profil erstellte. Daraufhin trat beim Starten des Programms die Fehlermeldung "Thunderbird wird bereits ausgeführt, reagiert aber nicht..." auf, die auch in diversen Artikeln dieses Forums diskutiert wird (unter anderem hier: http://www.thunderbird-mail.de…php?f=26&t=22342&start=15).


    Da keiner dieser Artikel eine Lösung für mein Problem enthielt (Der Profil-Pfad war richtig in der Datei profiles.ini eingetragen, die Mailverzeichnisse und -dateien waren nach wie vor im TB-Profilverzeichnis vorhanden, die Datei parent.lock wurde regelmäßig beim Beenden des Programms gelöscht, und auch sonst traf keine der vorgeschlagenen Fehlerbeschreibungen zu), experimentierte ich selber herum.


    Verschwunden ist das Problem mit der Fehlermeldung schließlich, als ich den ersten Eintrag in der Datei profiles.ini löschte, der festlegt, dass beim Programmstart automatisch das letzte Profil geladen wird. Offensichtlich ist der Eintrag ohnehin völlig überflüssig, denn bei einem Neustart wird er automatisch wieder in die Datei geschrieben, wie ich danach festgestellt habe. Trotzdem war das Problem mit der Fehlermeldung daraufhin beseitigt, TB ließ sich zumindest wieder starten. Ob das nun ein Zufall war, kann ich nicht sagen.


    Anstelle der Fehlermeldung trat nun der oben beschriebene Fehler auf - nämlich das Verschwinden der Mails in der Programmoberfläche. Es hat mich noch zwei weitere Stunden des Herumprobierens gekostet, bis ich auf die absurde "Lösung" kam, dass ich einfach nur den 'Synchronizer' aktivieren muss, um die Mails wieder zu sehen.


    Somit kann ich jetzt zwar mein TB wieder uneingeschränkt nutzen, aber das ist natürlich keine wirklich zufriedenstellende Lösung, da ich das Add-On eigentlich gar nicht nutze und es deswegen nicht unbedingt aktivert lassen möchte bzw. es am liebsten ganz deinstallieren würde (Es verdient ohnehin nicht den Namen "Synchronizer", da es nicht wirklich synchronisiert, aber das steht auf einem anderen Blatt... ^^).


    Langer Rede kurzer Sinn, ich würde gerne wissen, was es mit dieser mysterösen Koinzidenz von Aktivierung eines Add-Ons und Sichtbarkeit der Mails auf sich hat. Vielleicht kann mir da jemand mit etwas mehr Erfahrung weiterhelfen.


    *****************************************************************************************************


    Version :  
    Thunderbird 2.0.0.19 (2008120920)


    Betriebssystem: 
    XP, SP2 (WINNT x86-msvc)


    Sonstige Add-Ons:
    - AccountEx [de] 0.2.3
    (deaktiviert)
    - Addressbooks Synchronizer 0.8.3
    - addressContext 0.8.1
    - Any key 1.6.3
    (deaktiviert)
    - Auto Zip Attachments 0.6.2
    - Birthday Reminder 1.0.4.2
    (deaktiviert)
    - ContactClean 1.0.1
    - Contacts Sidebar 0.7.1
    - Delete Junk Context Menu 0.3.2.1
    - Duplicate Contact Manager 0.6
    - Equations 1.2
    - Extension List Dumper 1.14.1
    - ImportExportTools (Mboximport enhanced) [de] 2.1.2
    - Lightning 0.9
    (deaktiviert)
    - Linky 2.7.1
    (deaktiviert)
    - LookOut 1.2.3
    - Password Exporter 1.1
    (deaktiviert)
    - Quote Colors 0.2.8
    - Remove Duplicate Messages (Alternate) 0.3.1
    - Restart Thunderbird 0.9.1
    - SyncMab 3.1
    (deaktiviert)
    - Talkback 2.0.0.9
    - Thunderbird Message Filter Import/Export 1.3.7.3
    (deaktiviert)
    - Toolbar Buttons 0.6.0.4
    - URL Link 2.02.3
    - Xpunge 0.3
    (deaktiviert)


    *****************************************************************************************************

  • Hallo, schon komisch.


    Ideen:


    - IMAP oder POP-Konto
    - Wie hast du Addressbook Synchronizer eingestellt? FTP? IMAP?
    - Mal in einem neuen Profil testen mit der einzigen Erweiterung "Addressbook Synchronizer"?
    - Schon versucht, die Erweiterung zu deinstallieren anstatt zu deaktivieren? (Danach auch alle zugehörigen Zeilen in der "prefs.js" mal löschen) - Achtung, vorher Sicherheitskopie der Datei machzen!
    - Der Autor der Erweiterung ist deutschsprachig. Vielleicht mal anschreiben?


    HInweis: Du hast eine Reihe von Erweiterungen, teils deaktiviert. Es ist nicht auszuschließen, dass sich da was in die Quere kommt, z.B. SyncMab und AddressBook Synchronizer..

  • Danke erstmal für die Vorschläge.
    Hatte bisher noch keine Zeit, weiter zu probieren, aber erstmal die Antworten auf deine Rückfragen:


    Zitat

    IMAP oder POP-Konto


    POP.
    Einen Imap-Dienst hatte ich vor längerer Zeit mal für ein GMail-Konto in Anspruch genommen, aber schon lange wieder gelöscht (ohne weitere Probleme danach).


    Zitat

    Wie hast du Addressbook Synchronizer eingestellt? FTP? IMAP?


    Im AS sind alle Häkchen entfernt, inklusive IMAP-Reiter. Die übrigen Einstellungen sind Default - kein Adressbuch angegeben etc.


    Zitat

    Schon versucht, die Erweiterung zu deinstallieren anstatt zu deaktivieren?


    Ja, hat wie gesagt den selben Effekt wie die Deaktivierung


    Zitat

    Du hast eine Reihe von Erweiterungen, teils deaktiviert. Es ist nicht auszuschließen, dass sich da was in die Quere kommt, z.B. SyncMab und AddressBook Synchronizer..


    Da habe ich schon so ziemlich alle Kombinationen (Aktivierung /Deaktivierung) ausprobiert


    Der Tipp mit der "prefs.js" klingt für mich am ehesten plausibel. Werde ich nach dem Mittagessen probieren ;)

  • So, habe jetzt doch erstmal die Finger von der prefs.js gelassen, und stattdessen nocheinmal mit den übrigen Add-Ons experimentiert.


    Irgendwann bin ich darauf gestoßen, dass der Fehler ebenfalls verschwindet, wenn ich den Duplicate Contact Manager entferne bzw. deaktiviere. Anscheinend gab es da sowas wie eine Inkompatibilität zwischen DCM und Addressbook Synchronizer (?). Erstaunlich allerdings, dass diese Inkompatibilität bei Deaktivierung, und nicht bei Aktivierung des AS auftritt (falls diese Erklärung überhaupt zutrifft)


    Da ich nicht auf den äußerst nützlichen DCM verzichten wollte, habe ich letzten Endes einfach alle Add-Ons noch einmal deinstalliert, neu heruntergeladen und neu installiert. Seitdem funktioniert auf wundersame Weise alles wieder einwandfrei :-)


    Wenn mich nicht alles täuscht, verwendet der DCM jetzt eine andere ID als bei der ursprünglichen Installation, und er erzeugt dementsprechend ein andersnamiges Verzeichnis im extensions-Folder und einen anderen Eintrag in der profiles.ini. Offensichtlich ist dieses Add-On also überarbeitet worden. Komisch daran ist, dass das nicht bei den automatischen Updates korrigiert wurde.


    Wie dem auch sei, zumindest funktioniert mit Profil jetzt wieder alles wie gewünscht.
    Nochmals danke für die Lösungshinweise ;)