Inbox e-Mails weg

  • Hallo zusammen,


    ich bin verzweifelt: Ich nutze Thunderbird (Version 2.0.0.21) mit einem IMAP-Postfach (bei strato). Hat bisher alles geklappt. Vor einigen Tagen aber war mein Posteingang komplett leer - auch nix im Papierkorb - einfach alles weg.


    Starto hat so eine Funktion, dass alle e-Mails älter als 60 Tage automatisch gelöscht werden. Ich hatte vergessen diese Funktion abzuschalten, aber das betrifft doch einzelne Mails die aufgrund der Starto-Frist überfällig sind , oder? Das kann doch nicht der Grund sein.


    In diversen Foren habe ich schon gelesen dass - solange die Ordner von Thunderbid nicht komprimiert wurden - alles reperabel ist. Ich habe die Anleitung zum Wiederherstellen unter http://www.pctipp.ch/praxishil…ail_wiederherstellen.html angewendet.
    Das Problem: In der Datei "Inbox" steht die Zeile "X-Mozilla-Status" bereits auf 0001. Obwohl die Inbox-Datei über 70 MB gross ist wird mir aber immernoch keine einzige alte Mail angezeigt.


    Interessant auch: Mein Thunderbrid/Profil/xy/IMAP-Mail - Ordner enthält zwei Verzeichnisse. Einmal "imap.strato.de" und einmal "imap.strato-1.de".


    Kann mir da geholfen werden? Danke!!

  • Hallo soundslikefish,


    "soundslikefish" schrieb:

    Das Problem: In der Datei "Inbox" steht die Zeile "X-Mozilla-Status" bereits auf 0001. Obwohl die Inbox-Datei über 70 MB gross ist wird mir aber immernoch keine einzige alte Mail angezeigt.


    die Index-Datei hast du auch schon gelöscht? Wenn ja, kopiere die Maildatei (die ohne Endung) zunächst einmal an einen sicheren Ort und komprimiere dann mal den Posteingang (rechte Maustaste). Bleiben die alten Mails auch nach der Komprimierung in der Maildatei (mit Editor prüfen)?


    Am besten du sicherst vor allen Maßnahmen das gesamte Profilverzeichnis (wenn nicht schon geschehen)



    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Guten Morgen!


    Vielleicht irre ich mich ja. Aber mir ist so, als müsste der Mozillastatus auf 0000 stehen, damit ich die Mails wieder importieren kann, ich hab sowas mal gemacht auf Anraten unseres großen Feuerwasserhäuptlings, und hatte damals wunderbar geklappt, aber wenn mich meine 2 grauen Zellen nicht trüben, wars eben Mozillastatus 0000 und nich 0001, aber meinen Skalp wollte ich nicht drauf verwetten.

  • Hallo Rothaut,


    also 0001 kannst du auch nehmen... 0000 ist ungelesen, 0001 ist gelesen (0008 ist dann ungelesen-gelöscht und 0009 ist dann gelesen und gelöscht nur der Vollständigkeit halber, wobei auch das nicht stimmt, es gibt noch eine ganze Reihe anderer Tags...)


    wichtig dabei ist aber auch das man den Index nach einer solchen Aktion noch einmal löscht - am besten offline, also durch löschen der msf-Datei.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Hallo Toolman!


    Vielen Dank für diese Infos, ich konnte mich nur erinnern, dass es bei mir damals mit Rückstellen auf 0000 geklappt hatte. Die .msf hatte ich schon vorher in den Datenhimmel befördert.

  • Hallo Toolman,


    danke für deine Hilfe! Ja, die Index-Datei (namens "INBOX.msf) hatte ich auch gelöscht gehabt.


    Ich habe nun also wie von dir beschrieben den Posteingang mal komprimiert. In der dann geöffneten Inbox-Datei kann ich aus dem Hieroglyphen-Wirrwarr nicht viel erkennen (bin nur Laie). Aber die Datei ist jetzt nur noch 137 kB gross statt vorher 76 MB. Demnach scheint sie jetzt dem realen Posteingang-Stand zu entsprechen.


    Warum gibt es diese zwei Starto-Ordner "imap.strato.de" und einmal "imap.strato-1.de"? Beide waren vor dem Posteingang-Komprimieren ähnlich gross (ich hatte in beiden Ordnern die Index-Datei gelöscht). Seit dem Komprimieren aber sind in dem imap.strato.de- keine Inbox-Dateien mehr vorhanden.


    Besteht noch Hoffnung an die alten Mails zu kommen? Bitte bitte...

  • Hallo Toolman,


    you are the real Toolman, man! Es hat geklappt. SUPER!
    Zum Ausführen der Funktion IMPORT darf man allerdings keinen IMAP-Ordner ausgewählt haben: Dann kommt die Beschwerde dass Import in einen IMAP-Odner nicht geht.
    Statt dessen habe ich unter LOKAL ORDNER einen neuen Ordner angelegt, makiert, und dann IMPORT gewählt. Und tatsächlich sind die Mails wieder da. Das hätte ich nicht mehr für möglich gehalten.


    Eine Frage zum Schluss: Wie kann es sein dass die Mails alle weg waren? Sie galten ja anscheinend nicht als gelöscht (weil 0001), und meines Wissens habe ich bei Thunderbird "nicht ausversehen irgendwas geklickt". Gibt es dafür noch eine Erklärung?


    Tausend Dank.

  • Hallo soundslikefish ,


    danke für die Rückmeldung. Nun ja, ich habe das hier nachvollziehen können. Ich habe hier ein Konto das ich sowohl über IMAP als auch über POP3 abrufen kann. Unterwegs rufe ich nur per IMAP ab. Zu Hause - quasi als Archivierung, rufe ich das Konto dann mit POP3 ab und lösche die Nachrichten auf dem Server. Nach einem flüchtigen Blick in die mbox-Datei des IMAP-Kontos auf dem Laptop habe ich gesehen, das es dort noch Mails gibt, die sich zum einen nicht mehr auf dem Mailserver befinden und auch in Thunderbird in dem betreffenden Konto nicht mehr angezeigt wurden. Ich habe dann mit den üblichen Methoden versucht die Mails zum anzeigen zu bringen - ohne Erfolg. Die entsprechenden Tags (X-Mozilla-Status und X-Mozilla-Status2) habe ich dabei sowohl bearbeitet als auch einfach mal heraus gelöscht - ohne das das auch in Verbindung mit dem löschen der msf-Dateien (bzw. zusätzlichen cleanen - nicht löschen der zentralen msf-Dateien der zugeordneten IMAP-msf-Dateien oberhalb des eigentlichen Mailordners) irgendeinen Effekt hatte. Erst als ich den Ordner komprimierte, verschwanden diese längst anderweitig abgerufenen Mails. Ich vermute mal das der Status bei IMAP-Konten noch irgendwo anders (außerhalb des jeweiligen Mailkontainers) liegt.


    Es kann auch prinzipiell so sein, dass bei bestehender Verbindung zum Mailserver, nur die Mails angezeigt werden die auch (noch) auf dem Mailserver vorhanden sind.
    Das die Mails importiert werden konnten, ist ja ein weiteres Indiz dafür, das die Tags in Ordnung waren - ich habe leider einen letzten Test jetzt nicht gemacht - kopieren der Mbox-Datei unterhalb von local Folders und dann schauen ob die Mails in dem neuen Ordner dann angezeigt werden.


    Das Speichern in der Mbox-Datei soll ja auch nur dazu dienen, den Traffic zum Mailserver etwas zu reduzieren (offline-Lesen ist eine weitere Funktion). Daher meine Vermutung - die Mails, die jetzt weg waren wurden entweder von dir entweder anderweitig heruntergeladen/gelöscht (evtl. über anderen Zugangsweg wie Webzugang oder POP3-Abruf) oder der Mailprovider hat aufgrund von eigenen Policies die Mails gelöscht (z.B. alle Mails älter als 90 Tage werden gelöscht - habe schon so etwas gehört). Auch Störungen auf seitens des Mailproviders sind vorstellbar.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro