Keine Umlaute [erledigt]

  • Hallo zusammen,


    eine Kundin von mir hat das Problem, dass bei ihren eMails keine Umlaute angezeigt werden.


    Sie war so nett, mir diese eMail weiterzuleiten:


    Zitat

    Nachricht: Hallo, habe gestern Abend eine Bestellung aufgegeben, da ist
    mir ein kleiner Fehler unterlaufen.
    Ich habe für meinen Mann die *Zensiert* in "Wlidlife khaki"
    Gr.45 bestellt sollten aber die "schwarzen" in Gr 45 sein ist
    es möglich das sie das noch ändern können.


    Hat das problem etwas mit der Zeichenkodierung zu tun?


    Sie benutzt den Mozilla Thunderbird in der Version 2.0.0.21 unter Windows XP (SP3).


    Ich hoffe ihr könnt mir helfen, damit ich ihr helfen kann. ;D



    Danke und schönen Gruß


    err0r

  • Hallo,
    das hat auf jeden Fall mit der Zeichenkodierung (=Zeichensatz engl. charset) zu tun.
    Die Frage ist nur, bei wem da etwas schief läuft.
    Allerdings ist deine Beschreibung ungenau, da ich nicht einmal weiß, ob es ich um versendete oder empfangende Mails handelt.
    Ist eine Mail richtig deklariert, kann sie TB auch Automatisch korrekt darstellen, vorausgesetzt, TB ist richtig eingestellt.


    Unter Extras, Einstellungen, Ansicht, Formatierung, Schriftarten und Kodierung bei den unteren beiden Kästchen keinen Haken setzen .
    "Nachrichten erlauben andere Schriftarten zu erlauben",kann angehakt sein, bezieht sich aber nur auf HTML-Mails.
    Außerdem sollte im Hauptfenster unter Ansicht, Zeichenkodierung, "Automatisch bestimmen" auf "universell" stehen.
    Bitte alle beteiligten Ordner überprüfen, ob bei Rechtsklick auf diese, Eigenschaften, Allgemein, ein Haken gesetzt wurde oder ein anderer Zeichensatz steht, als unter Extras, Einstellungen, Lesen, Schriftarten und Zeichenkodierungen.


    Das kläre mal bitte ab.


    Es gibt aber Mails, die gar nicht oder falsch deklariert sind, dann kann TB nur noch raten und oft eben daneben.
    Steht in der Deklarierung (im Quelltext (strg+U))


    Content-Type: text/html; charset=ISO-8859-15
    Content-Transfer-Encoding: 8bit


    Dann stellt ihn TB mit dem Zeichensatz "Westlich" dar. Ist aber die Mail in UTF-8 geschrieben und angegeben ist Iso-8859, dann werde alle Umlaute und das "ß" falsch dargestellt, umgekehrt ebenfalls.
    Dann muss man versuchen, temporär unter Ansicht, Zeichenkodierung, manuell den richtigen zu finden.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    erstmal zur Beschreibung: Es handelt sich um eine empfangene eMail. Ich war heute beim lieben kunden und habe mir ein paar Screenshots gemacht.


    [IMG:http://www.bilder-space.de/thumb/25.08aGf98qUTS7qwIyA.JPG]


    Die zwei unteren Haken habe ich entfernt. Die Zeichenkodierungen waren schon so eingestellt. HTML ist bei Ihr ausgeschaltet.



    Der eine Ordner, wo sich die fehlerhaften eMails befinden, hat die gleichen Zeichenkodierungen wie unter den Einstellungen im Thunderbird.


    [IMG:http://www.bilder-space.de/thumb/25.08ol3dSWFBbCT3TSx.JPG]


    Wenn ich nun eine eMail zum lesen markiere und dann unter Ansicht-> Zeichenkodierung-> Automatisch bestimmen auf "Universell" klicke, geht die komplette Struktur verloren und es wird mir der gesamte Quelltext angezeigt. Dafür ist der oben beschriebene Text ohne Fehler!


    Dann noch zum Quelltext:

    Code
    1. Content-Type: text/plain; charset=ISO-8859-1; format=flowed
    2. Content-Transfer-Encoding: 7bit


    Ziemlich merkwürdig, besonders weil bei Universell der Text ohne Fehler angezeigt wird, aber mir dafür der Komplette Quelltext mit angezeigt wird.


    Fals ihr noch Informationen benötigt, meldet euch!


    Wünsche einen schönen Feierabend!

  • Hallo,

    Zitat

    Der eine Ordner, wo sich die fehlerhaften eMails befinden, hat die gleichen Zeichenkodierungen wie unter den Einstellungen im Thunderbird.


    Nein, genau der hat den Haken zu viel (bei der zweiten Abbildung) und es werden alle gemachten Einstellungen für diesen Ordner außer Kraft gesetzt. Steht doch dort: "Individuelle Zeichenkodierung und automatische Bestimmungen werden ignoriert".
    Es wird dann eben eine feste Zeichenkodierung genommen mit den daraus resultierenden Problemen.

    Zitat

    Wenn ich nun eine eMail zum lesen markiere und dann unter Ansicht-> Zeichenkodierung-> Automatisch bestimmen auf "Universell" klicke, geht die komplette Struktur verloren


    Tja, jetzt weiß TB gar nicht mehr, was es machen soll, offensichtlich wurde diese sich widersprechende Einstellung von den Programmierern nicht vorausgeahnt.
    Man sollte schon wissen, was man beim Haken setzten bewirkt. Der Haken dort steht nämlich by default nicht.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo zusammen,


    Entschuldigung für die lange Antwortzeit.


    Ich habe letzte Woche den Haken, in den Eigenschaften vom Ordner "Anfragen Internet" entfernt. Dann habe ich noch die Standard Kodierung auf Westlich (ISO-8859-15) gestellt.
    Unter Extras->Einstellungen->Ansicht->Schriftarten und Kodierung habe ich (wie im Bild) die unteren zwei Haken entfernt und die Aus- und Eingehende Standard Zeichenkodierung auf Westlich (ISO-8859-15) eingestellt. Bis jetzt kahmen keine beschwerden mehr. Auch nach dem letzten Telefonat mit der lieben Kundin, hatte Sie nichts erwähnt gehabt.


    Ich danke euch bis hierhin schon einmal! Ein dankeschön von der Kundin natürlich auch. ;)