HTML-Schriftart beim Empfänger bestimmen

  • Hallo,


    bin Neuling für TB (2.0.0.23 unter Vista) und natürlich auch im Forum. Und auch, wenn meine Frage an unterschiedlichen Stellen bereits in mehr oder weniger ähnlicher Form diskutiert wurde, konnte ich noch keine abschließende Antwort entdecken. Über Vor- und Nachteile von Rein-Text vs. HTML habe ich gelesen. Dennoch möchte ich gerne die Schriftart meiner Mails beim Empfänger bestimmen (und nicht nur in meiner Anzeige - das habe ich bereits mit Mail-Tweak gelöst). Ich habe alles (mir) mögliche versucht und dennoch bisher nur verstanden, dass bei TB der Empfänger entscheidet, wie die Mail dargestellt wird. Die Sinnhaftigkeit kann ich ein Stück weit nachvollziehen. Aber Outlook ermöglicht die Schriftart-Vorgabe in seinen Mails. Und genau das ist mein Ziel. Idealerweise in einer Form, wie das bei Websites üblich ist. Prüfe, ob Verdana vorhanden ist, wenn nicht Arial und wenn alles nicht geht nimm bspw. Courier. Und wenn jemand keine HTML Mails möchte, dann zeige eben Reintext an (wobei ich das "Rein-Text und HTML versenden" auch bereits gefunden habe). Geht das mit TB? Und zwar so, dass ich einen Standard definiere, der automatisch beim Erstellen einer Mail gezogen wird und ich nicht jedes mal die Einstellung neu aktivieren muss.


    Danke Euch schon mal!

  • Hallo und willkommen im Forum!

    Zitat

    Und zwar so, dass ich einen Standard definiere, der automatisch beim Erstellen einer Mail gezogen wird und ich nicht jedes mal die Einstellung neu aktivieren muss.


    Ja. Dafür gibt es Menüs unter Extras, Einstellungen, Verfassen, Allgemein.

    Zitat

    Idealerweise in einer Form, wie das bei Websites üblich ist. Prüfe, ob Verdana vorhanden ist, wenn nicht Arial und wenn alles nicht geht nimm bspw. Courier.


    Das wird nicht gehen.

    Zitat

    Dennoch möchte ich gerne die Schriftart meiner Mails beim Empfänger bestimmen


    Das geht schon:
    Unter Extras, Einstellungen, Ansicht, Formatierung, Schriftarten und Kodierung den Haken beim oberen Kästchen entfernen. Das Falldownmenü für HTML-Mails ist das für "feste Breite". (Das ist das gleiche Menü wie in MailTweak).


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke Dir mrb,


    funktioniert leider nur teilweise... Bisher ändert sich beim Wechsel in das Textfeld die Formatierung von <Normaler Text - feste Breite (Verdana)> auf <Normaler Text - Verdana (standard)>. Und das scheint nur die Anzeige unter TB zu betreffen, denn beim Testen kommt die versendete Mail auf Outlook in Times an. Allerdings hat auch bereits ein Test funktioniert (leider von mir bisher nicht bewußt reproduzierbar). Wenn ich aber das Absende-Konto ändere, ändert sich aber immer auch die Formatierung. Anders formuliert: die Formatierung bleibt z.T. so, wie ich sie will nur dann, wenn ich keines Falls das Konto ändere. Seltsam, oder? Hast Du eine Idee?


    Installierte Add-Ons sind:
    - Lightning
    - Mail Tweak
    - Signature Switch
    - Sync Kolab
    - Talkback
    - TB QuickMove Extension
    Alles aktuell.

  • Zitat

    Wenn ich aber das Absende-Konto ändere, ändert sich aber immer auch die Formatierung.


    Kannst du mir das mal näherer erklären?
    Alle deine Konten sind beim Senden auf HTML gestellt?
    Poste mal deine gemachten Einstellungen, damit ich die hier nachspielen kann.


    Grtuß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hallo mrb,


    danke Dir für Deine Geduld! Los geht's (ich hoffe, die Images kommen richtig an...):


    - 1 IMAP Konto (Postausgangsserver) mit 4 Identitäten. Alle verfassen HTML-Nachrichten und haben eine über den Signatur Switch zugeordnete Signatur (HTML und Rein-Text).


    - Einstellungen:


    - Und hier siehst Du was geschieht, wenn ich etwas schreibe:


    Reicht Dir das an Infos, oder benötigst Du noch weitere?

  • Hallo,
    warum stellst du das feste Breite nicht Verdana ein (im Menü Verfassen)? Verdana ist Proportionalschrift.
    Es gibt auch kein Arial mit fester Breite, auch wenn es so scheint.
    Feste Breite haben:
    Courier New, abgeleitet von der alten Courier (ebenfalls Festbreite). Andere
    sind: Andale Mono, Century Schoolbook Monospace (sieht klasse aus),
    Monospace 821 (mein Liebling), Orator, Lucida Console...
    Auf Windows Systemen gibt nur sehr wenige davon.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    bin mir nicht sicher, ob ich Dich richtig verstanden habe:


    Wenn ich in den Einstellungen > Verfassen > HTML-Optionen > Schriftart "Verdana" wähle und speichere, dann ist beim nächsten Aufruf des Menüpunkts - ohne, dass ich auch nur etwas anderes dazwischen aufgerufen oder geändert habe - "Variable Breite" eingetragen. Das hatte mich bisher irritiert, so dass ich diesen Versuch wohl nicht getestet hatte. Ich habe es jetzt, aufgrund Deines Hinweises, dennoch versucht mit folgendem (interessanten!) Resultat:


    - Mails unter dem Standard-Konto erreichen mich nun in der gewünschten "Verdana". (Danke! Damit bin ich schon deutlich weiter als bisher.)


    - Wechsel ich aber noch vor dem Schreiben der Nachricht die Identität des Kontos, ändert sich auch die Typo:


    Das ist doch skurriel! Allerdings bin ich einer Lösung meines Problems insofern näher gekommen, dass wenn ich die Nachricht fertig stelle und erst vor Versand die Identität ändere, alles wie gewünscht verschickt wird. Die Typo ändert sich dann zwar für den neuen, ungeschriebenen Text, der alte bleibt aber "richtig" formatiert.


    Ich kann damit leben - danke Dir für Deine Hilfe! Wenn Du noch eine Idee hast, dann teste ich sehr gerne weiter, um das Problem final zu lösen. Aber ich möchte Deine Geduld nicht unnötig auf die Probe stellen...

  • Hallo,
    danke für die Rückmeldung.
    Hast du das mal im Postausgang mal überprüft? (Statt "Senden" auf "Später senden" gehen [Dateimenü]).
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hi mrb,


    entweder finde ich den Punkt nicht, oder ich vermute vielmehr, dass ich ihn nicht habe, da ich per IMAP direkt auf dem Server arbeite.

  • Hallo,
    alle später gesendeten Mail landen im lokalen Postausgang, unabhängig ob IMAP oder POP. Das Versenden hat ja nichts mit IMAP zu tun.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Nicht ganz: ich habe meine Einstellungen so gewählt, dass die Kopie der versendeten Mail im Posteingang auf dem Server liegt.


    Aber ich habe mir beide angesehen - was ja Deine Frage war: sie sehen genauso aus, wie versendet (was ja auch i.O. ist, da ich Verdana für meine TB-Anzeige erzwinge. Aber: anbei ein Auszug des HTML-Quelltextes der beiden Testmails:


    1. korrekt:
    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    </head>
    <body bgcolor="#ffffff" text="#000000">
    <font face="Verdana">test<br>
    <br>
    <br>
    </font>
    <div class="moz-signature">-- <br>
    <title></title>


    2. inkorrekt:
    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    </head>
    <body bgcolor="#ffffff" text="#000000">
    test test test<br>
    <br>
    <div class="moz-signature">-- <br>
    <title></title>


    Mir fällt dazu nichts ein.

  • Hallo,

    Zitat


    Nicht ganz: ich habe meine Einstellungen so gewählt, dass die Kopie der versendeten Mail im Posteingang auf dem Server liegt.


    Im Postausgang ist sie aber noch gar nicht versendet, was danach passiert, ist eine andere Sache.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    ich wiederhole mich: wenn du eine Mail versendest, klicke nicht auf Senden" sondern im Dateimenü des "Verfassenfensters" - denn dort befindet man sich ja, wenn man eine Mail versendet, oder? -
    auf "später senden". Daduch gelangt eine Mail in den Postausgang und genau so wird die Mail auch versendet. Dort kann man also noch einmal in Ruhe seine Mails überprüfen und gegebenenfalls auch ändern (Rechtsklick, "Als neu bearbeiten".
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ah! Das war der entscheidende Hinweis, der mir zuvor gefehlt hatte:

    Zitat von "mrb"

    ...wenn du eine Mail versendest, klicke nicht auf Senden" sondern im Dateimenü des "Verfassenfensters" (...) auf "später senden"...


    Jetzt bin ich wieder bei Dir. Habe ich getan und die Mail geprüft. Keine Auffälligkeiten soweit - Reaktionen auf Veränderungen wie zuvor. Auf was sollte ich denn Deiner Meinung nach prüfen?

  • Hallo.
    na ja es geht doch bei dir auch darum, wie eine Mail bei Empfänger ankommt.
    Du schriebst ja,

    Zitat

    denn beim Testen kommt die versendete Mail auf Outlook in Times an


    entscheidend ist ja, welche Schriftart im Verfassenfenster erscheint.Diese Schriftart muss dann ja auch im HTML-Code sichtbar sein und genau das kann man per Quelltext (strg+U) im Postausgang überprüfen.
    Schreibe ich beispielsweise in Courier, steht im Quelltext: <font face="Courier">.
    Genau das liest Outlook und muss das dann auch richtig anzeigen.


    Welche Frage hast du also jetzt noch?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Naja, den HTML-Quellcode hatte ich Dir ja bereits geschickt. Dieser zeigt, dass eben nach Umstellen des Absendekontos das HTML geändert wurde - warum auch immer. Ich verstehe diese Reaktion von TB nicht und bin geneigt zu vermuten, dass dies ein Bug ist. Insofern habe ich auch keine Frage mehr, denn ein Workaround hat sich schließlich durch Deine Hilfe ergeben. Dieser löst zwar nicht den Bug, ermöglicht aber über Umwege den von mir erwünschten Effekt.


    Wie gesagt: danke für Deine Unterstützung! Falls Du keine weitere Idee hast, woran das liegen könnte, können wir das Thema beenden. Vielleicht ist der Bug ja in einer der nächsten Versionen von TB gefixt.

  • Hallo,
    nein, ist noch nicht beendet, denn ich muss dein Problem nachvollziehen können. Ist das bei mir genau so wie bei dir, könnte es ein Bug sein.
    Darum von vorne:
    Du gehst auf Verfassen, im Von-Feld steht eine deiner Mailadressen.
    Du klickst das Nachrichtenfeld an und es wird bspw. normaler Text, Courier angezeigt.
    Bisher OK?
    Jetzt wechselt du im Von-Feld die Mailadresse und dann steht dort eine andere Schriftart?
    Du hast wie viele Konten und wie viele Mailadressen? Die Konten sind global oder separat?
    Und du hast in den Einstellungen, Verfassen "Verdana " aktiviert?
    Und du hast unter Unter Extras, Einstellungen, Ansicht, Formatierung, Schriftarten und Kodierung dort unter "Sans Serif" ebenfalls Verdana stehen?


    Unter genau diesen Bedingungen ändert sich bei mir bei einem Identitäten-/Kontenwechsel die Schriftart nicht. Und warum das so ist, möchte ich gerne herausbekommen.
    Welche Add-ons sind installiert?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hi mrb,


    na dann, wie gewünscht, von vorne (freut mich, mich für Deine Hilfe revangieren zu können):

    Zitat

    Du gehst auf Verfassen, im Von-Feld steht eine deiner Mailadressen.
    Du klickst das Nachrichtenfeld an und es wird bspw. normaler Text, Courier angezeigt.
    Bisher OK?
    Jetzt wechselt du im Von-Feld die Mailadresse und dann steht dort eine andere Schriftart?


    Soweit, so richtig. Aus <Normaler Text - Verdana> wurde <Normaler Text - Verdana (standard)>, sobald ich in den Mailbody geklickt habe.


    Ich habe ein Hauptkonto, auf das ich per IMAP zugreife. Dieses Hauptkonto hat insges. vier Identitäten. Zu den Einstellungen s. weiter oben im Threat. Seltsam, wie bereits beschrieben, war allerding, dass ich unter Einstellungen > Verfassen > Allgemein > HTML-Optionen > Schriftart auf Dein Hinweis "Verdana" eingestellt habe, dies sich durch das System aber wieder nach dem Schließen und wieder Öffnen auf "Variable Breite" geändert hatte.


    Die restlichen Anmerkungen stimmen ebenfalls. AddOns hatte ich ja (ebenfalls weiter oben) schon dargestellt, wobei ich inzwischen Signature Switch wieder deaktiviert habe, da es nicht das brachte, was ich erhofft hatte. Entsprechend habe ich zu jeder Identität eine HTML-Signatur angelegt, die aktuell noch fälschlicherweise komplette HTML-Syntax (Titel- und Meta-Tags) beinhaltet.


    Soweit so gut?

  • Re: HTML-Schriftart beim Empfänger bestimmen


    Zitat

    Dein Hinweis "Verdana" eingestellt habe, dies sich durch das System aber wieder nach dem Schließen und wieder Öffnen auf "Variable Breite" geändert hatte.


    Ist bei mir ebenfalls so. Ändert aber nicht das Ergebnis.
    Du hattest die entspr. Option in Mail-Tweak deaktiviert, die könnte ja immer dazwischenfunken.

    Zitat

    Entsprechend habe ich zu jeder Identität eine HTML-Signatur angelegt, die aktuell noch fälschlicherweise komplette HTML-Syntax (Titel- und Meta-Tags) beinhaltet.


    Das ist der einzige Punkt, der bei mir anders ist. Könnte du die mal testweise alle ausschalten?
    Hattest du die Signaturen in TB selbst erstellt?
    Denke daran die entspr. Einstellungen Unter Extras, Einstellungen, Ansicht, Formatierung, Schriftarten und Kodierung zu machen. Sans Serif ist für HTML zuständig.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw