Thunderbird portable startet nicht

  • Guten Morgen,
    ich habe seit ein paar Tagen ein erhebliches Problem, und hoffe auf etwas Hilfe hier... :) 
    Ersteinmal zum System. Mein Rechner läuft unter Win XP SP2+3.
    Ich benutze Thunderbird portable von einem USB-Stick (8 GB) aus, was den Vorteil hat, daß ich den Stick von mehreren Rechnern aus nutzen kann, mein Emailbüro somit immer bei mir habe und später nicht mühsam synchronisieren muß.
    Das Thunderbird auf dem Stick hat die Version 2.0.0.23 (20090812), ich nutze noch diese ältere Version, weil ich das Add-On 'Lightning' nutze und darauf nicht verzichten will. Lightning läuft aber wohl nicht mit der neuen Version. Bis jetzt hat mein Thunderbird auch zuverlässig gearbeitet und sehe keinen Bedarf.
    Nun zum Problem. Seit ein paar Tagen passiert beim Versuch Thunderbird zu öffnen folgendes: zuerst erscheint, wie gewohnt, das TB-Logo, dann öffnet sich die Programmoberfläche bleibt aber inhaltlich leer und ich bekomme die Fehlermeldung:


    "thunderbird.exe hat ein Problem festgestellt und muß geschlossen werden" (oder so ähnlich),


    nach Bestätigung von 'OK' schließt sich die Programmoberfläche und das wars. Am USB-Stick kann es nicht liegen, den habe ich mit 'Flash Drive Tester' gecheckt und der ist ok. Ich habe dann anschließend eine Sicherungskopie gemacht, den USB-Stick entfernt und an einem anderen Rechner ausprobiert (ebenfalls XP SP2-3). Dort lief Thundebird portable auch bei mehrmaligem Öffnen einwandfrei. Zurück auf dem anderen Rechner war wieder nichts zu machen. Dann habe ich den Rechner heruntergefahren, ein paar Minuten gewartet, und wieder hochgefahren und der Donnervogel arbietete wie gewohnt! Und das geht jetzt seit ein paar Tagen so. Manchmal reicht ein Neustart, manchmal muß ich den Rechner mehrmals runter- und wieder hochfahren, um Thunderbird zum arbeiten zu bewegen.
    Das einzige was ich noch in Erfahrung bringen konnte, sind die Fehlerprotokolle in der Ereignisanzeige (Anwendungsfehlereinträge):


    "Fehlgeschlagene Anwendung thunderbird.exe, Version 1.8.20090.15674, fehlgeschlagenes Modul ntdll.dll, Version 5.1.2600.5755, Fehleradresse 0x0001b21a."


    Vielleicht hat irgendwer hier ein paar hilfreiche Tipps, was ich tun kann, um den "Normalzustand" wiederherzustellen?
    Vielen Dank schon mal!

  • Nachtrag:


    Nachdem nun heute TB-portable auch nicht mehr in Gang zu setzen war, weder auf dem Zweitrechner unter XP, noch auf dem Notebook unter Vista, und nachdem leider auch hier niemandem etwas einegfallen ist, habe ich etwas experimentiert.
    Ich habe in regelmäßigen Abständen TB-portable so gesichert, daß ich das komplette Programm inklusive aller Dateien in Ordner auf einer externen Festplatte kopiert habe, also quasi den kompletten Inhalt des USB-Sticks (den nich auch nur für TB benutze). Da geht ja, und ich konnte theoretisch (und praktisch! - habs ja ausprobiert :) ) TB dann auch von dieser Festpaltte aus starten. So habe ich einiges an Versionen des TB-port. auch aus der Zeit, bevor diese Probleme aufgetreten sind. Und gestern habe ich, als TB vom Stick noch lief und ich die letzten Mails abgeholt habe, ebenfalls eine Sicherung gemacht.
    Nun habe ich auf der Festplatte einen Ordner eingerichtet, in den ich von der externen Platte eine ätere Sicherung von TB (vor dem Auftreten der Probleme) reingespielt habe. Dort habe ich dann den Inhalt des "profile" Ordners (ThunderbirdPortable\Data\profile) komplett gelöscht und den Inhalt des "profile"-Ordners aus der gestrigen letzten aktuellen Sicherung reinkopiert.
    Anschließend habe ich den USB-Stick komplette Formatiert und den vorher so aus beiden Sicherungen kreierten "neuen" Thunderbrid-portable aufgespielt. Und siehe da - jetzt funzt TB-port. wieder normal - und zwar auf allen Rechnern!


    Das Problem schein somit behoben, und dennoch möchte ich diesen Thread nicht abschließen, in der Hoffnung, daß sich doch noch ein "Spezialist" findet, der rausfinden kann, was eigentlich passiert ist. Klar scheint folgendes: es liegt nicht an den "Host-Rechnern", es liegt nicht am USB-Stick, und es liegt auch nicht an den Inhalten des "profile"-Ordners (übrigens habe ich auch vorher den Stick auf Viren gescannt - ohne was zu finden). Eine erfolgreiche Fehleranalyse wäre nicht zuletzt hilfreich, um in Zukunft solche Widrigkeiten zu vermeiden.
    Allen TB-portable-Usern kann ich nur wärmstens empfehlen, Backups zu machen - lieber zu viele, als zu wenige! Bei den Kapazitäten externer Platten ist das auch kein Problem.

  • Hallo,

    Zitat

    Anschließend habe ich den USB-Stick komplette Formatiert


    Wobei nicht auszuschließen ist, dass es doch am Stick lag.
    Die Laufwerksbuchstaben waren in allen Fällen gleich?
    Manchmal behandelt Windows USB-Sticks wie feste Laufwerke, auch das kann ein Problem sein.
    Weiterhin ist zu bedenken, dass nie ein normaler TB und ein pTB gleichzeitig laufen dürfen, da dann Registry-Einträge nicht mehr gelöscht werden und u.U. versucht wird, von einem normalen TB zu starten.
    Hast du in deinem Dokumenten/Anwendungsorder/Thunderbird/Profiles eine Datei profiels.ini?
    USB-Sticks sind - wie du gut erkannt hast - keineswegs eine 100%ig sichere Sache. Mir sind schon mehrere kaputt gegangen. Aber das kann einem Computer auch passieren.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw