Problem beim importieren von öffentlichen PGP Keys

  • Hallo,


    beim Importieren von öffentlichen PGP Keys bekomme ich folgende Fehlermeldung:


    OpenPGP-Meldung
    Speichern det Schlüssel fehlgeschlagen
    gpg: Schlüssel 6BF5C935: Keine gültigen User-IDs
    gpg: dies könnte durch fehlende Eigenbeglaubigung verursacht worden sein
    gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
    gpg: ohne User-lOt 1


    Mit der Meldung komme ich nicht weiter. Vielleicht kennt jemand das Problem.
    Verschlüsseln, signieren und senden von Nachrichten funktioniert problemlos.
    Ich verwende W7 64-bit, TB 3.0.4, Enigmail 1.0.1,


    Grüße
    Dieter

  • Hallo,


    ist das die gesamte Fehlemeldung? Wie willst Du den Schlüssel importieren (Server, Datei)? Zufällig Hushmail? Und was sagt OpenPGP->Fehlersuche->Konsole anzeigen?


    Karla

  • Der zu importierende Schlüssel liegt als Datei vor oder direkt aus einer Mail, egal das Ergebis ist immer das gleiche.
    Allerdings habe ich nur diesen einen öffentlichen Schlüssel. Mit einem anderen habe ich's noch nicht versucht.


    Die openPGP Konsole sagt folgendes:


    enigmail> C:\Program Files (x86)\GNU\GnuPG\pub\gpg.exe --charset utf8 --batch --
    no-tty --status-fd 2 --import D:\Dieter\EIGENE~2\Computer\SECURI~1\Z0001V~1.ASC
    gpg: Schlüssel 6BF5C935: Keine gültigen User-IDs
    gpg: dies könnte durch fehlende Eigenbeglaubigung verursacht worden sein
    gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
    gpg: ohne User-ID: 1


    enigmail> C:\Program Files (x86)\GNU\GnuPG\pub\gpg.exe --charset utf8 --batch --
    no-tty --status-fd 2 --with-fingerprint --fixed-list-mode --with-colons --list-k
    eys



    enigmail> C:\Program Files (x86)\GNU\GnuPG\pub\gpg.exe --charset utf8 --batch --
    no-tty --status-fd 2 --with-fingerprint --fixed-list-mode --with-colons --list-s
    ecret-keys

  • Hallo,
    kann es sein, daß der Schlüssel uralt ist, oder aus PGP (nicht GnuPG) stammt?
    Woher stammt der Schlüssel? Falls der Besitzer nichts dagegen hat, kannst du ihn ja einfach mal auf einen Schlüsselserver hochladen, zur allgemeinen "Begutachtung".
    Oder der Besitzer signiert seinen Schlüssel ordnungsgemäß, falls er das nicht getan hat (in neueren Versionen dürfte dasPflicht sein).
    Ansonsten ist ein Versuch mit gpg.exe auf der Kommandozeile vielleicht erfolgversprechender?


    Code
    1. <Pfad>gpg.exe --import <dateiname> --allow-non-selfsigned-uid


    ...oder mit der Option --pgp2 (oder --pgp6 oder womit auch immer der Schlüssel erzeugt wurde)
    Evtl. gibt es weitere Optionen, diesen Fehler zu ignorieren oder zu umgehen, sicher hast du irgendwo eine Hilfedatei oder etwas ähnliches zu GnuPG - unter Linux gibt man im Zweifelsfalle "man gpg" ein...
    Gruß, muzel

  • Danke für die Info. Der betreffende öffentliche Schlüssel wurde mit PGP V3 erstellt. Mittlerweile konnte ich andere öffentliche Schlüssel importieren. Es liegt wohl an der fehlenden Selbstbeglaubigung.
    Das vorgeschlagene Kommado kennt offensichtlich (in meiner Version) die Option nicht. Es kommt die Meldung:"gpg: '--allow-non-selfsigned-uid' kann nicht ge÷ffnet werden: Invalid argument".
    Die gpg Doku gibt für den --import Befehl keine weiteren Optionen an, so werde ich es wohl dabei belassen müssen.


    Grüße
    Dieter

  • Na gut, die Reihenfolge der Paramater spielt wohl eine Rolle, richtig wäre gewesen

    Code
    1. gpg --allow-non-selfsigned-uid --import <Dateiname>

    Gruß, muzel

  • Hallo,


    grundsätzlich kann ich leider da auch nicht mehr sagen.


    Mir ist es jedoch noch nie passiert, daß ich einen PGP-Schlüssel nicht importieren konnte.
    Und da ich sozusagen 'von PGP komme', denke ich daß ich schon eine Weile Erfahrung (auch mit älteren Vesionen) habe. :nixweiss:


    {Nur mal als Frage: Läßt sich der key denn unter PGP importieren? Haben andere user das gleiche Problem?}


    MfG ... Vic

  • Zitat von "muzel"

    Na gut, die Reihenfolge der Paramater spielt wohl eine Rolle, richtig wäre gewesen

    Code
    1. gpg --allow-non-selfsigned-uid --import <Dateiname>

    Gruß, muzel


    Ja, mit der Reihenfolge geht's. Der Schlüssel ist dann importiert. Verwenden kann ich ihn allerdings nicht. Beim Verschlüsseln kommt wieder die Meldung mit der fehlenden Eigenbeglaubigung.


    Grüße
    Dieter


  • Es handelt sich dabei um den öffentlichen Schlüssel meiner Firmenadresse. Mit der PGP-Software (Secude) die ich dort zur Verfügung habe, kann ich m.W. keine Eigenbeglaubigung durchführen. Ich werde mal versuchen einen anderen Schlüssel der von der gleichen Stelle erstellt wurde zu importieren.
    Mit meiner "alten" PGP Software konnte ich den Schlüssel übrigens importieren. Die legte offensichtlich keinen Wert auf Eigenbeglaubigung.


    Grüße
    Dieter

  • Zitat

    Beim Verschlüsseln kommt wieder die Meldung mit der fehlenden Eigenbeglaubigung.

    Dann mußt du auch da diesen Parameter verwenden - entweder fest verdrahten in der gpg.conf oder unter OpenPGP-Einstellungen - Erweitert - zusätzliche Parameter. Gilt natürlich dann global und ist möglicherweise ein Sicherheitsrisiko.

    Zitat

    Mit der PGP-Software (Secude) die ich dort zur Verfügung habe, kann ich m.W. keine Eigenbeglaubigung durchführen.

    Sicher? Das wäre aber armselig.
    Hast du denn den geheimen Schlüssel?
    Gruß, muzel

  • Zitat von "diku"


    Mit meiner "alten" PGP Software konnte ich den Schlüssel übrigens importieren. Die legte offensichtlich keinen Wert auf Eigenbeglaubigung.


    Widerspricht das nicht dem eigentlichen Prinzip? Die Beglaubigungen sind doch der Hauptbestandteild er ganzen Geschichte.