Google Kalender synchronisiert nicht - Modification failed

  • Hallo,


    nachdem ich nun x. Mal den Addon Provider für Googlekalender runtergeladen habe bin ich am verzweifeln.


    Ich kann über "Extras" und "Add ons" diese .xpi Datei nicht sehen... WARUM?


    Ich flippe gleich aus, wenn ich nicht bald den Kalender mit Thunderbird zusammenkoppeln kann. Jedes Mal kommt der Fehler "Modification failed", wenn ich einen Termin eintrage.


    Bei mir fehlt einfach beim Erstellen eines neuen Kalenders diese Schaltfläche für den Google Kalender....



    Hilfe :(

  • Hallo yellowcat,


    um das Add-on zu installieren musst du natürlich auf den Pfad gehen, auf dem es nach dem Download liegt. Aber das wirst du vielleicht schon gemacht haben. Ansosnten kann ich dir nicht weiter helfen.


    Aber ich habe mich auch mit der Synchronisation beschäftigt und bin zu folgender Teil-Lösung gekommen:
    Zunächst zu meinen Systemen: Büro: W XP mit TB 3.1.16 / Zuhause: Ubuntu 10.04 mit TB 3.1.10, beides mit dem jewils aktuellstem Lightning.
    Auf dem Ubuntu-Rechner klappt die Synchronisation über folgenden Weg sehr gut, d.h. die Kalender ließen sich in beiden Richtungen synchronisieren (ich zitiere mal aus einem anderen Forum, wenngleich das in den Foren verpönt ist - aber für mich was das hilfreich):



    Incendium:
    Die Synchronisation zwischen Google Calendar und meinem Thunderbird 3.0.2 mit Lightning 1.0b1 funktionierte auf Anhieb problemlos. Folgende Dinge sind dabei zu beachten:
    Im Thunderbird:
    -> "Neuer Kalender..." auswählen
    -> im "Neuen Kalender erstellen" Dialog
    -->"Im Internet" auswählen und auf "Weiter" klicken
    --> "CalDAV" auswählen, wenn man sowohl lesen als auch schreiben möchte. (WICHTIG: iCalendar kann nur lesen, aber nicht nach Google Calendar schreiben!)
    --> Adresse: "https://www.google.com/calendar/dav/[ID]/events" eintragen, wobei die ID folgendermaßen ermittelt wird:
    ---> In Google Calendar neben dem entsprechenden Kalender auf den kleinen "Pfeil nach unten" klicken und "Kalendereinstellungen" auswählen
    ---> Unter "Kalenderadresse" steht die entsprechende ID neben den drei Buttons XML ICAL HTML in Klammer mit dem Text "Kalender-ID:" (Hinweis: Lasst euch nicht irritieren, weil da steht, dass dieser Link nur funktionieren würde, wenn der Kalender freigegeben wäre. Das trifft zwar auf die Links hinter den drei Buttons zu, nicht aber auf die Kalender-ID.)
    ---> Die ID also einschließlich "@group.calendar.google.com" anstelle von [ID] in den obigen Link einfügen (das sieht dann z.B. so aus: https://www.google.com/calenda…alendar.google.com/events). ACHTUNG: Die ID für den primären Kalender in Google Calendar ist die E-Mail-Adresse von Google Mail, die natürlich auf "@googlemail.com" endet und nicht auf "@group.calendar.google.com".
    --> im "Neuen Kalender erstellen" Dialog von Thunderbird auf "Weiter" klicken
    --> Unter "Name" einen beliebigen Name für den Kalender eintragen (Hinweis: Dieser Name gilt nur in Thunderbird und wird nicht in Google übernommen.)
    --> Eine "Farbe" für die Kalendereinträge auswählen (Hinweis: Dies gilt auch nur für Thunderbird.)
    --> Ggf. den Haken bei "Erinnerungen anzeigen" setzen (Hinweis: Dies gilt auch nur für Thunderbird.)
    --> Bei "E-Mail" trägt man sinnvollerweise seine Google-Mail-Adresse ein, muss man aber nicht.
    --> Auf "Weiter" und anschließend auf "Fertigstellen" klicken.
    -> In Thunderbird kann man die gerade gemachten Einstellungen mit einem Rechtsklick auf den neuen Kalender mit "Einstellungen" einsehen und alles bis auf die Adresse ändern. Wenn man nur aus Google lesen möchte, dann kann man den Kalender in diesen Einstellungen auch als "Schreibgeschützt" markieren.


    Jetzt ist der Kalender eingerichtet und kann verwendet werden (sowohl lesend als auch schreibend). Diesen Vorgang muss man dann für jeden Kalender, den man hinzufügen möchte, wiederholen.


    Quelle: http://www.google.com/support/…id=53c1a02bf50238d4&hl=de


    Die von dir beschriebene Fehlermeldung kam bei mir auch am Anfang, aber nach einem Neustart von TB kam sie nicht mehr.


    Das Problem für mich ist jetzt noch - deshalb sprach ich von einer Teil-Lösunng - dass ich es noch nicht mit meinem Büro-Rechner hinbekommen habe, obwohl ich genauso vorgegangen bin, wie beschrieben.
    Hier habe ich das Problem, dass mir nach Einrichtung eines Netz-Kalenders mit den beschriebenen Parametern alle vorhandenen Kalender in der von mir am liebsten genutzten mehrwöchigen Ansicht auf einmal nicht mehr sicht bar sind.
    Ich habe noch nicht rausbekommen, woran das liegt.


    Kann da vielleicht jemand helfen?


    Gruß
    Radler

  • Hallo yellowcat,


    hier noch eine Ergänzung:


    Auf meiner Windows-Kiste klappt es nun auch mit der Synchronisation:

    Add-on "Provider für Google Kalender 0.7.1" installiert


    neuen Kalender angelegt "im Netzwerk" -> Weiter Option "Google-Kalender" ausgewählt


    in die Adresszeile dann die Link-Adresse aus der Eigenschaft des ausgewählten Google-Kalenders, die mit dem ICAL-Button angezeigt wird, eingefügt.


    Manchmal fragte er mich dann auch noch nach einem Benutzernamen und Passwort. Hier musst du die Zugangsdaten für dein Google-Konto eingeben


    Die Eigenschaften im Kalender (Name, Farbe etc.) ausgewählt und dann auf Fertig gedrück.


    Dann kam zwar manchmal auch noch diese "Modification failed"-Meldung, die habe ich einfach immer mit o.k. bestätigt und dann hat es funktioiniert. Wenn es mal mit einem Kalender nicht funktioniert hat, habe ich ihn kurzerhand noch mal gelöscht und neu angelegt.


    Im Google-Kalender musst du dann zunächst das Browser-Fenster aktualisieren, dann übernimmt er die Daten aus Deinem TB-Kalender.


    Noch ein Tip, wie Du einen lokalen Kalender in den Netz-Kalender bekommst.
    Ich habe einfach meine lokalen Kalender als ics-Datei irgendwohin exportiert und dann wieder in die entsprechenden Google-Netzkalender importiert. Funktionierte wunderbar. Jezt habe ich es so, wie ich es wollte.


    Gruß Radler.


    P.S.: Wenn Dir das geholfen hat, dann setze den Thread bitte auf [gelöst]